none
Проблема после установки апдейтов SharePoint Server 2010 SP1 + June CU RRS feed

  • Вопрос

  • Приветствую! Поставили на боевом сервере SP1 и июньский пакет апдейтов.

    Появилась проблемка - те пользователи, которые раньше редактировали профили пользователей через mysites (у них стоит разрешение "Управление профилями"), теперь не могут загружать фотографии пользователей, при этом остальную информацию в профилях менять могут.

    Возникает ошибка "Ошибка при сохранении рисунка. Повторите попытку позже".

    При этом данной ошибки не возникает при редактировании только собственного фото пользователя.

    В ULS толковых подробностей об ошибке не нашел.

    Заранее благодарю за ответы!




Ответы

  • На сайте http://stefvanhooijdonk.codeplex.com/releases/view/41749 есть утилитка SharePoint2010.ProfilePicturesLoader в виде c# проекта (если не ошибся). Для русской версии SharePoint в исходном проекте SharePoint2010.ProfilePicturesLoader.zip
    list.Title == "User Photos" заменил на
    list.Title == "Фотографии пользователя"

    После сборки проекта эта утилитка нормально грузит фотки пачками. Мне понравилась. Запускать .exe на серваке.

    • Помечено в качестве ответа Roman Zhukov 1 августа 2011 г. 11:00
    26 июля 2011 г. 11:52

Все ответы

  • Хотелось бы добавить о проблемах после апдейта. 

    На портале в разделе задачи. В списке с группированием задач, раскрываю активные задачи, редактирую задачу и после редактирования ни одна группа не раскрывается. Помогает только перезапуск браузера. Помогите вылечить это!

    • Предложено в качестве ответа Сердюков Евгений 11 июля 2011 г. 6:13
    • Помечено в качестве ответа Roman Zhukov 11 июля 2011 г. 10:46
    • Снята пометка об ответе Andrey Myasnikoff 12 июля 2011 г. 11:34
    • Помечено в качестве ответа Andrey Myasnikoff 12 июля 2011 г. 11:35
    • Снята пометка об ответе Andrey Myasnikoff 12 июля 2011 г. 11:35
    • Отменено предложение в качестве ответа Andrey Myasnikoff 12 июля 2011 г. 11:35
    11 июля 2011 г. 5:04
  • Спасибо, Алексей, а не мог бы куда-нибудь залить файлики английской версии?

    А то у меня русская инсталяция Шарепоинт, в папке 14\TEMPLATE\LAYOUTS\1033 вообще скриптов нет.

    12 июля 2011 г. 11:28
  • О спасибо, замена 4 файлов из папки 1033 в папку 1049 у меня сработало!

    Еще бы с фотографиями теперь разобраться! Ни у кого такой проблемы не наблюдается?


    12 июля 2011 г. 13:09
  • Проблема так и не устранена.

    Нашлись те, у которых такая же проблема.

    http://social.technet.microsoft.com/Forums/en-us/sharepoint2010setup/thread/fe943f7f-0f8e-4383-8ec7-9aa0a439f0fb

    25 июля 2011 г. 5:44
  • На сайте http://stefvanhooijdonk.codeplex.com/releases/view/41749 есть утилитка SharePoint2010.ProfilePicturesLoader в виде c# проекта (если не ошибся). Для русской версии SharePoint в исходном проекте SharePoint2010.ProfilePicturesLoader.zip
    list.Title == "User Photos" заменил на
    list.Title == "Фотографии пользователя"

    После сборки проекта эта утилитка нормально грузит фотки пачками. Мне понравилась. Запускать .exe на серваке.

    • Помечено в качестве ответа Roman Zhukov 1 августа 2011 г. 11:00
    26 июля 2011 г. 11:52
  • Алексей, спасибо за workaround=)
    27 июля 2011 г. 5:28
  • После установки последних указанных обновление на русскую версию SP 2010 мало то, что возникают проблемы с группировкой, также пропали значки панели расширенного форматирования текста, например, в поле "Описание" в задачах. Есть ли решение?


    Создал тему по этой ошибке здесь.
    29 августа 2011 г. 6:47
  • Мне интересно, у меня стоит просто SP1. CU June 2011 я не ставил. Его стоит ставить? Не прибавится ли проблем и ошибок? 

    У меня с группировкой тоже проблемы. Чтобы заработал верхний RibbonBar необходимо нажать F5. После добавления задачи например, не появляется скрол. Короче куча проблем... Жаль что я не сделал бекап перед sp1, думал что таких проблем не будет :(:(

    29 августа 2011 г. 8:09
  • О да, а я только сейчас заметил - у меня тоже самое!(( Я в шоке от Майкрософта...
    30 августа 2011 г. 7:53
  • Так что никаких обновлений не предвидится чтобы устранить все проблемы с sharepoint? 
    1 сентября 2011 г. 11:58
  • У меня значки расширенного форматирования текста пропали не после устанвоки обновлений, а после того, как я поставил себе INIT.js из 1033.

    Группировка при этом починилась, а значки - поламались. Когда вернул родной INIT.js из 1049 - все стало как было - группировка поломалась, значки - починились.
    Вот теперь сужу и думаю - какое зло меньше. :(


    1 сентября 2011 г. 12:02
  • Да, я тоже ставил EN версию, похоже, что после этого значки и ломаются.

    1 сентября 2011 г. 12:24
  • Да, я тоже ставил EN версию, похоже, что после этого значки и ломаются.


    1 сентября 2011 г. 12:25
  • А никто не пробовал объединить два init.js чтобы работала и группировка и значки??
    1 сентября 2011 г. 13:06
  • После устанвки августовского обноления - у меня все стало нормально  и группировка и иконки.

    Пока других глюков не заметил.

    Августвокие обновления качал отсюда:

    http://blogs.technet.com/b/stefan_gossner/archive/2011/09/07/august-2011-cu-for-sharepoint-2010-has-been-released.aspx

     


    19 сентября 2011 г. 7:33
  • После устанвки августовского обноления - у меня все стало нормально  и группировка и иконки.

    Пока других глюков не заметил.

    Августвокие обновления качал отсюда:

    http://blogs.technet.com/b/stefan_gossner/archive/2011/09/07/august-2011-cu-for-sharepoint-2010-has-been-released.aspx

     


    А устанавливать их надо на June CU? Или можно сразу на SP1? У меня установлено только SP1.

    19 сентября 2011 г. 7:36
  • Если коротко - то да, сразу поверх SP1, без June CU.

    Я у себя делел и так и так. - На тестовой среде - через June CU, на боевой - сразу на SP1.

     

    А дальше - возникают нюансы. Так как у меня + Project Server + Language Pack + WebApps - у меня возникала путанница с последовтаельнустью установки обновлений на все это хозяйство.

    В интернете было нескольк статей на тему - как это делать правильно.

    Вот например http://blogs.technet.com/b/office2010_ru/archive/2011/09/07/office-web-apps-1-sp1-sharepoint-server-2010.aspx
    http://blogs.msdn.com/b/opal/archive/2011/06/30/the-mystery-behind-sharepoint-2010-patching.aspx

    19 сентября 2011 г. 7:48
  • Спасибо! Мне помогло. Устанавливал поверх SP1. 
    19 сентября 2011 г. 9:17
  • А что по поводу загрузки фотографий в профили после установки August CU? И не обнаружились ли новые косяки после установки обновления?=)
    21 сентября 2011 г. 6:31
  • Попробовал - фотографии в профиль обычным пользователем загрузились нормально.

    Каких то явных косяков пока не вижу. Прячутся наверное. :)

    21 сентября 2011 г. 6:51
  • А может и не помогло. Также пропадает сролл, панель редактирования элементов не появляется.... 
    21 сентября 2011 г. 9:40
  • Еще вот вышел хотфикс конкретно для исправления косяка с группировкой - http://support.microsoft.com/default.aspx?scid=kb;EN-US;2553117

    Здесь пишут, что помогает. У меня стояли английские версии файлов .js, поставил хотфикс на тестовом серваке, после установки менюшки стали русские, группировка работает. Но баг с расширенным текстбоксом не исчез. Вот думаю теперь, может надо было файлики .js сначала на родные заменить до фикса или бестолку...

    На продакшн пока не ставил.

    23 сентября 2011 г. 6:04
  • Евгений! What is "сролл"? Какая панель редактирования имеется ввиду?
    23 сентября 2011 г. 6:12
  • А может и не помогло. Также пропадает сролл, панель редактирования элементов не появляется.... 


    Тут на одной ферме заметил интересный эффект  - в консоли администрирования, в информации об установленных обновлениях - все нормально, состояние баз - обновление не требуется, а группировка - не работает. Окзалось, файл INIT.js оказался по какой то причине не обновленным. Тупо скопировал его с фермы где все обноления установлись нормально  - вроде работает.

    У себя проблем со скролом и и панелью редактирования - не наблюдаю, все нормально.


    • Изменено Mike_Tarasov 23 сентября 2011 г. 6:16
    23 сентября 2011 г. 6:14
  • Mike, А можешь поделится своим Init.js? Или его тупо скопировать с англ версии на русскую? Или может надо ставить language pack для августовского хотфикса? 

    У меня прошло обновление, показывает что базы не требуют обновлений, в реестре версия сходится с тем, что пишут в этом хотфиксе, а проблемы со скроллом, и панелью редактирования не прошли.

    Андрей, "сролл" - это опечатка. Имеется ввиду "скролл". Когда заходишь в задачи, то скрол не работает, выбираешь любую задачу и сверху не появляется панель с кнопками, создать, изменить и т.д. 

     

    23 сентября 2011 г. 6:21
  • Вот мой INIT.js с которым у меня все работает - https://skydrive.live.com/#!/?cid=66c8f72332cf14a5&sc=documents&uc=1&id=66C8F72332CF14A5%21393

    23 сентября 2011 г. 6:35
  • Вот мой INIT.js с которым у меня все работает - https://skydrive.live.com/#!/?cid=66c8f72332cf14a5&sc=documents&uc=1&id=66C8F72332CF14A5%21393

    У меня с Вашим файликом проблема не исчезла :(. Открыл свои задачи, группировка работает, сверху панель появилась когда я выделил задачу, нажимаю изменить, появляется окошко сверху панель полностью вся недоступна, доступны только снизу кнопки. Изменяю задачу, нажимаю сохранить, сохраняет, потом группировка не раскрывается, скролл не работает, верхняя панель тоже. :(

    Еще вот вышел хотфикс конкретно для исправления косяка с группировкой - http://support.microsoft.com/default.aspx?scid=kb;EN-US;2553117

    Андрей, мне кажется этот хотфикс включен был в CU August 2011, и устанавливать я его не хочу. У него даже версия меньше нежели у CU. 

    UPD: после F5 все работает, но опять сохраняю задачу - и опять не работает. Такое ощущение что какой то скрипт не подключается после postback'а...


    23 сентября 2011 г. 6:47
  • Евгений,  да, думаю, действительно вошел. Просто по опыту косяков июньских обновлений августовкие просто так боязно ставить, нужно подробно тестить сначала. 

    23 сентября 2011 г. 6:58
  • Евгений,  да, думаю, действительно вошел. Просто по опыту косяков июньских обновлений августовкие просто так боязно ставить, нужно подробно тестить сначала. 

    Так косяки то принес SP1, который через центр обновлений был доступен! Я вообще не ожидал что будут такие косяки! Теперь то выхода нету, как ставить все обновления, которые выходят, с надеждой что исправят косяки. Я привык что то что через центр обновлений, все оттестировано, все надежно и т.д. вот и не делал бекап перед обновлением и пожалел. Так бы остался без SP1 и жил бы спокойно :)
    23 сентября 2011 г. 7:02
  • Так косяки то принес SP1, который через центр обновлений был доступен! Я вообще не ожидал что будут такие косяки! Теперь то выхода нету, как ставить все обновления, которые выходят, с надеждой что исправят косяки. Я привык что то что через центр обновлений, все оттестировано, все надежно и т.д. вот и не делал бекап перед обновлением и пожалел. Так бы остался без SP1 и жил бы спокойно :)
    Вообще все жалуются на косяки именно после June CU. То, что Вы описывали по поводу скроллинга и риббона, у меня такого нет. Вы копались в англоязычных форумах, создавали ветку про свои проблемы? Если нет, то советую, может кто-то встречал то же, что и у Вас.
    23 сентября 2011 г. 7:16
  • Евгений,

    На всякий случай выкладываю всю свою папку Layouts. Сравните файлы - может где-то еще есть отличия.

    https://skydrive.live.com/#!/?cid=66c8f72332cf14a5&sc=documents&uc=1&id=66C8F72332CF14A5%21393

    Другой вариант - может уже быстрее по времени будет сделать чистую инсталяцию SharePoint со всеме обновлениями и подключить к ней существующие базы контента?
    Можно для пробы сделать коипю баз контента и паралельно поднять портал на виртуалке.

    Честно говоря, наобжигавшись, я теперь все портальные обноления сначала гоняю на тестовой зоне, которая является точной копией боевой.

    Ну и разработчикам сделал третью ферму.

    23 сентября 2011 г. 7:23
  • Так косяки то принес SP1, который через центр обновлений был доступен! Я вообще не ожидал что будут такие косяки! Теперь то выхода нету, как ставить все обновления, которые выходят, с надеждой что исправят косяки. Я привык что то что через центр обновлений, все оттестировано, все надежно и т.д. вот и не делал бекап перед обновлением и пожалел. Так бы остался без SP1 и жил бы спокойно :)
    Вообще все жалуются на косяки именно после June CU. То, что Вы описывали по поводу скроллинга и риббона, у меня такого нет. Вы копались в англоязычных форумах, создавали ветку про свои проблемы? Если нет, то советую, может кто-то встречал то же, что и у Вас.

    Нет, не пробовал. Я вот думаю попробовать на тестовой машине поставить все заново и базы поключить. Может заработает... 

    Я заметил что у меня разный набор скриптов подключается после сохранения задачи. Например нету sp.ribbon.js. Он просто не подключается...  Нажимаю F5, он есть. 


    23 сентября 2011 г. 7:27
  • Хочу предложить вариант решения проблемы с добавлением фото пользователей...

    У меня лично проблема появилась внезапно, никаких обновлений перед этим не устанавливал - последнее стоит апрельское. Если при добавлении фото пишет ошибку, я открывал это фото в стандартном Paint, потом ничего не меняя "Сохранить как" - выбирал тип "jpg" и записывал его поверх старого. после этого фото нормально уходит в SharePoint. Смысл сего действия не нашел - размер тот же, атрибуты не меняются, но тем не менее работает...

    • Предложено в качестве ответа Spektr_07 27 ноября 2011 г. 10:30
    24 ноября 2011 г. 18:59
  • Евгений,

    Другой вариант - может уже быстрее по времени будет сделать чистую инсталяцию SharePoint со всеме обновлениями и подключить к ней существующие базы контента? 

    Сделал. После инсталляции заметил что проблемы остались в хроме. В ие9 все работает как надо.

    9 января 2012 г. 7:19