none
Использование TLS 1.2 - вечная проблема RRS feed

  • Общие обсуждения

  • ДОл.....й мелкософт, даже написание этой стаьи не удалось с первого раза, сайт сказал sorкy.... мать еего...

    короче, СУТЬ

    Exchange 2016 DAG

    везде включен tls 1.0-1.2

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client]
    "DisabledByDefault"=dword:00000000
    "Enabled"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server]
    "Enabled"=dword:00000001
    "DisabledByDefault"=dword:00000000
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client]
    "DisabledByDefault"=dword:00000000
    "Enabled"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Server]
    "Enabled"=dword:00000001
    "DisabledByDefault"=dword:00000000
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2]
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
    "DisabledByDefault"=dword:00000000
    "Enabled"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]
    "Enabled"=dword:00000001
    "DisabledByDefault"=dword:00000000

    в т.ч. для .NetFraemwork 2 and 4

    согласно статье.

    https://techcommunity.microsoft.com/t5/exchange-team-blog/exchange-server-tls-guidance-part-1-getting-ready-for-tls-1-2/ba-p/607649

    При таком раскладе, окружающий софт, в т.ч. браузеры, outlook используют МИНИМАЛЬНО поддерживаемую версию tls - 1.0...

    отключение tls 1.0-1.1 приводит к фатальным последствиям, - windows 7 и outlook 2010 перестают подключаться, испралвения которые рекомендует мелкософт, на помогают

    https://docs.microsoft.com/ru-ru/archive/blogs/schrimsher/enabling-tls-1-1-and-1-2-in-outlook-on-windows-7

    https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi

    иные пляски с бубнами - так же не помогают. Outlook просто не может подключиться (даже до входа дело не доходит)

    Иной софт, так же испытывает массу пролем.

    ВОПРОС:

    Можно ли заставить мелкософтового использовать МАКСИМАЛЬНО поддерживаемую версию TLS

    т.е. не принудительно использовать tls 1.2, а только если я как клиент могу его использовать, т.е. я пробую подключиться по tls 1.2 - не получилось, пробую tls 1.1

    6 октября 2020 г. 7:56