none
Не запускается Sharepoitn 2010 при первичном запуске RRS feed

  • Вопрос

  • Добрый день. проблема такая. А не запускается после установки Sharepoint server 2010 ни под каким видом. То есть я установил, мастер настройки запустил и в конце работы мастера ошибка. Пишет так. Что ему надо? Хорошо допустим можно подредактировать это файл web.config - я знаю где он, но нужно знать как его редактировать - он не маленький. Может что -то с базой данных?

    Server Error in '/' Application.

     

    Runtime Error

     

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly"/>
        </system.web>
    </configuration>


    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

     

     

    Имя журнала:   Application
    Источник:      ASP.NET 2.0.50727.0
    Дата:          15.11.2011 17:36:05
    Код события:   1310
    Категория задачи:(3)
    Уровень:       Предупреждение
    Ключевые слова:Классический
    Пользователь:  Н/Д
    Компьютер:     WIN-T63G6RBJID0.infoworker.doc
    Описание:
    Event code: 3008
    Event message: A configuration error has occurred.
    Event time: 11/15/2011 5:36:05 PM
    Event time (UTC): 11/16/2011 1:36:05 AM
    Event ID: 84851bd832e54faab9edbf5b36eac928
    Event sequence: 1
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/895777383/ROOT-3-129658809646220000
        Trust level: WSS_Minimal
        Application Virtual Path: /
        Application Path: C:\inetpub\wwwroot\wss\VirtualDirectories\7912\
        Machine name: WIN-T63G6RBJID0
     
    Process information:
        Process ID: 5432
        Process name: w3wp.exe
        Account name: INFOWORKER\service_spfarm
     
    Exception information:
        Exception type: ConfigurationErrorsException
        Exception message: Could not load file or assembly 'RSSharePointSoapProxy, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.
     
    Request information:
        Request URL: http://localhost:8081/
        Request path: /
        User host address: ::1
        User: 
        Is authenticated: False
        Authentication Type: 
        Thread account name: INFOWORKER\service_spfarm
     
    Thread information:
        Thread ID: 6
        Thread account name: INFOWORKER\service_spfarm
        Is impersonating: False
        Stack trace:    at System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase)
       at System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement)
       at System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList)
       at System.Web.HttpApplication.GetModuleCollection(IntPtr appContext)
       at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
     
     
    Custom event details:

    Xml события:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="ASP.NET 2.0.50727.0" />
        <EventID Qualifiers="32768">1310</EventID>
        <Level>3</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-11-16T01:36:05.000000000Z" />
        <EventRecordID>38002</EventRecordID>
        <Channel>Application</Channel>
        <Computer>WIN-T63G6RBJID0.infoworker.doc</Computer>
        <Security />
      </System>
      <EventData>
        <Data>3008</Data>
        <Data>A configuration error has occurred.</Data>
        <Data>11/15/2011 5:36:05 PM</Data>
        <Data>11/16/2011 1:36:05 AM</Data>
        <Data>84851bd832e54faab9edbf5b36eac928</Data>
        <Data>1</Data>
        <Data>1</Data>
        <Data>0</Data>
        <Data>/LM/W3SVC/895777383/ROOT-3-129658809646220000</Data>
        <Data>WSS_Minimal</Data>
        <Data>/</Data>
        <Data>C:\inetpub\wwwroot\wss\VirtualDirectories\7912\</Data>
        <Data>WIN-T63G6RBJID0</Data>
        <Data>
        </Data>
        <Data>5432</Data>
        <Data>w3wp.exe</Data>
        <Data>INFOWORKER\service_spfarm</Data>
        <Data>ConfigurationErrorsException</Data>
        <Data>Could not load file or assembly 'RSSharePointSoapProxy, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.</Data>
        <Data>http://localhost:8081/</Data>
        <Data>/</Data>
        <Data>::1</Data>
        <Data>
        </Data>
        <Data>False</Data>
        <Data>
        </Data>
        <Data>INFOWORKER\service_spfarm</Data>
        <Data>6</Data>
        <Data>INFOWORKER\service_spfarm</Data>
        <Data>False</Data>
        <Data>   at System.Web.Configuration.ConfigUtil.GetType(String typeName, String propertyName, ConfigurationElement configElement, XmlNode node, Boolean checkAptcaBit, Boolean ignoreCase)
       at System.Web.Configuration.Common.ModulesEntry..ctor(String name, String typeName, String propertyName, ConfigurationElement configElement)
       at System.Web.HttpApplication.BuildIntegratedModuleCollection(List`1 moduleList)
       at System.Web.HttpApplication.GetModuleCollection(IntPtr appContext)
       at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
    </Data>
      </EventData>
    </Event>

    16 ноября 2011 г. 1:58

Ответы

Все ответы

  • Привет!

    Подредактровав файл web.config вы получите вместо оного текста на странице тескт ошибки и stack trace, который виден из других указанных вами логов. А ругается он вот на какую ошибку: RSSharePointSoapProxy, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified

    Проверьте есть ли в папке %windir%\assembly искомая сборка. Если нету, то скорее всего установка прошла с ошибками. Если же есть, то стоит попробовать сделать iisreset.


    SharePoint MCPD, MCITP. Высказанное мною здесь - мои личные взгляды, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.
    16 ноября 2011 г. 6:37
    Модератор
  • Странно как-то - у меня на одной "ферме" такая сборка есть, на другой нет. Обе Шарепойнт Сервер Enterprise и обе работают.
    16 ноября 2011 г. 8:46
    Отвечающий
  • Да. Спасибо всем - у меня нету такой сборки. И я даже знаю почему. Очевидно я что-то удалил из sql report serv. Это компонент очевидно теперь для связи был. Я хотел срезать все от Sharepoint и удалил его . Он назывался как то смешанно. Что -то вроде sql report sharepoint . Во всяком случае наверно у  кого он стоит его можно увидеть набрав в пункте установка и уд программ share.... Хотя не факт что поэтому не работает.. Надо пробовать. Или сносить RS с SQL

    16 ноября 2011 г. 9:08
  • Странно как-то - у меня на одной "ферме" такая сборка есть, на другой нет. Обе Шарепойнт Сервер Enterprise и обе работают.


    Аналогично.

    Побинговал эту ошибку. Весьма похоже, что проблема с репортингом. Вот похоже человек описал решение подобной проблемы: http://seenu-kb.blogspot.com/2011/07/could-not-load-file-or-assembly.html


    SharePoint MCPD, MCITP. Высказанное мною здесь - мои личные взгляды, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.
    • Изменено IAfanasovModerator 16 ноября 2011 г. 9:14 сделал ссылку
    16 ноября 2011 г. 9:11
    Модератор
  • СПС. Я вот пока тут http://www.microsoft.com/downloads/ru-ru/details.aspx?FamilyId=b3bebf9d-d86d-48cd-94e2-0639a846be80&displaylang=ru

    Кстати с большой вероятностью это один и тот же файл

    • Предложено в качестве ответа IAfanasovModerator 16 ноября 2011 г. 9:29
    • Помечено в качестве ответа Roman Zhukov 16 ноября 2011 г. 11:12
    16 ноября 2011 г. 9:18
  • Админка заработала)))
    • Помечено в качестве ответа Dmitr123 16 ноября 2011 г. 9:27
    • Снята пометка об ответе IAfanasovModerator 16 ноября 2011 г. 9:28
    16 ноября 2011 г. 9:27