none
Sharepoint и имена портала RRS feed

  • Вопрос

  • Коллеги день добрый. Подскажите как сделать что бы портал ходил по имени: https://portal  и https://portal.domen.ru  и https://portal-mysite и https://portal-mysite.domen.ru

    У меня сейчас работает только https://portal  https://portal-mysite

    прописал в ЦА в меню  "Сопоставления для альтернативного доступа"  добавил как внутренние url-адреса   https://portal.domen.ru https://portal-mysite.domen.ru

    также в реесторе на сервер Front-end по пути H_L_M\system\currentControlset\Control\LSA\Msv1_0 в  мулти строковом параметре BackConnectionHostNames прописал : 

    portal

    portal.domen.ru

    portal-mysite

    portal-mysite.domen.ru

    также прописал все это дело в файл host:

    192.168.3.50     portal

    192.168.3.50     portal.domen.ru

    192.168.3.50     portal-mysite

    192.168.3.50     portal-mysite.domen.ru

    где еще нужно прописать ??? подскажите что упустил?

    8 апреля 2017 г. 14:54

Ответы

  • в файл host  прописал:
    вот это оставить:

    127.0.0.1       portal.domen.ru
    127.0.0.1       portal
    127.0.0.1       portal-mysite.domen.ru
    127.0.0.1       portal-mysite

    Вот это удалить:
    192.168.2.175 portal.domen.ru
    192.168.2.175 portal-mysite.domen.ru
    192.168.2.175 portal
    192.168.2.175 portal-mysite

    Как делали https://portal.domen.ru/ 
    брали веб приложение 
    http://portal.domen.ru/  и Расширяли?

    • Изменено Alexander Surbashev 12 апреля 2017 г. 14:05
    • Помечено в качестве ответа Dedman2k3 13 апреля 2017 г. 6:42
    12 апреля 2017 г. 14:03
  • Думаю, точка входа должна быть едина.
    что для внешних, что для внутренних. Так меньше путаницы (то есть редирект)

    Если есть строго требование, доступа к порталу по https://portal из доменной сети, то да, делать самоподписной, если нет собственного центра сертификации
    • Изменено Alexander Surbashev 13 апреля 2017 г. 6:48
    • Помечено в качестве ответа Dedman2k3 13 апреля 2017 г. 7:38
    13 апреля 2017 г. 6:48
  • оказывается на сайте были сторонние  куски кода, которые отображали некоторые сервисы. убрал их https норм отработал. 

    но проблема теперь возникла в том, что через http все норм заходит  отрабатывает керберос. а по https запрашивает залогинеться...

    видимо kerberos не доверяет ssl

    • Помечено в качестве ответа Dedman2k3 18 апреля 2017 г. 9:54
    18 апреля 2017 г. 9:54
  • добавил сертификат в доверенные корневые центры. kerberos с ssl отработал норм.

    • Помечено в качестве ответа Dedman2k3 18 апреля 2017 г. 11:18
    18 апреля 2017 г. 11:17

Все ответы

  • 1. На DNS сервере.

    Ну и пропинговать все имена.

    2. Диспетчер IIS-сайты-<вебприложение>-привязки проверить привязки сайта, должен быть прописан порт 443 для https и установлен сертификат, ну а 80 порт там просто должен БЫТЬ!!!!

    10 апреля 2017 г. 6:32
  • Привязки в iis настроены?
    10 апреля 2017 г. 6:33
  • Коллеги день добрый. Подскажите как сделать что бы портал ходил по имени: https://portal  и https://portal.domen.ru  и https://portal-mysite и https://portal-mysite.domen.ru

    У меня сейчас работает только https://portal  https://portal-mysite

    прописал в ЦА в меню  "Сопоставления для альтернативного доступа"  добавил как внутренние url-адреса   https://portal.domen.ru https://portal-mysite.domen.ru

    также в реесторе на сервер Front-end по пути H_L_M\system\currentControlset\Control\LSA\Msv1_0 в  мулти строковом параметре BackConnectionHostNames прописал : 

    portal

    portal.domen.ru

    portal-mysite

    portal-mysite.domen.ru

    также прописал все это дело в файл host:

    192.168.3.50     portal

    192.168.3.50     portal.domen.ru

    192.168.3.50     portal-mysite

    192.168.3.50     portal-mysite.domen.ru

    где еще нужно прописать ??? подскажите что упустил?

    в хостах я бы прописал 
    127.0.0.1  portal
    и т д 
    10 апреля 2017 г. 7:08
  • так я вообще откатился назад. создал заного ферму.

    только теперь создал приложения с доменом т.к. решили покупать WC

    portal.domen.ru\ portal-mysite.domen.ru

    и так еще раз по пунктам:

    в файл host  прописал:

    127.0.0.1          portal.domen.ru
    127.0.0.1          portal
    127.0.0.1          portal-mysite.domen.ru
    127.0.0.1          portal-mysite
    192.168.2.175  portal.domen.ru
    192.168.2.175  portal-mysite.domen.ru
    192.168.2.175  portal
    192.168.2.175  portal-mysite

    в реесторе на сервер Front-end по пути H_L_M\system\currentControlset\Control\LSA\Msv1_0 в  мулти строковом параметре BackConnectionHostNames прописал : 

    portal

    portal.domen.ru

    portal-mysite

    portal-mysite.domen.ru

    в iis  привязки настроил: по приложению в "привязки сайта"

    тип        имя Узла                 порт            ip адрес 

    http       portal                       80                192.168.3.50

    http       portal.domen.ru       80                192.168.3.50

    https     portal.domen.ru       443                *                      

    здесь ssl-сертификат WС который куплен на домен domen.ru   выбираю *.domen.ru

    https    portal                        443                 *              

    здесь ssl-сертификат WС который куплен на домен domen.ru   выбираю *.domen.ru

    прописал в ЦА в меню  "Сопоставления для альтернативного доступа"  

    и в изменениях внутренних URL - адресов исправил http://portal.domen.ru на https://portal.domen.ru

    также через Добавить внутренние URL-адреса

     прописал https://portal

    теперь когда захожу в ЦА \Управление приложениями\ Управление веб-приложениями\ 

    отображается c hhtps и 443 портом.

    SharePoint - portal.domen.ru Выбранные элементы  https://portal.domen.ru/  443 

    и что по итогу получается:

    на https://portal.domen.ru/ заходит без проблем.

    на https://portal 

    заходит но с начало отображается окно:

    Собственно нажимаю дополнительно и нажимаю перейти на сайт отображается:

    

    тоесть сначало он ругается что на именно  https://portal нету сертификата  ( это первая проблема второстепенная)

    а джальше просто не загружается. " к сожалению что то пошло не так"

    причем на сервер  вебфронтенде там после перейти на сайт страничка портала загружается. понятное дело потому что в хостах прописано.

    собственно две проблемы в одной 1) как сделать что бы внутри организации(не наружу, внутри сети) отрабатывал  норм https://portal без ошибки ssl пускал и сама страничка загружалась. ??



    • Изменено Dedman2k3 12 апреля 2017 г. 13:56
    12 апреля 2017 г. 13:35
  • в файл host  прописал:
    вот это оставить:

    127.0.0.1       portal.domen.ru
    127.0.0.1       portal
    127.0.0.1       portal-mysite.domen.ru
    127.0.0.1       portal-mysite

    Вот это удалить:
    192.168.2.175 portal.domen.ru
    192.168.2.175 portal-mysite.domen.ru
    192.168.2.175 portal
    192.168.2.175 portal-mysite

    Как делали https://portal.domen.ru/ 
    брали веб приложение 
    http://portal.domen.ru/  и Расширяли?

    • Изменено Alexander Surbashev 12 апреля 2017 г. 14:05
    • Помечено в качестве ответа Dedman2k3 13 апреля 2017 г. 6:42
    12 апреля 2017 г. 14:03

  • Как делали https://portal.domen.ru/ 
    брали веб приложение 
    http://portal.domen.ru/  и Расширяли?

    в файле host оставил только это:

    127.0.0.1       portal.domen.ru
    127.0.0.1       portal
    127.0.0.1       portal-mysite.domen.ru
    127.0.0.1       portal-mysite

    в iis  привязки настроил: по приложению в "привязки сайта"  Исправил как на рисунке.

    тип        имя Узла                    порт            ip адрес 

    http       portal                           80                 *

    http       portal.domen.local       80                *

    https     portal.domen.ru            443              *                      

    здесь ssl-сертификат WС который куплен на домен domen.ru   выбираю *.domen.ru

    https    portal                            443               *              

    здесь ssl-сертификат WС который куплен на домен domen.ru   выбираю *.domen.ru


    Изначально пробовал расширять, но получалось только создание дополнительного веб приложения. После решил заного сделать ферму с нуля и собственно приложение создвал, через кнопку создать ну и там как обычно.

    да и http вообще не нужен, нужно что бы все пользователи заходили через https ( но этот вопрос  я прошлый раз решал редиректом установкой приложения URL Rewrite  http://www.e-du.ru/2016/08/iis-http-to-https.html )  и все работало.

    исправил как в предыдущем посту ситуация не изменилась.

    на https://portal.domen.ru заходит норм без проблем. а на https://portal

    ошибка сертификата и к сожалению что то пошло не так.

    также в логах винды пишет вот такое предупреждение:

     
    • Изменено Dedman2k3 12 апреля 2017 г. 14:41
    12 апреля 2017 г. 14:19
  • после нескольких перезагрузок и ресета iisa 

    ситуация поменялась.

    теперь https://portal.domen.ru заходит норм без проблем. как и было.

    на https://portal заходит с ошибкой сертификата. нажимаю все равно перейти редеректит на https://portal.domen.ru

    я понимаю что т.к. у меня WС на *.domen.ru. страничка https://portal и не должна отрабатывать норм.

    какие варианты? делать разные сертификаты для сайтов https://portal.domen.ru здесь WC и https://portal здесь самоподписной.

     вообще конечно сделать нужно редирект автоматически c https://portal на https://portal.domen.ru

    посоветуйте как правильно сделать?

    • Предложено в качестве ответа Alexander Surbashev 13 апреля 2017 г. 6:47
    • Отменено предложение в качестве ответа Alexander Surbashev 13 апреля 2017 г. 6:47
    13 апреля 2017 г. 6:42


  • а зачем здесь писать portal.domain.local? что это дает? 

    13 апреля 2017 г. 6:46
  • Думаю, точка входа должна быть едина.
    что для внешних, что для внутренних. Так меньше путаницы (то есть редирект)

    Если есть строго требование, доступа к порталу по https://portal из доменной сети, то да, делать самоподписной, если нет собственного центра сертификации
    • Изменено Alexander Surbashev 13 апреля 2017 г. 6:48
    • Помечено в качестве ответа Dedman2k3 13 апреля 2017 г. 7:38
    13 апреля 2017 г. 6:48
  • Думаю, точка входа должна быть едина.
    что для внешних, что для внутренних. Так меньше путаницы (то есть редирект)

    Если есть строго требование, доступа к порталу по https://portal из доменной сети, то да, делать самоподписной, если нет собственного центра сертификации

    ок спс буде делать редирект. точка входа должны быть одна.

    13 апреля 2017 г. 7:37
  • У меня еще один вопрос возник. может подскажите?

    через Chrome. при загрузки странички портал сначало пишет надежный, но после того как загружается пишет вот такой значок:

    Если использовать IE

    страница загрузилась норм  но внизу пишет предупреждение вот такое:

    как все таки сделать что бы был зеленый кружок надежный. 

    и предупреждение в IE  не выскакивало??


    • Изменено Dedman2k3 13 апреля 2017 г. 8:10
    13 апреля 2017 г. 7:51
  • адрес портала добавлен в надежные узлы?
    13 апреля 2017 г. 8:01
  • если ты про в IE св-ва браузера\безопасность\ надежные сайты там добавлен сайт портала.

    или ты не про это??

    13 апреля 2017 г. 8:13
  • если ты про в IE св-ва браузера\безопасность\ надежные сайты там добавлен сайт портала.

    или ты не про это??

    Да, да, про это. а в ie такой проблемы нет?
    13 апреля 2017 г. 8:17
  • если ты про в IE св-ва браузера\безопасность\ надежные сайты там добавлен сайт портала.

    или ты не про это??

    Да, да, про это. а в ie такой проблемы нет?

     проблема есть везде можно сказать, в Chrome отображается кружок

    вместо

     

    в IE пишется предупреждение в виде:

    в FreeFox вообще загружается сразу;

    тоесть получается, что ssl как бы и не шифрует страницу, не отрабатывает вообще.

    как исправить??

    13 апреля 2017 г. 8:38
  • Интересную штуку заметил в Chrome:

    загружается страница c;

    и есть момент здесь.

     жму загрузить небезопасные скрипты

    выкидывает в:

    13 апреля 2017 г. 12:54
  • а статичный контент (стили скрипты) у вас случаем не на CDN ?
    13 апреля 2017 г. 13:09
  • а статичный контент (стили скрипты) у вас случаем не на CDN ?

      а можно по подробнее, что такое CDN ? ну стандартный шаблон портала, выбрана зеленая цветовая гамма. нету не каких скриптов, просто странички и туда накиданы документы по отделам и фоточки.

    получается что контент статичный.


    • Изменено Dedman2k3 13 апреля 2017 г. 13:43
    13 апреля 2017 г. 13:35
  • а статичный контент (стили скрипты) у вас случаем не на CDN ?

      а можно по подробнее, что такое CDN ? ну стандартный шаблон портала, выбрана зеленая цветовая гамма. нету не каких скриптов, просто странички и туда накиданы документы по отделам и фоточки.

    нет CDN не использую, точно.
    13 апреля 2017 г. 13:38
  • оказывается на сайте были сторонние  куски кода, которые отображали некоторые сервисы. убрал их https норм отработал. 

    но проблема теперь возникла в том, что через http все норм заходит  отрабатывает керберос. а по https запрашивает залогинеться...

    видимо kerberos не доверяет ssl

    • Помечено в качестве ответа Dedman2k3 18 апреля 2017 г. 9:54
    18 апреля 2017 г. 9:54
  • добавил сертификат в доверенные корневые центры. kerberos с ssl отработал норм.

    • Помечено в качестве ответа Dedman2k3 18 апреля 2017 г. 11:18
    18 апреля 2017 г. 11:17