none
Microsoft Exchange 2013 on two different Hyper-V nodes RRS feed

  • Вопрос

  • Добрый день, уважаемые специалисты.

    Возможно кто-то сталкивался с подобной проблемой, но ответа я пока так и не нашел.

    Пытаюсь развернуть 4 виртуальных машины с ПО Microsoft Exchange 2013 CU3 под управлением ОС Microsoft Windows Server 2012 Standard. В качестве гипервизора выбран Microsoft Hyper-V.

    Хосты, на которых развернута роль гипервизора, используют также ОС Microsoft Windows Server 2012. Хосты имеют несколько сетевых интерфейсов, объединенных в режиме Port Agregation. 

    Пытаюсь создать DAG и добавить туда все 4 сервера, чего сделать не удается. В DAG добавляется всего лишь 2 сервера с определенного хоста, а при попытке добавить в кластер остальные сервера, я получаю ошибку. Лог ошибки представлен ниже:

    GetRemoteCluster() for the mailbox server failed with exception = An Active Manager operation failed. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"OpenCluster(<servername>) failed with 0x6d9. Error: В системе отображения конечных точек не осталось доступных конечных точек"' failed.. This is OK.

    [2014-02-15T07:04:48] WriteError! Exception = Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error Сбой операции. Ошибки CreateCluster могут возникать в результате неправильной настройки статических адресов. Ошибка: Произошла ошибка при выполнении операции кластера. Ошибка: Сбой API кластера 'Ошибка AddClusterNode() (MaxPercentage=100): 0x5b4. Ошибка: Возврат из операции произошел из-за превышения времени ожидания'.. ---> Microsoft.Exchange.Cluster.Replay.AmClusterApiException: An Active Manager operation failed. Error: Произошла ошибка при выполнении операции кластера. Ошибка: Сбой API кластера 'Ошибка AddClusterNode() (MaxPercentage=100): 0x5b4. Ошибка: Возврат из операции произошел из-за превышения времени ожидания'. ---> System.ComponentModel.Win32Exception: Возврат из операции произошел из-за превышения времени ожидания

    При этом отмечается, что необходимые порты для создания Failover Cluster открыты и доступны, пинги ходят стабильно и без потерь.

    Но самое интересное начинается когда я мигрирую все 4 виртуальные машины с ПО Microsoft Exchange 2013 на один физический хост. Кластер мгновенно собирается без каких-либо проблем и ошибок. Однако, такой вариант меня не устраивает, поскольку держать 4 сервера на одной железке... Смысла тогда нет поднимать DAG....

    Траблшуттинг ошибок ни к чему не привел. Очень надеюсь, что кто-нибудь уже решал подобные проблемы, заранее благодарю всех за предложенные варианты решения этой проблемы.




    15 февраля 2014 г. 10:32

Ответы

  • Отключите TCP/UDP Checksum Offload на физических интерфейсах узлов кластера Hyper-V.
    15 февраля 2014 г. 10:52
    Отвечающий
  • Добрый день. Большое спасибо за ответ, уже видел нечто подобное вот здесь:

    http://bazanovv.livejournal.com/33367.html

    Заставило задуматься почему отключение TCP/UDP CheckSum Offload решает эту проблему. Ответа так и не нашел... 

    Перед тем как попробовать вышеуказанное решение, наткнулся на ссылку http://support.microsoft.com/kb/2872325/en-us, где я и нашел решение своей проблемы. Проблема заключается в использовании компонента Microsoft Failover Cluster Virtual Adapter Perfomance Filter. Отключение этого компонента в настройках сетевого адаптера на хосте Hyper-V позволило решить проблему.

    Всем большое спасибо!


    17 февраля 2014 г. 8:39

Все ответы

  • Отключите TCP/UDP Checksum Offload на физических интерфейсах узлов кластера Hyper-V.
    15 февраля 2014 г. 10:52
    Отвечающий
  • Добрый день. Большое спасибо за ответ, уже видел нечто подобное вот здесь:

    http://bazanovv.livejournal.com/33367.html

    Заставило задуматься почему отключение TCP/UDP CheckSum Offload решает эту проблему. Ответа так и не нашел... 

    Перед тем как попробовать вышеуказанное решение, наткнулся на ссылку http://support.microsoft.com/kb/2872325/en-us, где я и нашел решение своей проблемы. Проблема заключается в использовании компонента Microsoft Failover Cluster Virtual Adapter Perfomance Filter. Отключение этого компонента в настройках сетевого адаптера на хосте Hyper-V позволило решить проблему.

    Всем большое спасибо!


    17 февраля 2014 г. 8:39