none
не работает служба терминалов RRS feed

  • Общие обсуждения

  • Здравствуйте. ОС: w2k3. Подняты службы Сервер терминалов, Служба лицензирования терминалов. При попытке зайти на сервер терминалов, клиент не пишет ни каких ошибок сразу дает отбой. Галочка на "Динстанционное управление рабочий столол" стоит. Фаерволы отключены.________________________________________________________________Удаление и новая установка служб терминалов ни чего не дает. Службы запущены. netstat -an показывает:_____________________________________ Активные подключения:_________________________________________________ Имя_____Локальный адрес________Внешний адрес______Состояние TCP_____0.0.0.0:23_____________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:135____________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:445____________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:475____________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:1025___________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:1026___________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:3389___________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:4899___________0.0.0.0:0__________LISTENING TCP_____0.0.0.0:30303__________0.0.0.0:0__________LISTENING TCP_____127.0.0.1:5152_________0.0.0.0:0__________LISTENING TCP_____192.168.0.3:1154_______192.168.0.112:139__TIME_WAIT TCP_____192.168.0.3:1155_______192.168.0.112:139__TIME_WAIT UDP_____0.0.0.0:445____________*:* UDP_____0.0.0.0:475____________*:* UDP_____0.0.0.0:500____________*:* UDP_____0.0.0.0:4500___________*:* UDP_____127.0.0.1:123__________*:* UDP_____127.0.0.1:1128_________*:* В реестре след. параметры: HKLM\SYSTEM\CurrentControlSet\Control\TerminalServer\fDenyTSConnections в 0.__________________________________________________________________ HKLM\SYSTEM\CurrentControlSet\Control\TerminalServer\IdleWinStationPoolCount на 2. Помоему порт 3389 чемто занят. Помогите решить проблему. Почемуто форум пробелы не понимает((
    20 апреля 2010 г. 4:00

Все ответы

  • изменение порта на 9090 сервера терминалов не помогло. Дело не в портах.
    20 апреля 2010 г. 4:47
  • Предпологаемые пользователи добавлены в локальную группу пользователей терминалов?

    20 апреля 2010 г. 6:44
  • естественно, пользователи находятся в группе "Пользователи удаленного рабочего стола." До вчерашнего дня все работало. Удалил все обновления не помогло. Затем поставил снова. Не помогло.

    20 апреля 2010 г. 17:53
  • Покажите вывод этого батника, выполненнного на сервере (это покажет установленные у вас программы):

    @echo off
    regedit /a %TEMP%\filename.reg "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall"
    for /f "Skip=1 Tokens=*" %%i in ('type %TEMP%\Filename.reg') do set line="%%i"&call :parse
    goto :EOF
    :parse
    set work=%line:~2,11%
    set work=%work:"=%
    If NOT "%work%" EQU "DisplayName" goto :EOF
    set work=%line:~16,120%
    set work=%work:"=%
    @echo %work%
    И есть ли в логах ошибки при попытке подключения?
    20 апреля 2010 г. 18:04
    Отвечающий
  • На клиенте чисто... а на сервере какие ошибки в логе во время подключения клиента???

    И посмотрите веточку реестра [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

    Параметр Userinit

    Его значение должно быть таким:

    "Userinit"="C:\\WINDOWS\\system32\\userinit.exe,"

     

    Было похожее, троян сидел на этом порту, 5 антивирей сказали что все чисто :)


    А все могло быть и лучше...
    20 апреля 2010 г. 18:13
  • балин, я уже снес ее, но на всякий сделал бекап.

    21 апреля 2010 г. 11:18
  • На клиенте логи не смотрел. На сервере логи чисты, ошибок нет. ОС уже снес к сожалению но бекап сделал. Как будет свободное время попробую. Троян? Систему ставил я не давно, буквально через 2 дня перестал работать сервер терминалов, за это время не мог же троян завестись. Кстати в этой же конторе была проблема с троянами.

    Недавно произошла такая история у клиентов. Они пожаловались что у них глючит винда на компьютере гл. бухгалтера. Я приехал к ним посмотрел, у них небыло антивируса. Запустил утилитку cureit от drweb'а и просканел диск, нашел около 20-30 троянов. Все они были с расширением *.exe. Название не запомнил. Проблема была в следующем: Не работал DNS-клиент для Интернета, т.е пинги по имени прохадили по корпоратиной сети, а пинги в Интернет уже ни как не шли. У бухгалтера соответсвенно на этом компе стоял клиент-банк который подключался к серверу через браузер IE, и из-за того что пинги не шли не работал Клиент-Банк. На компьютере DNS сервер был изначально прописан как предпочитаймый провайдера. Я только что не делал чтоб его восстановить но ни как не получалось. Пришлось снести винду. Удалить старый раздел и создать два. Один под систему, а второй под данные. После того как разделы были созданы и винда поднята. Оказалось что с этого счета перевели деньги на другой. Но как мне объяснили перевели деньги за неделю до моего прихода (проблему обнаружили поздно), моя вина как бы получается в том что я уничтожил доказательсва, логи cureit и самих троянов. Только кто знал что такое может случится. Завели уголовное дело. Хотелось бы знать, что за троян такой который хакает клиент банк и ломает днс-клиент или протокол tcp/ip? Пинги по днс не проходят, я подозреваю это после использовая утилиты AVZ после восстановлении системы.

    21 апреля 2010 г. 11:33
  • Кстати дрвеб и авз моего терминального трояна не видели :)
    А все могло быть и лучше...
    21 апреля 2010 г. 13:06
  • такую же проблему (как описано) видел на компах с XP SP3 - сбразывалось терминальное подключение, сразу после установки соединения. Так проблему и оставил :( 

    21 апреля 2010 г. 14:23