none
Веб доступ к ecp и owa RRS feed

  • Общие обсуждения

  • Добрый день!

    Переустановил Exchange server 2013. При попытке зайти через вёб-интерфейс на ecp или owa пишет bad request 400.

    В самом IIS все что нужно присутствует в Exchange Back End

    При вводе команд get-ecp(owa)virtualdirectory в PS Exchange, ни чего не выводит.

    1 декабря 2017 г. 12:17

Все ответы

  • Тебе необходимо прописать виртуальные директории для ECP и OWA, это делает через PS или вебку.

    Get-MapiVirtualDirectory | Set-MapiVirtualDirectory -InternalUrl https://mail.itband.ru/mapi -ExternalUrl https://mail.itband.ru/mapi -IISAuthenticationMethods Negotiate
    
    
    Get-OutlookAnywhere | Set-OutlookAnywhere -InternalHostname mail.itband.ru -ExternalHostname mail.itband.ru -ExternalClientsRequireSsl $true -InternalClientsRequireSsl $true -InternalClientAuthenticationMethod negotiate -ExternalClientAuthenticationMethod negotiate
    
    
    Get-ActiveSyncVirtualDirectory | Set-ActiveSyncVirtualDirectory -InternalUrl "https://mail.itband.ru/Microsoft-Server-ActiveSync" -ExternalUrl "https://mail.itband.ru/Microsoft-Server-ActiveSync"
    
    Get-OabVirtualDirectory  | Set-OabVirtualDirectory -InternalUrl "https://mail.itband.ru/OAB" -ExternalUrl "https://mail.itband.ru/OAB"
    
    Get-WebServicesVirtualDirectory | Set-WebServicesVirtualDirectory -InternalUrl "https://mail.itband.ru/EWS/Exchange.asmx" -ExternalUrl "https://mail.itband.ru/EWS/Exchange.asmx"
    
    Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -InternalUrl "https://mail.itband.ru/owa" -ExternalUrl “https://mail.itband.ru/owa”
    
    Get-ECPVirtualDirectory | Set-ECPVirtualDirectory -InternalUrl "https://mail.itband.ru/ecp" -ExternalUrl "https://mail.itband.ru/ecp"
    

    1 декабря 2017 г. 13:00
  • Ввел все эти команды, ни какого эффекта, все тоже самое.
    4 декабря 2017 г. 8:11
  • Попробуйте пересоздать каталоги. remove-owavirtualdirectory, new-owavirtualdirectory. ECP по аналогии.
    4 декабря 2017 г. 8:40
  • Посмотрел вот эту статью:

    https://rmamyshev.wordpress.com/2014/04/21/recreate-owa-ecp-exchange2013/

    Написано, что если роли совмещены (а я ставил на сервер и cas и mailbox) то должно быть содержимое и в DefaultWebSite (80, 443 порты) и в ExchangeBackEnd(81, 444 порты)

    У меня только в ExchangeBackEnd. (сервер ставил cu17).

    4 декабря 2017 г. 9:12
  • Попробуем еще раз. Соберитесь и ответьте на мой вопрос. 

    Пересоздание каталогов помогло?

    4 декабря 2017 г. 10:29
  • Нет, не помогло.
    4 декабря 2017 г. 12:49
  • Очень хорошо. Посмотрите в журнал, возможно это наведет на какие-то мысли.

    И еще. Вы только одним пользователем проверяете? Попробуйте еще другой учеткой.

    4 декабря 2017 г. 12:56
  • Возможно дело в SSL сертификате после переустановки сервера, как привязать в IIS сертификат exchange или проверить что все нормально?
    5 декабря 2017 г. 10:50
  • В EMS проверить

    Get-Exchnagecertificate, Assign-ExchangeCertificate

    5 декабря 2017 г. 13:23
  • Ввел все эти команды, ни какого эффекта, все тоже самое.
    После этих настроек вы перезапускали IIS или хотя бы пулы отвечающий за ECP и OWA?
    11 декабря 2017 г. 13:41
  • Счастье как, наступило?
    18 декабря 2017 г. 8:52