none
Windows7 не видит CD привод

    Вопрос

  • Не видит привод СД/ДВД... Сам драйвер на месте, в диспетчере пишет "Не удалось загрузить драйвер этого устройства. Возможно, драйвер поврежден или отсутствует. (Код 39)" При попытке обновить его, пишет что драйвер в обновлении не нуждается... Что делать?
    3 ноября 2009 г. 13:28

Ответы

  • Помогал решать такую проблему, помог совет:

    "Несколько вариантов..
    1. - обновить драйвера на chipset и материнскую плату в целом.
    2. - данная проблема может быть связана с повреждением двух параметров реестра Windows. Для устранения неполадок нужно удалить поврежденные параметры при помощи редактора реестра. Чтобы использовать данный метод, необходимо войти в систему Windows с правами администратора

    1. Нажмите кнопку Пуск выберите пункт Все программы.
    2. Выберите пункт Стандартные, затем пункт Выполнить.
    3. Введите команду regedit и нажмите кнопку ОК. При получении запроса на ввод пароля администратора или подтверждение введите пароль или нажмите кнопку Разрешить.
    4. Откройте в области переходов следующий подраздел реестра:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
    5. На правой панели выберите параметр UpperFilters.

    Примечание. Здесь также может находиться параметр реестра UpperFilters.bak. Этот параметр не нужно удалять. Выберите только параметр UpperFilters. Если параметр UpperFilters отсутствует, возможно, надо будет удалить параметр LowerFilters. Для этого перейдите к действию 8.
    6. В меню Правка выберите команду Удалить.
    7. Нажмите кнопку Да, чтобы подтвердить удаление.
    8. На правой панели выберите параметр LowerFilters.

    Если параметр LowerFilters отсутствует, данное решение, к сожалению, уже не сможет ничем помочь.
    9. В меню Правка выберите команду Удалить.
    10. Нажмите кнопку Да, чтобы подтвердить удаление.
    11. Закройте редактор реестра.
    12. Перезагрузите компьютер."
    http://forum.oszone.net/post-1201037-5.html

    Позже нашёл такие же рекомендации от МС, подобная проблема после обновления до Висты http://support.microsoft.com/default.aspx/kb/929461
    _______________
    О, ещё нашёл вариант решения такой же по описанию проблемы:

    "Добрый день всем !
    Столкнулся с подобной проблемой. Справился так:
    Копался в диспетчере устройств, и обнаружил, что для первичного IDE канала (к которому и подключен CD-ROM) не установлен драйвер. Попытка обновить драйвер ни к чему не привела. Тогда я удалил его, и CD/DVD привод, который ложно определялся, как SCSI устройство, и запустил поиск нового оборудования. Windows его нашла, и успешно установила драйвер. Всё заработало (только ещё раз пришлось удалить SCSI устройство )."
    http://forum.oszone.net/post-1191193-28.html
    • Предложено в качестве ответа Sarento 3 ноября 2009 г. 21:11
    • Изменено Sarento 3 ноября 2009 г. 21:15 Ещё вариант решения проблемы
    • Помечено в качестве ответа Vinokurov YuriyModerator 1 декабря 2009 г. 8:49
    3 ноября 2009 г. 21:03

Все ответы

  • Всё-таки раньше-то драйвер работал? Иначе как Вы установили ось?
    У меня подобное случается с драйвером сетевухи: иногда
    он слетает после пробуждения из хибернации. Тогда мне приходится
    удалять его, после чего устанавливать вновь и перезагружаться.
    Попробуйте и Вы драйвер удалить, после чего перезагрузиться--может поможет?
    Если нет, поищите на этом форуме (поле вверху "Поиск по форумам"): 
    жалоб на глюки с DVD приводами здесь довольно много,
    вот только не помню, как они разрешались...
    3 ноября 2009 г. 18:08
  • Да работает привод конечно... В ХР работает нормально... Второй раз 7-ю переустановил, тоже самое... При установки драйверов (вэки, принтера, сканера), оказывается привод работать, тоесть он работает 20-30 мин и все, драйвер поврежден... При попытке переустановить его, пишет ошибка, если обновить, то пишет в обновлении не нуждается... Откатывал систему до установки чего либо, проблему не решает...

    3 ноября 2009 г. 19:31
  • Помогал решать такую проблему, помог совет:

    "Несколько вариантов..
    1. - обновить драйвера на chipset и материнскую плату в целом.
    2. - данная проблема может быть связана с повреждением двух параметров реестра Windows. Для устранения неполадок нужно удалить поврежденные параметры при помощи редактора реестра. Чтобы использовать данный метод, необходимо войти в систему Windows с правами администратора

    1. Нажмите кнопку Пуск выберите пункт Все программы.
    2. Выберите пункт Стандартные, затем пункт Выполнить.
    3. Введите команду regedit и нажмите кнопку ОК. При получении запроса на ввод пароля администратора или подтверждение введите пароль или нажмите кнопку Разрешить.
    4. Откройте в области переходов следующий подраздел реестра:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
    5. На правой панели выберите параметр UpperFilters.

    Примечание. Здесь также может находиться параметр реестра UpperFilters.bak. Этот параметр не нужно удалять. Выберите только параметр UpperFilters. Если параметр UpperFilters отсутствует, возможно, надо будет удалить параметр LowerFilters. Для этого перейдите к действию 8.
    6. В меню Правка выберите команду Удалить.
    7. Нажмите кнопку Да, чтобы подтвердить удаление.
    8. На правой панели выберите параметр LowerFilters.

    Если параметр LowerFilters отсутствует, данное решение, к сожалению, уже не сможет ничем помочь.
    9. В меню Правка выберите команду Удалить.
    10. Нажмите кнопку Да, чтобы подтвердить удаление.
    11. Закройте редактор реестра.
    12. Перезагрузите компьютер."
    http://forum.oszone.net/post-1201037-5.html

    Позже нашёл такие же рекомендации от МС, подобная проблема после обновления до Висты http://support.microsoft.com/default.aspx/kb/929461
    _______________
    О, ещё нашёл вариант решения такой же по описанию проблемы:

    "Добрый день всем !
    Столкнулся с подобной проблемой. Справился так:
    Копался в диспетчере устройств, и обнаружил, что для первичного IDE канала (к которому и подключен CD-ROM) не установлен драйвер. Попытка обновить драйвер ни к чему не привела. Тогда я удалил его, и CD/DVD привод, который ложно определялся, как SCSI устройство, и запустил поиск нового оборудования. Windows его нашла, и успешно установила драйвер. Всё заработало (только ещё раз пришлось удалить SCSI устройство )."
    http://forum.oszone.net/post-1191193-28.html
    • Предложено в качестве ответа Sarento 3 ноября 2009 г. 21:11
    • Изменено Sarento 3 ноября 2009 г. 21:15 Ещё вариант решения проблемы
    • Помечено в качестве ответа Vinokurov YuriyModerator 1 декабря 2009 г. 8:49
    3 ноября 2009 г. 21:03
  • Alex_2550, совет Sarento вам пригодился?
    Все вышесказанное является моим личным мнением, не имеющим отношения к корпорации Майкрософт.
    Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    9 ноября 2009 г. 13:42
    Модератор
  • С последним ясно - там бы знак вопроса стоял.. :)
    9 ноября 2009 г. 15:57
  • Я тоже долго мучался с сидюком, ставил дрова, лазил по сайтам и форумам, пока не вскрыл системник, не поленился, и не обнаружил, что кабель, скрученный как пружина, просто выдернулся из разъема в материнской плате. ;)

    При загрузке определяется сидюк (еще до старта системы)?
    • Предложено в качестве ответа Nikita PanovModerator 24 ноября 2009 г. 6:55
    9 ноября 2009 г. 18:12