none
Не отправляются письма RRS feed

  • Вопрос

  • Доброго времени суток коллеги. Помогите решить проблемму, на свежеустановленном Exchange 2013 не отправляются письма. Если отправлять через owa то они падают в черновики, а если через outlook то письмо падает в отправленные, но ни кому не приходит.
    8 октября 2019 г. 6:37

Все ответы

  • 1. Не отправляются внутренним адресатам или внешним?

    2. Проверьте наличие не менее 10% на диске с очередью.

    3. Посмотрите почтовую очередь - с каким статусом (ошибкой) письма там лежат?

    4. Проверьте что все службы Exch запущены.

    8 октября 2019 г. 6:39
  • 1 Не отправляются не тем ни другим

    2 Место более 50% свободного

    3 В очереди пусто

    4 Службы запущены

    8 октября 2019 г. 6:42
  • 1. Через telnet отправьте письмо коллеге внутри организации.

    2. Вы очереди на всех серверах проверили? Также посмотрите SMTP лог отправки.

    3. Есть что интересное в логах System, Application на серверах Exch?

    8 октября 2019 г. 6:50
  • через телнет такая ошибка "451 4.7.0 Temporary server error. Please try again later. PRX4"

    В логах Application вот такое предупреждение "Сбой входящей проверки подлинности для соединителя приема Client Frontend . Ошибка: LogonDenied. Механизм проверки подлинности: Login. Исходный IP-адрес клиента, который предпринял попытку проверки подлинности для Microsoft Exchange: [127.0.0.1]."


    8 октября 2019 г. 7:21
  • Скорее всего вы изменили настройки коннекторов приёма и/или отправки. 

    Сравните с дефолтными значениями - https://docs.microsoft.com/en-us/Exchange/mail-flow/connectors/receive-connectors?view=exchserver-2019 и расскажите зачем и для чего меняли.

    8 октября 2019 г. 7:47
  • С конекторами приема ничего не делал, а отправки создал для области * через MX запись
    8 октября 2019 г. 7:51
  • У вас проблема и с внутренними получателями, а они не используют SendConnector. Попробуйте выключить то, что вы создали и всё-таки сравнить настройки коннекторов с дефолтными.
    8 октября 2019 г. 8:38
  • Выключил созданный коннектор, сравнил с дефолтными все равно не отправляет

    8 октября 2019 г. 9:16
  • Давайте с вами сетевые настройки проверим. Покажите ipconfig /all с сервера Exchange.
    8 октября 2019 г. 10:36
  • C:\Users\adminex>ipconfig /all

    Настройка протокола IP для Windows

       Имя компьютера  . . . . . . . . . : sumzex
       Основной DNS-суффикс  . . . . . . : sumz.umn.ru
       Тип узла. . . . . . . . . . . . . : Гибридный
       IP-маршрутизация включена . . . . : Нет
       WINS-прокси включен . . . . . . . : Нет
       Порядок просмотра суффиксов DNS . : sumz.umn.ru

    Ethernet adapter Ethernet:

       DNS-суффикс подключения . . . . . :
       Описание. . . . . . . . . . . . . : Контроллер семейства Realtek PCIe GBE
       Физический адрес. . . . . . . . . : 34-64-A9-2F-09-70
       DHCP включен. . . . . . . . . . . : Нет
       Автонастройка включена. . . . . . : Да
       Локальный IPv6-адрес канала . . . : fe80::3cbb:f6dc:c52:7792%12(Основной)
       IPv4-адрес. . . . . . . . . . . . : 10.33.0.244(Основной)
       Маска подсети . . . . . . . . . . : 255.255.252.0
       Основной шлюз. . . . . . . . . : 10.33.0.2
       IAID DHCPv6 . . . . . . . . . . . : 255091881
       DUID клиента DHCPv6 . . . . . . . : 00-01-00-01-1F-BD-78-7B-34-64-A9-2F-09-70

       DNS-серверы. . . . . . . . . . . : 10.33.0.242
       NetBios через TCP/IP. . . . . . . . : Включен

    Туннельный адаптер isatap.{563CBB11-BFB0-45BC-B1C8-B65443496991}:

       Состояние среды. . . . . . . . : Среда передачи недоступна.
       DNS-суффикс подключения . . . . . :
       Описание. . . . . . . . . . . . . : Адаптер Microsoft ISATAP #2
       Физический адрес. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP включен. . . . . . . . . . . : Нет
       Автонастройка включена. . . . . . : Да
    8 октября 2019 г. 10:42
  • Проверил, не стояло разрешение на сервера, поставил, предупреждение в события перестало появляться, однако почта все равно не ходит
    8 октября 2019 г. 11:26
  • Доброго времени суток коллеги. Помогите решить проблемму, на свежеустановленном Exchange 2013 не отправляются письма. Если отправлять через owa то они падают в черновики, а если через outlook то письмо падает в отправленные, но ни кому не приходит.

    В черновики или в отправленные?

    Есть подозрение, что что-то не так со службой MAil Submission. Для начала проверьте (из EMS командой Test-ServiceHealth) что запущены все нужные службы Exchange. И посмотрите наличие ошибок/предупреждений в журнале событий Application.


    Слава России!

    8 октября 2019 г. 11:35
  • Если отправлять через owa то они падают в черновики, а если через outlook то письмо падает в отправленные, но ни кому не приходит.

    [PS] C:\Users\adminex\Desktop>Test-ServiceHealth


    Role                    : Роль сервера почтовых ящиков
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeDelivery, MSExchangeIS, MSExchangeMailboxAssistant
                              s, MSExchangeRepl, MSExchangeRPC, MSExchangeServiceHost, MSExchangeSubmission, MSExchangeThro
                              ttling, MSExchangeTransportLogSearch, W3Svc, WinRM}
    ServicesNotRunning      : {}

    Role                    : Роль сервера клиентского доступа
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeMailboxReplication, MSExchangeRPC, MSExchangeServi
                              ceHost, W3Svc, WinRM}
    ServicesNotRunning      : {}

    Role                    : Роль сервера единой системы обмена сообщениями
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeServiceHost, MSExchangeUM, W3Svc, WinRM}
    ServicesNotRunning      : {}

    Role                    : Роль транспортного сервера-концентратора
    RequiredServicesRunning : True
    ServicesRunning         : {IISAdmin, MSExchangeADTopology, MSExchangeEdgeSync, MSExchangeServiceHost, MSExchangeTranspo
                              rt, MSExchangeTransportLogSearch, W3Svc, WinRM}
    ServicesNotRunning      : {}
    8 октября 2019 г. 11:39
  • Вот такая ошибка стала появляться

    (Процесс w3wp.exe, идентификатор процесса 3664) Для ключа sumz.umn.ru/admin exchange в классе Microsoft.Exchange.Configuration.Authorization.WSManBudgetManager обнаружена утечка подключения. Потерянное значение: 3.

    8 октября 2019 г. 11:44
  • Судя по всему, это - совершенно посторонняя ошибка: связана она с IIS, а не со службами транспорта.

    Слава России!

    8 октября 2019 г. 12:27
  • Проверьте permissions group на коннекторе:

    https://social.technet.microsoft.com/Forums/ru-RU/d17e300c-a491-406f-8a38-f9cb21688558/105410961080107310821072-10851072?forum=exchange2013ru



    Это не помогло, предупреждение опять появилось
    8 октября 2019 г. 13:49
  • Доброго времени суток коллеги. Помогите решить проблемму, на свежеустановленном Exchange 2013 не отправляются письма. Если отправлять через owa то они падают в черновики, а если через outlook то письмо падает в отправленные, но ни кому не приходит.

    Предлагаю начать с  начала.

    1. Операцмрнная система какая? 

    2. Exchange 2013 CU? Если установили новый то с каким обновлением?

    3. Установили на рядовой север?

    4. VM или физический?

    5. Пример тела письма с hiders из OWA.


    MCITP, MCSE. Regards, Oleg

    9 октября 2019 г. 10:35
    Модератор
  • Добрый день.

    Почитайте вот отсюда и ниже
    https://t.me/UCChat/65808
    Суть - проблема с настройками ДНС и работы с ним в Exchange.

    Там про другую проблему, но что у вас вот здесь:
    (ессно, SET не надо делать, просто через GET посмотрите)

    Get-TransportService | Set-TransportService -ExternalDNSServers 192.168.1.210 -InternalDNSServers 192.168.1.210 -ExternalDNSAdapterEnabled $false -InternalDNSAdapterEnabled $false
    Get-FrontendTransportService | Set-FrontendTransportService -ExternalDNSServers 192.168.1.210 -InternalDNSServers 192.168.1.210 -ExternalDNSAdapterEnabled $false -InternalDNSAdapterEnabled $false
    9 октября 2019 г. 11:34
  • Доброго времени суток коллеги. Помогите решить проблемму, на свежеустановленном Exchange 2013 не отправляются письма. Если отправлять через owa то они падают в черновики, а если через outlook то письмо падает в отправленные, но ни кому не приходит.

    Предлагаю начать с  начала.

    1. Операцмрнная система какая? 

    2. Exchange 2013 CU? Если установили новый то с каким обновлением?

    3. Установили на рядовой север?

    4. VM или физический?

    5. Пример тела письма с hiders из OWA.


    MCITP, MCSE. Regards, Oleg

    1. Server 2012 Standart

    2. Exchange 2013 CU 23

    3. Установили на физический комп

    5. не совсем понял

    9 октября 2019 г. 11:41
  • Добрый день.

    Почитайте вот отсюда и ниже
    https://t.me/UCChat/65808
    Суть - проблема с настройками ДНС и работы с ним в Exchange.

    Там про другую проблему, но что у вас вот здесь:
    (ессно, SET не надо делать, просто через GET посмотрите)

    Get-TransportService | Set-TransportService -ExternalDNSServers 192.168.1.210 -InternalDNSServers 192.168.1.210 -ExternalDNSAdapterEnabled $false -InternalDNSAdapterEnabled $false
    Get-FrontendTransportService | Set-FrontendTransportService -ExternalDNSServers 192.168.1.210 -InternalDNSServers 192.168.1.210 -ExternalDNSAdapterEnabled $false -InternalDNSAdapterEnabled $false

    [PS] C:\Users\adminex\Desktop>Get-TransportService

    Name                                                        MessageTrackingLogEnabled
    ----                                                        -------------------------
    SUMZEX                                                      True


    [PS] C:\Users\adminex\Desktop>Get-FrontendTransportService

    Name
    ----
    SUMZEX

    9 октября 2019 г. 11:44
  • Get-TransportService | fl ExternalDNSServers,InternalDNSServers,ExternalDNSAdapterEnabled,InternalDNSAdapterEnabled

    Get-FrontendTransportService | fl ExternalDNSServers,InternalDNSServers,ExternalDNSAdapterEnabled,InternalDNSAdapterEnabled
    9 октября 2019 г. 11:48
  • [PS] C:\Users\adminex\Desktop>Get-TransportService | fl ExternalDNSServers,InternalDNSServers,ExternalDNSAdapterEnabled,
    InternalDNSAdapterEnabled


    ExternalDNSServers        : {10.33.0.242}
    InternalDNSServers        : {10.33.0.242}
    ExternalDNSAdapterEnabled : True
    InternalDNSAdapterEnabled : True



    [PS] C:\Users\adminex\Desktop>Get-FrontendTransportService | fl ExternalDNSServers,InternalDNSServers,ExternalDNSAdapter
    Enabled,InternalDNSAdapterEnabled


    ExternalDNSServers        : {10.33.0.242}
    InternalDNSServers        : {10.33.0.242}
    ExternalDNSAdapterEnabled : True
    InternalDNSAdapterEnabled : True
    9 октября 2019 г. 11:52
  • 10.33.0.242 это адрес вашего контроллера домена?
    А на уровне ОС нет внешних ДНС серверов на этом интерфейсе в Exchange?

    ipconfig /all
    9 октября 2019 г. 11:56
  • да это адрес контроллера, нет внешних днс нету

    C:\Users\adminex>ipconfig /all

    Настройка протокола IP для Windows

       Имя компьютера  . . . . . . . . . : sumzex
       Основной DNS-суффикс  . . . . . . : sumz.umn.ru
       Тип узла. . . . . . . . . . . . . : Гибридный
       IP-маршрутизация включена . . . . : Нет
       WINS-прокси включен . . . . . . . : Нет
       Порядок просмотра суффиксов DNS . : sumz.umn.ru

    Ethernet adapter Ethernet:

       DNS-суффикс подключения . . . . . :
       Описание. . . . . . . . . . . . . : Контроллер семейства Realtek PCIe GBE
       Физический адрес. . . . . . . . . : 34-64-A9-2F-09-70
       DHCP включен. . . . . . . . . . . : Нет
       Автонастройка включена. . . . . . : Да
       Локальный IPv6-адрес канала . . . : fe80::3cbb:f6dc:c52:7792%12(Основной)
       IPv4-адрес. . . . . . . . . . . . : 10.33.0.244(Основной)
       Маска подсети . . . . . . . . . . : 255.255.252.0
       Основной шлюз. . . . . . . . . : 10.33.0.2
       IAID DHCPv6 . . . . . . . . . . . : 255091881
       DUID клиента DHCPv6 . . . . . . . : 00-01-00-01-1F-BD-78-7B-34-64-A9-2F-09-70

       DNS-серверы. . . . . . . . . . . : 10.33.0.242
       NetBios через TCP/IP. . . . . . . . : Включен

    Туннельный адаптер isatap.{563CBB11-BFB0-45BC-B1C8-B65443496991}:

       Состояние среды. . . . . . . . : Среда передачи недоступна.
       DNS-суффикс подключения . . . . . :
       Описание. . . . . . . . . . . . . : Адаптер Microsoft ISATAP #2
       Физический адрес. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP включен. . . . . . . . . . . : Нет
       Автонастройка включена. . . . . . : Да

    9 октября 2019 г. 11:58
  • 5. View internet message headers in Outlook

    У вас сообщение из OWA было доставленно в почтовый ящик, значит оно прошло через транспорт.

    Его можно прочмотреть через Message Header Analyzer https://testconnectivity.microsoft.com/


    MCITP, MCSE. Regards, Oleg

    9 октября 2019 г. 11:59
    Модератор
  • Когда отправляю из owa сообщение падает в черновики
    9 октября 2019 г. 12:01
  • Когда отправляю из owa сообщение падает в черновики

    Это письмо надо открыть проверить headers почему оно попадает в черновики.

    У вас FW включен на сервере или выключен? 

    Когда вы устанавливали Exchange FW был ключен или выключен?


    MCITP, MCSE. Regards, Oleg

    9 октября 2019 г. 12:45
    Модератор
  • Включен, но создано правило разрешающее все
    9 октября 2019 г. 12:59
  • Исправить получилось только полной очисткой AD от exchange и переустановкой exchange
    21 ч. 28 мин. назад