locked
CentOS-based VM hangs if the VM is warm rebooted RRS feed

  • Вопрос

  • 2 VMS with the following setup:

    1. CentOS-based VM with custom kernel 3.12.43 and Hyper-V LIS modules running as Gen1 on Hyper-V 2012 R2.
    2. Original CentOS 6.6 with kernel 2.6.32 from a fresh installation. No configs whatsoever. 

    The VMs boot fine. If you restart the OS (e.g. # reboot) it gets stuck just after displaying the grub entry that the system automatically selected. The cursor stays blinking. The only way to get the VM back is to Turn it off and then Turn it back on. 

    I was reading that this could be something related with the IDE controller. I have already deleted the CD drive and I have no SCSI controllers in the VM.

    Any ideas?

    thanks



    18 июня 2015 г. 20:43

Все ответы

  • Did you install LIS with the installer script or by directly loading the RPMs? It sounds like you have a conflict between the built-in and LIS kernel modules.

    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    30 июня 2015 г. 19:09
  • VM with kernel 3.12 -->  I compiled the kernel enabling LIS support, so it got whatever version of LIS Microsoft has ported on this kernel version (which is longterm support at kernel.org)

    VM with CentOS 6.6 --> this distro came with LIS support out of the box. We had the issues with it and tried upgrading the LIS to version 4.0 using the ./upgrade.sh script included in the ISO with the LIS modules. 

    Thanks !

    30 июня 2015 г. 19:18
  • You may have better results removing the LIS support that you compiled in and using the RPMs provided in the LIS 4.0 release, but without testing your custom kernel, I cannot make any guarantees.

    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    27 июля 2015 г. 18:16
  • I even tried with a standard CentOS 6 (no modifications at all) and got the same results. Warm reboot results in the VM stuck when booting up. 

    I tried another CentOS 6 but 64 bits and didn't have any problems. So it looks like Hyper-V doesn't like the 32 bits version of CentOS. 

    Any ideas? 

    27 июля 2015 г. 18:24
  • We test 32-bit CentOS 6 and do not encounter problems booting on Hyper-V unless there is a conflict in the kernel modules (LIS 4.0 installed at the same time as the built-in LIS). This is why the installer and updater removes previous versions of the LIS kernel modules before installing the latest versions.

    When you upgrade the kernel, you also have to remove LIS and reinstall it after upgrading, as upgrades often reinstall the built-in versions of the drivers.


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    27 июля 2015 г. 18:41
  • Oh, I've already tried that without any luck  :(
    27 июля 2015 г. 18:59
  • Have you solved the problem? I still have a same problem with other 32-bits Linux distro (Ubuntu 14, Debian 6, RHEL) on Hyper-V G1 VMs.
    19 октября 2015 г. 11:21
  • I gave up... I was trying to bring an Endian Firewall VM onto Hyper-V but ended up using PFSense (much better and full HV support)
    20 октября 2015 г. 2:41
  • We are tracking a 32-bit bug on Ubuntu and SLES, but that only applies to the most recent kernels.

    We don't recommend Debian 6.

    On RHEL are you using Linux Integration Services 4.0.11?

    Thanks, --jrp


    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    20 октября 2015 г. 4:33
  • Hi Josh.
    Can you tell me bug # (or url) of bug in Ubuntu bug tracker ?

    Josh, you can help me with my problem?

    https://social.technet.microsoft.com/Forums/ru-RU/74691cd5-5fb5-4670-bfa2-39d6e4dc3314/ubuntu-1404-32bit-on-hyperv-g1-vm?forum=linuxintegrationservices

    20 октября 2015 г. 10:04
  • https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1495983 is the 43-bit installation bug on Ubuntu.

    Joshua R. Poulson, Program Manager, Microsoft Open Source Technology Center

    3 ноября 2015 г. 0:48