none
не устанавливается клиент sccm 2012 на старые ПК RRS feed

  • Вопрос

  • Старых компов около 20, но не могут клиенты сццм 2012 R2 стать на 6 компов.  например, не может стать на комп с : Amd Sempron 2200+ 1.5 GGz и 512 Mb памяти

    устанавливая клиента вручную, в логе ccmsetup такое предупреждение:


    устанавливая клиента с сервера, в логе ccmsetup такая ошибка:

    а в логе ccm такая ошибка:

    Проверил след службы:
    Windows Installer (вкл), RPC (вкл), WMI (вкл), BITS (вкл), Windows Firewall (выкл). Подключение в разные VLAN ничё не дало.

    Но на ПК с AMD Sempron 3000+ 1.8 Ггц и 512 Мб памяти клиент установился !!!  Что означают ошибка и предупрежденеи? почему на некоторые компы не становится клиент?? что ещё можно предпринять?

Все ответы

  • Клиент не смог получить информацию о системе из WMI. Это скорее всего связано с тем что WMI репозиторий поврежден.

    подробный мануал по  Repair WMI можете прочитать тут: https://blogs.technet.microsoft.com/askperf/2009/04/13/wmi-rebuilding-the-wmi-repository/

    • Предложено в качестве ответа Sergey Shostak 18 мая 2016 г. 13:29
  • такое возникает даже на новой ОС, свежеустановленной !!
    1. Change startup type to Window Management Instrumentation (WMI) Service to disabled
    2. Stop the WMI Service; you may need to stop IP Helper Service first or other dependent services before it allows you to stop WMI Service
    3. Rename the repository folder:  C:\WINDOWS\system32\wbem\Repository to Repository.old
    4. Open a CMD Prompt with elevated privileges
    5. CD windows\system32\wbem
    6. for /f %s in (‘dir /b /s *.dll’) do regsvr32 /s %s
    7. Set the WMI Service type back to Automatic and start WMI Service
    8. cd /d c:\  ((go to the root of the c drive, this is important))
    9. for /f %s in (‘dir /s /b *.mof *.mfl’) do mofcomp %s
    10. Reboot the server
    11. проделал 10 шагов - не помогло. всё те же ошибки.


  • Полный лог куда-нибудь скиньте.

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • Полный лог куда-нибудь скиньте.

    Сазонов Илья

    https://isazonov.wordpress.com/

    на почту можно?
  • На любой файлообменник положите, чтобы специалисты посмотрели ваш лог.

    Сазонов Илья

    https://isazonov.wordpress.com/

    Модератор
  • с помощью многих переустановок ОС и догадок выявил, что клиент версии 5.00.8239.100 не устанавливается на ПК с процом менее 1.8 Ггц. может вы что-то подскажете??

    вот лог ccmsetup (при установке клиента вручную) или самый первый скрин :

    <![LOG[==========[ ccmsetup started in process 608 ]==========]LOG]!><time="10:05:27.395-180" date="05-19-2016" component="ccmsetup" context="" type="1" thread="564" file="ccmsetup.cpp:9601">
    <![LOG[Updated security on object C:\WINDOWS\ccmsetup\cache\.]LOG]!><time="10:05:27.411-180" date="05-19-2016" component="ccmsetup" context="" type="0" thread="564" file="ccmsetup.cpp:9445">
    <![LOG[Launch from folder N:\soft\Corporate\MS System Center 2012\MS SCCM 2012\SCCM 2012 R2\Client\Client\]LOG]!><time="10:05:27.411-180" date="05-19-2016" component="ccmsetup" context="" type="1" thread="564" file="ccmsetup.cpp:680">
    <![LOG[CcmSetup version: 5.0.8239.1001]LOG]!><time="10:05:27.411-180" date="05-19-2016" component="ccmsetup" context="" type="1" thread="564" file="ccmsetup.cpp:686">
    <![LOG[Running on 'Microsoft Windows XP Professional' (5.1.2600). Service Pack (3.0). SuiteMask = 272. Product Type = 18]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="1" thread="564" file="util.cpp:2000">
    <![LOG[Ccmsetup command line: "N:\soft\Corporate\MS System Center 2012\MS SCCM 2012\SCCM 2012 R2\Client\Client\ccmsetup.exe" ]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="1" thread="564" file="ccmsetup.cpp:3719">
    <![LOG[Local Machine is joined to an AD domain]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="0" thread="564" file="lsad.cpp:732">
    <![LOG[Current AD forest name is ukrenergo.ent, domain name is dbes.ukrenergo.ent]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="1" thread="564" file="lsad.cpp:860">
    <![LOG[Domain joined client is in Intranet]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="1" thread="564" file="lsad.cpp:1071">
    <![LOG[DhcpGetOriginalSubnetMask entry point not supported.]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="2" thread="564" file="ccmiputil.cpp:105">
    <![LOG[Begin checking Alternate Network Configuration]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="0" thread="564" file="ccmiputil.cpp:1095">
    <![LOG[Finished checking Alternate Network Configuration]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="0" thread="564" file="ccmiputil.cpp:1172">
    <![LOG[Adapter {40E4576A-036B-4111-AE43-75BBCAC32C4F} is DHCP enabled. Checking quarantine status.]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="0" thread="564" file="ccmiputil.cpp:436">
    <![LOG[Adapter {8992E4BD-688A-4C2B-B65E-B93529450577} is DHCP enabled. Checking quarantine status.]LOG]!><time="10:05:27.457-180" date="05-19-2016" component="ccmsetup" context="" type="0" thread="564" file="ccmiputil.cpp:436">

  • Можно посмотреть полный лог?
  • папку ccsmsetup удалил, и заново запустил установку вручную. щас это полный лог.
  • Ccmsetup command line: "N:\soft\Corporate\MS System Center 2012\MS SCCM 2012\SCCM 2012 R2\Client\Client\ccmsetup.exe"

    вы устанавливаете без параметра, а надо с параметрами как минимум сайт код.

    ccmsetup.exe SMSSITECODE= <сайт код вашего сайта>

    Все параметры установки: https://technet.microsoft.com/ru-ru/library/gg699356.aspx?f=255&MSPPError=-2147217396

  • на 15 других ПК установилось без указания параметров !!
  • так сложно сказать не видя полной информации, как проводилась инсталяция, ПК в домене или нет, логи и тп. Могу предположить, что на данных ПК была уже до этого инсталяция клиента и он использовались параметры из HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCMSetup\LastSuccessfulInstallParams.
  • нет, где не получалось установить клиента сразу, ОС переустанавливалась и такое предупреждение "DHCP... " возникало на новой ОС. да, пк в домене, установка производится запуском ccmsetup.exe.
  • руками что-ли городите? Пуш-инсталл пробовали? Какая версия сццм? Разрешена ли автоматическая принудительная установка при обнаружении?
  • да , руками горожу !!! на многие ПК клиент установился с сервера, ПУШ-инсталл !!  на многие старые ПК он не ставился. Поэтому приходилось вручную, иногда с переустановкой ОС. Версия СЦЦМ 5.0.8239.1000 .
  • По WMI попробуйте такой фикс на брандмауер, бывает закрыта совсем подгруппа пропуска

    для русской версии ОС (если запускать через пакетный файл, то вот так, файл сохранить в кодировке OEM-866)
    netsh advfirewall firewall set rule group="€­бва㬥­в аЁ© гЇа ў«Ґ­Ёп Windows (WMI)" new enable=yes
    Если просто из cmd
    netsh advfirewall firewall set rule group="Инструментарий управления Windows (WMI)" new enable=yes
    Для английской версии ОС
    netsh advfirewall firewall set rule name="Windows Management Instrumentation (WMI)" new enable=yes


    • Изменено NTLose 25 мая 2016 г. 7:06
  • службу брандмауэр везде отключаю !!
  • Вы привели странный лог.

    Давайте Вы запустите пуш-инсталл, и вот с него и приведете лог из

    %windir%\ccmsetup\logs\ccmsetup.log

    А то вот это все ручное покоцанное ничего не проясняет

  • могу сразу сказать что установка производить только с параметром, минимум SMSSITECODE. Даже для Push install в SCCM необходимо указать параметры установки в настройках.

    По поводу того что у вас не подключается к ПК, нет либо прав, файрвол (от ОС или антивируса).

    P.S. если вы опускаете службу брандмауэра на Win7 вы заблокируете все входящие соединения, это применимо только к WinXP.



  • да, но почему с такими же настройками на других WinXP (отключенный брандмауэр и включённые все те же службы, и даже на свежепереустановленную ОС) установка клиента происходит?? код сайта и MP определяется без проблем, устанавливая хоть вручную, хоть с сервера !!! вот лог ccmsetup при установке клиента с сервера:

    <![LOG[==========[ ccmsetup started in process 304 ]==========]LOG]!><time="12:28:34.923-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="536" file="ccmsetup.cpp:9601">
    <![LOG[Launch from folder C:\WINDOWS\ccmsetup\]LOG]!><time="12:28:34.923-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="536" file="ccmsetup.cpp:680">
    <![LOG[CcmSetup version: 5.0.8239.1001]LOG]!><time="12:28:34.923-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="536" file="ccmsetup.cpp:686">
    <![LOG[In ServiceMain]LOG]!><time="12:28:34.938-180" date="05-26-2016" component="ccmsetup" context="" type="0" thread="1520" file="ccmsetup.cpp:3492">
    <![LOG[Running on 'Microsoft Windows XP Professional' (5.1.2600). Service Pack (3.0). SuiteMask = 272. Product Type = 18]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="util.cpp:2000">
    <![LOG[Ccmsetup command line: "C:\WINDOWS\ccmsetup\ccmsetup.exe" /runservice /config:MobileClient.tcf]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:3719">
    <![LOG[Command line parameters for ccmsetup have been specified.  No registry lookup for command line parameters is required.]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:3924">
    <![LOG[Command line: "C:\WINDOWS\ccmsetup\ccmsetup.exe" /runservice /config:MobileClient.tcf]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:3925">
    <![LOG[SslState value: 224]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="0" thread="1520" file="ccmsetup.cpp:4572">
    <![LOG[CCMHTTPPORT:    80]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:8781">
    <![LOG[CCMHTTPSPORT:    443]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:8796">
    <![LOG[CCMHTTPSSTATE:    480]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:8814">
    <![LOG[CCMHTTPSCERTNAME:    ]LOG]!><time="12:28:34.970-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:8832">
    <![LOG[FSP:    ]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:8884">
    <![LOG[CCMFIRSTCERT:    1]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:8942">
    <![LOG[Config file:      C:\WINDOWS\ccmsetup\MobileClientUnicode.tcf]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4686">
    <![LOG[Retry time:       10 minute(s)]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4687">
    <![LOG[MSI log file:     C:\WINDOWS\ccmsetup\Logs\client.msi.log]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4688">
    <![LOG[MSI properties:    INSTALL="ALL" SMSSITECODE="SSS" CCMHTTPPORT="80" CCMHTTPSPORT="443" CCMHTTPSSTATE="480" CCMFIRSTCERT="1"]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4689">
    <![LOG[Source List:]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4697">
    <![LOG[                  \\S-SCCM02.es.ent\SMSClient]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4704">
    <![LOG[                  \\S-SCCM02.ES.ENT\SMSClient]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4713">
    <![LOG[MPs:]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4716">
    <![LOG[                  S-SCCM02.es.ent]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:4731">
    <![LOG[No version of the client is currently detected.]LOG]!><time="12:28:34.985-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:2875">
    <![LOG[Updated security on object C:\WINDOWS\ccmsetup\.]LOG]!><time="12:28:35.001-180" date="05-26-2016" component="ccmsetup" context="" type="0" thread="1520" file="ccmsetup.cpp:9445">
    <![LOG[Failed to get client version for sending state messages. Error 0x8004100e]LOG]!><time="12:28:35.001-180" date="05-26-2016" component="ccmsetup" context="" type="2" thread="1520" file="state.cpp:178">
    <![LOG[Params to send '5.0.8239.1001 Deployment Error: ']LOG]!><time="12:28:35.001-180" date="05-26-2016" component="ccmsetup" context="" type="0" thread="1520" file="state.cpp:215">
    <![LOG[A Fallback Status Point has not been specified and no client was installed.  Message with STATEID='100' will not be sent.]LOG]!><time="12:28:35.001-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="state.cpp:229">
    <![LOG[Failed to send status 100. Error (87D00215)]LOG]!><time="12:28:35.001-180" date="05-26-2016" component="ccmsetup" context="" type="3" thread="1520" file="state.cpp:242">
    <![LOG[Running as user "SYSTEM"]LOG]!><time="12:28:35.595-180" date="05-26-2016" component="ccmsetup" context="" type="1" thread="1520" file="ccmsetup.cpp:2018">

    вот как ошибка выглядит:


    • Изменено serg_23 26 мая 2016 г. 9:53 4