none
Exchange 2013 вытащил из DAG RRS feed

  • Вопрос

  • Добрый день. На самом деле всё просто. Вот рисунок работающей продакшн среды. Был изолирован из этой среды один домен контроллер DC1 и один почтовый сервер EX1 ( на рисунке под ним). DC1 запустился, всё на нем можно делать как и раньше (только ругается что нет партнеров по репликации, сайты он не видит, ну пока оставил как есть). А вот почтовый сервер запускается на половину, то есть я не могу попасть в ECP, я не могу запустить ExchnageShell что бы элементарно выполнить команды Test-Servicehealth или Test-MappiConnectivity и т.п. Вопрос, куда копать и что я упустил? Ещё уточню, все службы MsExchange - одна треть не работала, запустил вручную, но подключиться к серверу по прежнему не могу.


    • Изменено user00431 11 октября 2016 г. 12:55
    11 октября 2016 г. 12:55

Ответы

  • Сначала переустановил сетевые карты на почт серверах на случай если они глючили. Ничего не изменилось. Потом занялся вычищением AD от отсутствующих домен-контроллеров. Сперва ntdsutil, далее в Сайтах и службах, далее в DNS удалил отсутств ДК в серверах имен для всех папок). В итоге Оставшийся ДК заработал полностью, перестал ругаться что нет др домен-контроллеров, тест dcdiag проходит успешно. Единств на что ругается dcdiag, что некоторые политики, не применяются на др ДК, думаю просто удалить эти политики или исправить.

    На почтовых серверах после их перезагрузки, службы MsExchange***(порядка 8) не стартуют автоматически. Но! стоит их запустить вручную (запускаю прям из Dashboard в Server Manager, выделяю разом и - Запустить) и почтовые сервера  начинают работать. Проделываю с первым сервером в DAG и со вторым в DAG. На каком моменте ситуация изменилась в лучшую сторону, пока не понял, то ли действительно вычищение каталога AD от старых ДК помоголо, то ли что то другое, но возможно всё же вычищение каталога AD. Автоматом службы exchange так и не стартуют, но зато после руч запуска всё работает и даже базы данных, которые я перенес (две из пяти и только для одного primary почт сервера в DAG). Проходят тесты: test-servicehealth, test-mapiconnectivity (естеств для доступных БД), get-mailboxdatabase, get-mailbox получатель и т.п., создаются новые уч записи в автоматически доступных баз данных и почта ходит внутри среды.

    • Помечено в качестве ответа user00431 19 октября 2016 г. 11:32
    19 октября 2016 г. 11:32

Все ответы

  • А что на этой схеме ex2? Iis запущен?

    scientia potentia est
    My blog

    11 октября 2016 г. 16:24
  • добрый день. не понял вопроса. на это схеме всё запущено и работает. а два сервера я скопировал (обычным копированием дисков vhdx) и изолировал в отдельный vlan. 


    • Изменено user00431 12 октября 2016 г. 12:43
    12 октября 2016 г. 12:40
  • в смысле вы развернули второй сервер Exchange простым копированием диска?

    Вопрос в том, что у вас на схеме два сервера, а вы говорите в описании про один. Про второй ни слова.

    Вопрос про IIS касался службы World Wide Web Services


    scientia potentia est
    My blog

    12 октября 2016 г. 14:08
  • -нет, второй exchange давно развернут с нуля и состоит в группе dag. копированием я "вытащил" два сервера DC1 и EX1 и поместил их в отдельный vlan. теоретически в получившейся новой среде должны работать оба сервера. ладно, я сейчас пока попробую "вытащить" два exch сервера (весь dag) но без баз данных и теоретически, опять, почта должна только ругаться что все базы данных недоступны. но попадать в панель управления я вроде как должен. отпишусь как сделаю..
    • Изменено user00431 13 октября 2016 г. 7:56
    13 октября 2016 г. 7:56
  • Сначала переустановил сетевые карты на почт серверах на случай если они глючили. Ничего не изменилось. Потом занялся вычищением AD от отсутствующих домен-контроллеров. Сперва ntdsutil, далее в Сайтах и службах, далее в DNS удалил отсутств ДК в серверах имен для всех папок). В итоге Оставшийся ДК заработал полностью, перестал ругаться что нет др домен-контроллеров, тест dcdiag проходит успешно. Единств на что ругается dcdiag, что некоторые политики, не применяются на др ДК, думаю просто удалить эти политики или исправить.

    На почтовых серверах после их перезагрузки, службы MsExchange***(порядка 8) не стартуют автоматически. Но! стоит их запустить вручную (запускаю прям из Dashboard в Server Manager, выделяю разом и - Запустить) и почтовые сервера  начинают работать. Проделываю с первым сервером в DAG и со вторым в DAG. На каком моменте ситуация изменилась в лучшую сторону, пока не понял, то ли действительно вычищение каталога AD от старых ДК помоголо, то ли что то другое, но возможно всё же вычищение каталога AD. Автоматом службы exchange так и не стартуют, но зато после руч запуска всё работает и даже базы данных, которые я перенес (две из пяти и только для одного primary почт сервера в DAG). Проходят тесты: test-servicehealth, test-mapiconnectivity (естеств для доступных БД), get-mailboxdatabase, get-mailbox получатель и т.п., создаются новые уч записи в автоматически доступных баз данных и почта ходит внутри среды.

    • Помечено в качестве ответа user00431 19 октября 2016 г. 11:32
    19 октября 2016 г. 11:32
  • Exchange очень сильно зависит от ad. Службы не стартуют потому что сеть не успевает подняться скорее всего. Поставьте все службы в отложенный автозапуск

    scientia potentia est
    My blog

    19 октября 2016 г. 11:52