none
Не работает OWA после обновления до CU6 Ошибка: ASP.NET 4.0.30319.0 Event ID 1309 Event Code 3005 RRS feed

  • Вопрос

  • Exchange 2016

    Различные варианты пока не исправили проблему.

    Подскажите решение. 

    *************************************************************************************

    Браузер пишет при подключении: https:/**********/owa/auth/errorFE.aspx?httpCode=500

    :-( Something went wrong We can't get that information right now. Please try again later. X-ClientId: 89EA949542D74EB8BE14D7489D593E0B X-FEServer: EX

    *************************************************************************************

    Event code: 3005 
    Event message: Возникло необработанное исключение. 
    Event time: 08.08.2017 12:57:46 
    Event time (UTC): 08.08.2017 9:57:46 
    Event ID: 0ff6bc0fcc4e452dbb47bab45f18b136 
    Event sequence: 2 
    Event occurrence: 1 
    Event detail code: 0 
     
    Application information: 
        Application domain: /LM/W3SVC/2/ROOT/owa-4-131466598515909064 
        Trust level: Full 
        Application Virtual Path: /owa 
        Application Path: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa\ 
        Machine name: EX 
     
    Process information: 
        Process ID: 26096 
        Process name: w3wp.exe 
        Account name: NT AUTHORITY\СИСТЕМА 
     
    Exception information: 
        Exception type: TargetInvocationException 
        Exception message: Адресат вызова создал исключение.
       в System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
       в System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
       в System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
       в Owin.Loader.DefaultLoader.<>c__DisplayClass12.<MakeDelegate>b__b(IAppBuilder builder)
       в Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
       в Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action`1 startup)
       в Microsoft.Owin.Host.SystemWeb.OwinBuilder.Build(Action`1 startup)
       в Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint()
       в System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory)
       в Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
       в System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       в System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       в System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       в System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Encryption certificate is absent
       в Microsoft.Exchange.Security.Authentication.Utility.GetCertificates()
       в Microsoft.Exchange.Clients.Owa2.Server.Core.notifications.SignalR.SignalRStartup.Configuration(IAppBuilder app)

     
     
    Request information: 
        Request URL: https://localhost:444/owa/proxylogon.owa 
        Request path: /owa/proxylogon.owa 
        User host address: ::1 
        User:  
        Is authenticated: False 
        Authentication Type:  
        Thread account name: NT AUTHORITY\СИСТЕМА 
     
    Thread information: 
        Thread ID: 45 
        Thread account name: NT AUTHORITY\СИСТЕМА 
        Is impersonating: False 
        Stack trace:    в System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
       в System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
       в System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
       в Owin.Loader.DefaultLoader.<>c__DisplayClass12.<MakeDelegate>b__b(IAppBuilder builder)
       в Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
       в Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action`1 startup)
       в Microsoft.Owin.Host.SystemWeb.OwinBuilder.Build(Action`1 startup)
       в Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint()
       в System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory)
       в Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
       в System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
       в System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
       в System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
       в System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
     
     
    8 августа 2017 г. 10:45

Ответы

  • Да, наши люди и там отметились. itpadla

    Я так понимаю, старый добрый .\updatecas.ps1 решает проблему.


    Да, я коряво вставил решение) исправил

    scientia potentia est
    My blog

    10 августа 2017 г. 15:58
  • После CU6 как я понимаю много у кого проблемы появились, в том числе эта.

    Почитайте у Родерика в коментах:

    https://blogs.technet.microsoft.com/rmilne/2017/06/27/exchange-2016-cu6-released/

    Cause:
    most probable cause is web.config file corruption

    Resolution:
    did research, all cases that I can find were pointing to corruption of web.config file under %Exchangeinstallpath%\ClientAccess\OWA , but we have already recreated this. Decided to recreate it with a brand new file, and I copied the contents of it, created a new web.config file using notepad and pasted it in the new file. Ran iisreset. stll no go. Tried to run .\updatecas.ps1 so that we can restore files in front end, if there are any stale entries of the old corrupted files. ran iis reset and issue was resolved.


    scientia potentia est
    My blog


    10 августа 2017 г. 15:00

Все ответы

  • https://support.microsoft.com/en-us/help/3099532/event-id-1309-and-you-can-t-access-owa-and-ecp-after-you-install-excha   Пробовали?
    8 августа 2017 г. 10:53
  • Да. Ничего не поменялось. 
    8 августа 2017 г. 11:09
  • А может быть в обновлении вирус? 

    Только что нашло это антивирусом microsoft при плановой проверке и owa открылась:

    Произошла следующая ошибка: Код ошибки 0x80508023. Не удалось найти вредоносные и другие потенциально нежелательные программы на этом компьютере. 

    Категория: Средство кражи паролей

    Описание: Эта опасная программа перехватывает пароли пользователей.

    Рекомендуемое действие: Немедленно удалите это программное обеспечение.

    Объекты: 
    file:C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\owa\f1907565\9fa11d9f\zp3ar20i.res->[HtmlCmtOut]->(SCRIPT0013)
     
    8 августа 2017 г. 11:37
  • Раз видите сообщение- стало быть вирус. Перекачайте СU с сайта загрузок МС, удалите вирусы и обновите сервер повторно.
    8 августа 2017 г. 12:47
  • CU проверил антивирус ничего не нашел.

    Вирус несколько раз находило в tmp ASP после установки.

    Перед обновлением была проверка на вирусы а после обновления owa не поднялась никак пока не прошла повторная проверка и нашла там вирус.

    9 августа 2017 г. 10:52
  • Если сейчас все еще есть проблема- пересоздайте директорию OWA через Powershell.
    9 августа 2017 г. 10:55
  • После CU6 как я понимаю много у кого проблемы появились, в том числе эта.

    Почитайте у Родерика в коментах:

    https://blogs.technet.microsoft.com/rmilne/2017/06/27/exchange-2016-cu6-released/

    Cause:
    most probable cause is web.config file corruption

    Resolution:
    did research, all cases that I can find were pointing to corruption of web.config file under %Exchangeinstallpath%\ClientAccess\OWA , but we have already recreated this. Decided to recreate it with a brand new file, and I copied the contents of it, created a new web.config file using notepad and pasted it in the new file. Ran iisreset. stll no go. Tried to run .\updatecas.ps1 so that we can restore files in front end, if there are any stale entries of the old corrupted files. ran iis reset and issue was resolved.


    scientia potentia est
    My blog


    10 августа 2017 г. 15:00
  • Да, наши люди и там отметились. itpadla

    Я так понимаю, старый добрый .\updatecas.ps1 решает проблему.

    10 августа 2017 г. 15:14
  • Да, наши люди и там отметились. itpadla

    Я так понимаю, старый добрый .\updatecas.ps1 решает проблему.


    Да, я коряво вставил решение) исправил

    scientia potentia est
    My blog

    10 августа 2017 г. 15:58
  • У меня такая же проблема с OWA после установки CU6

    Стоит 2 сервера объединенные в DAG. В добавок несколько пользователей не могут по mapi подсоединиться к exchange.

    6 сентября 2017 г. 22:29