none
Не запускается служба синхронизации профилей RRS feed

  • Вопрос

  • Здравствуйте, коллеги.
    Есть сервер Windows 2008 R2 SP1 c Sharepoint 2010 SP1 с апрельским CU.

    Сервер один, т.е. MSSQL + все приложения на нем.

    Возникла проблема со службой синхронизации пользователей - не хочет запускаться. При нажатии на "запустить" и вводе пароля пользователя (пользователь доменный, под его именем работает сервер) некоторое время висит в состоянии "Запуск", потом опять "Остановлено". В логах ошибок вроде нет. Обе службы FIM не запущены, руками не запускаются.
    Подскажите куда копнуть.

Ответы

  •  MindFreedom была подобная проблема после установки обновления kb2598152

    Помогло следующее:

    1. После обновления запустил SharePoint 2010 Products Configuration Wizard несколько раз.

    2. перезапустил IIS

    3.в central Administration-Services of Server запустил все остановленные службы и последней:

    User Profile Synchronization Service

    4.перезапустил IIS

    • Помечено в качестве ответа Roman Zhukov 6 июля 2012 г. 14:03
    14 июня 2012 г. 13:05
  • Уважаемый IL De, можно поподробнее про "июньский CU и декабрский CU". Это они:?

    December 2011 CU SharePoint Server 2010​ KB 2597014
    June 2011 CU SharePoint Server 2010​ KB 2536599
    June 2011 CU SharePoint Server with Project Server KB 2536590

    взято отсюда

    В частности, после установки kb2598152 возникла проблема с неправильной синхронизацией пользователей из AD.

    Поле "Account name" имеет вид "DomainName\username"  вместо необходимого "DomainName-XX\username", причем не у всех пользователей.

    Могут мне помочь данные обновления?

    Проблема решилась следующим образом:

    Заработало не сразу, поэтому помогло что-то из нижеперечисленного:

    Сделал

    $UPA = Get-SPServiceApplication –Id 79c8aa90-4c43-4d29-8375-4a40798669e0

    $UPA.NetBIOSDomainNamesEnabled=1

    $UPA.Update()

    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/39fb47df-4489-4217-98f7-90192b8689ca

     запускал синхронизацию несколько раз с TRUE (1) и False (0)

     затем

    Выполнил команды:

    stsadm -o sync -listolddatabases 1

    stsadm -o sync -deleteolddatabases 1

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/307d767f-a85b-4a8a-b520-adbd5295ac2b

    перезапустил службу UPS

    и через час сработало.



    • Изменено Michael Swan 14 июня 2012 г. 13:11
    • Помечено в качестве ответа Roman Zhukov 6 июля 2012 г. 14:03
    14 июня 2012 г. 11:18

Все ответы

  • http://www.harbar.net/articles/sp2010ups.aspx

    Делай все точно по инструкции

  • Поставь июньский CU и декабрский CU.

    Запускаться служба должная от имени локального админа. чтобы запустились 2 службы Fims в локальных службах сервера. Как службы запустятся, сделай IISreset а лучше полность перегрузи сервер.

  • Стоит CU от апреля 2012.
    Сейчас пытаюсь сделать все по  инструкции http://www.harbar.net/articles/sp2010ups.aspx
    Посмотрим.
  • Стоит CU от апреля 2012.
    Сейчас пытаюсь сделать все по  инструкции http://www.harbar.net/articles/sp2010ups.aspx
    Посмотрим.

    Все равно: Поставь июньский CU и декабрский CU.
  • Уважаемый IL De, можно поподробнее про "июньский CU и декабрский CU". Это они:?

    December 2011 CU SharePoint Server 2010​ KB 2597014
    June 2011 CU SharePoint Server 2010​ KB 2536599
    June 2011 CU SharePoint Server with Project Server KB 2536590

    взято отсюда

    В частности, после установки kb2598152 возникла проблема с неправильной синхронизацией пользователей из AD.

    Поле "Account name" имеет вид "DomainName\username"  вместо необходимого "DomainName-XX\username", причем не у всех пользователей.

    Могут мне помочь данные обновления?

    Проблема решилась следующим образом:

    Заработало не сразу, поэтому помогло что-то из нижеперечисленного:

    Сделал

    $UPA = Get-SPServiceApplication –Id 79c8aa90-4c43-4d29-8375-4a40798669e0

    $UPA.NetBIOSDomainNamesEnabled=1

    $UPA.Update()

    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/39fb47df-4489-4217-98f7-90192b8689ca

     запускал синхронизацию несколько раз с TRUE (1) и False (0)

     затем

    Выполнил команды:

    stsadm -o sync -listolddatabases 1

    stsadm -o sync -deleteolddatabases 1

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/307d767f-a85b-4a8a-b520-adbd5295ac2b

    перезапустил службу UPS

    и через час сработало.



    • Изменено Michael Swan 14 июня 2012 г. 13:11
    • Помечено в качестве ответа Roman Zhukov 6 июля 2012 г. 14:03
    14 июня 2012 г. 11:18
  •  MindFreedom была подобная проблема после установки обновления kb2598152

    Помогло следующее:

    1. После обновления запустил SharePoint 2010 Products Configuration Wizard несколько раз.

    2. перезапустил IIS

    3.в central Administration-Services of Server запустил все остановленные службы и последней:

    User Profile Synchronization Service

    4.перезапустил IIS

    • Помечено в качестве ответа Roman Zhukov 6 июля 2012 г. 14:03
    14 июня 2012 г. 13:05