none
Ссылки на страницы портала ведут на главную страницу RRS feed

  • Вопрос

  • Имею Sharepoint Server 2013.

    У меня есть портал, доступный из корпоративный сети: http://portal. К порталу есть доступ извне сети: https://site:port. Доступ извне настраивал админ сети, я не знаю как, но не средствами шарепоинта.

    При попытке открыть любую ссылку на страницу, например: https://site:port/page/library/ выполняется переадресация на главную страницу: https://site:port. При этом если открывать по ссылке, доступной из корпоративной сети http://portal/page/library/, то все работает как надо.

    Почему может происходить переадресация на главную страницу?

    22 января 2015 г. 7:56

Ответы

Все ответы

  • Добрый день

    думаю настроен редирект средствами IIS. Предлагаю посмотреть что там настроено.

    а после настроить 

    Настройка альтернативных сопоставлений доступа для SharePoint 2013

    • Предложено в качестве ответа Maxim Shusharin 22 января 2015 г. 9:06
    22 января 2015 г. 8:49
    Модератор
  • Добрый день, спасибо за ответ.

    Что именно нужно проверить? Я с iis не дружу.

    22 января 2015 г. 10:12
  • Добрый день, спасибо за ответ.

    Что именно нужно проверить? Я с iis не дружу.

    Первая часть статьи: Redirection options in SharePoint

    Как у вас там настроен Redirect? И какие параметры у вас в Alternate Access Mapping (Альтернативное сопоставление доступа)?


    22 января 2015 г. 10:32
  • Думаю это немного не то, но за статью спасибо. Раньше у меня все работало нормально, редиректа не происходило (в статье описана настройка редиректа на другой адрес, а у меня редиректится на тот же сайт, но на главную страницу).
    Редиректиться стало после того как шарепоинт поломался и я, в попытках починить его, отключился от фермы и заново подключился к ней, что привело к пересозданию IIS приложений и сайтов.
    И по пулам приложений: у меня есть сайт IIS для http://portal, но для https://site:port я пул не создавал.
    26 января 2015 г. 1:16
  • у меня устойчивое ощущение, что SharePoint тут не причем и копать нужно в сторону IIS
    26 января 2015 г. 8:09
    Модератор
  • Что может быть в iis не так? Вроде нет там редиректов. К тому же iis не знает что есть сайт https://site:port, он знает только http://portal (во всяком случае если администратор сети не настраивал дополнительно iis на сервере шарепоинта)
    26 января 2015 г. 8:15
  • Я немного не так описал ситуацию.

    Если открывать ссылку вида "https://site:4443/page", то она открывается, а если "http://site/page", то выполняется редирект на главную страницу "https://site:4443".

    сам IIS не знает про сайт "https://site:4443", он знает только "http://portal". Админ сети настраивал "https://site:4443" через шлюз (как я понял пользователь видит "https://site:4443", а на самом деле через шлюз работает с "http://portal")

    28 января 2015 г. 8:08
  • Все таки SharePoint Management и SharePoint Administration это разные вещи!

    Вам чтобы разобраться в данном вопросе стоит взять админа сети и посадить рядом с собой - только вместе разберетесь. Иначе вы будете сваливать часть настроек друг на друга, а тут именно комплексный подход нужен. Если у вас нет такого понимания, то к нему необходимо прийти.

    29 января 2015 г. 6:38
  • Дело в том что и SharePoint Management и SharePoint Administration админ свалил на меня (после того как я обновил SharePoint с 2010 на 2013 версию). Судя по всему я являюсь наиболее компетентным в нашей организации в вопросах, касающихся SharePoint, при этом сам я мало чего знаю.

    У вас есть предложения касательно того что можно проверить, чтобы к админу идти уже с конкретными вопросами, а не предложением проверить все?

    Админ говорит что он настройки не менял и раньше работало также как и сейчас, но пользователи говорит что раньше при переходе к "http://site/page" открывался "https://site:4443/page"

    29 января 2015 г. 6:52
  • А может порт у вас перепутан?

    443 порт - ssl, следовательно переадресация с http на https на порт 443 более правдоподобна, чем на 4443.

    И что за шлюз? Какой? Вам нужно и с маршрутом разбираться. А если админ говорит - настройки не менял, это не значит что он их не менял :)

    29 января 2015 г. 7:01
  • Порт и раньше был 4443. Не знаю почему именно такой. Про шлюз расспрошу подробнее.

    Админ всегда говорит что ничего не трогает, а на деле из-за изменений настроек сети что-то перестает работать :)

    29 января 2015 г. 7:09
  • есть идея.

    отсоеденить контентные базы от веб приложения, удалить веб приложение (удалением и записей IIS), создать его заново, присоеденить стары базы.

    плюсы:

    меньше заморочек со старыми проблемами переадресации.

    возможные риски:

    слетят права назначеные на уровне веб-приложения.

    потребуется настройка (проверка) служб, что все предоставляется и корректно работает. 


    29 января 2015 г. 7:22
    Модератор
  • отсоеденить контентные базы от веб приложения, удалить веб приложение (удалением и записей IIS), создать его заново, присоеденить стары базы.

    Я это уже делал когда у меня шарепоинт сломался (смотрите выше). Как раз после этого, предположительно, и появилась данная проблема :)
    29 января 2015 г. 7:29
  • Судя по всему все дело было в настройках переадресации в сети. Сейчас все работает. Что админ сделал не знаю
    20 апреля 2015 г. 4:58