none
Логин-Пароль в Outlook 2007, autodiscover ? RRS feed

  • Вопрос

  • Заметил сегодня проблему, что когда  хочу создать новый профиль или  добавить пользователя  в  outlook, то получаю  запрос  логин-пароль, при вводе которого ничего не происходит ( появляется снова и снова). Подключиться пытается  по FQDN  к серверу Ех2007.

    [PS] C:\Windows\System32>Get-ClientAccessServer | fl
    
    
    Name                           : SRV010
    OutlookAnywhereEnabled         : True
    AutoDiscoverServiceCN          : SRV010
    AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
    AutoDiscoverServiceInternalUri : https://srv010.int.domain.com/Autodiscover/Autodiscover.xml
    AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
    AutoDiscoverSiteScope          : {int-domain-com}
    IsValid                        : True
    OriginatingServer              : SRV014.int.domain.com
    ExchangeVersion                : 0.1 (8.0.535.0)
    DistinguishedName              : CN=SRV010,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Remedium,CN=Micr
                                     osoft Exchange,CN=Services,CN=Configuration,DC=int,DC=Domain,DC=com
    Identity                       : SRV010
    Guid                           : 8c9c4bda-6290-46e1-b376-e3c70720e799
    ObjectCategory                 : int.domain.com/Configuration/Schema/ms-Exch-Exchange-Server
    ObjectClass                    : {top, server, msExchExchangeServer}
    WhenChanged                    : 14.09.2009 14:41:29
    WhenCreated                    : 10.09.2008 14:36:34


    При попытки зайти по https://srv010.int.domain.com/Autodiscover/Autodiscover.xml
    Получаю запрос  пары логин-пароль для доменного пользователя. И  получаю:

    <? xml version="1.0" encoding="utf-8"  ?>
      < Autodiscover xmlns =" http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006 " >
      < Response >
      < Error Time =" 15:34:12.1800829 " Id =" 1642087492 " >
      < ErrorCode > 600 </ ErrorCode >
      < Message > Invalid Request </ Message >
      < DebugData />
      </ Error >
      </ Response >
      </ Autodiscover >
    


    на  данный момент изучаю http://technet.microsoft.com/en-us/library/bb332063.aspx на предмет  чего-либо интересного.

    Все происходит внутри домена.

    [upd]
    Аутлук настроил вручную ( ИП сервера и логин-пароль ).
    Нажимаю "Проверить автоконфигурацию эл.почты"
    скачивает XML

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
          <DisplayName>Баканов Денис</DisplayName>
          <LegacyDN>/o=Remedium/ou=First Administrative Group/cn=Recipients/cn=bakanov</LegacyDN>
          <DeploymentId>0cb97fdd-1b35-4ab7-88aa-e809892089d6</DeploymentId>
        </User>
        <Account>
          <AccountType>email</AccountType>
          <Action>settings</Action>
          <Protocol>
            <Type>EXCH</Type>
            <Server>SRV010.domain.ru</Server>
            <ServerDN>/o=Remedium/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=SRV010</ServerDN>
            <ServerVersion>720180F0</ServerVersion>
            <MdbDN>/o=Remedium/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=SRV010/cn=Microsoft Private MDB</MdbDN>
            <PublicFolderServer>SRV010.domain.ru</PublicFolderServer>
            <AD>SRV014.domain.ru</AD>
            <ASUrl>https://srv010.domain.ru/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://srv010.domain.ru/EWS/Exchange.asmx</EwsUrl>
            <OOFUrl>https://srv010.domain.ru/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://srv010.domain.ru/UnifiedMessaging/Service.asmx</UMUrl>
            <OABUrl>http://srv010.domain.ru/OAB/16e43f2f-b891-4bfd-b169-646e17f6dfe2/</OABUrl>
          </Protocol>
          <Protocol>
            <Type>EXPR</Type>
            <Server>mail.remedium.ru</Server>
            <SSL>On</SSL>
            <AuthPackage>Ntlm</AuthPackage>
          </Protocol>
          <Protocol>
            <Type>WEB</Type>
            <Internal>
              <OWAUrl AuthenticationMethod="Basic, Fba">https://srv010.domain.ru/owa</OWAUrl>
              <Protocol>
                <Type>EXCH</Type>
                <ASUrl>https://srv010.domain.ru/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </Internal>
          </Protocol>
        </Account>
      </Response>
    </Autodiscover>


    Если сообщение было информативным, отметьте его как ответ. И нам приятно и сразу видно ответ на вопрос :-)
    • Перемещено Hengzhe Li 12 марта 2012 г. 9:09 forum merge (От:Exchange Server 2007)
    14 сентября 2009 г. 11:32

Ответы

Все ответы

  • Опытным путем выяснилось, что проблема в согласовании подлинности клиента.
    Итак , если в профиле стоит (Панель управления - Почта - Доп.Настройки - Безопасность ) Проверка подлинности "Проверка подлинности с согласованием", то получаю рекурсию окон ввода  логин-пароля при запуске  Outlook 2007. Если принудительно выставить "Проверка подлинности NTLM", то все работает как часы.
    http://pic.ipicture.ru/uploads/090915/LkpoWUg8EQ.jpg

    Внимание, а теперь собственно вопрос, что  нужно подкрутить на сервере, кажется мне , что на IIS, что бы  согласование подлинности проходило  нормально ?

    Если сообщение было информативным, отметьте его как ответ. И нам приятно и сразу видно ответ на вопрос :-)
    15 сентября 2009 г. 6:35
  • а что говорит
    Get-WebServicesVirtualDirectory -server srv010 | fl ?
    16 сентября 2009 г. 7:52
  • Get-WebServicesVirtualDirectory -server srv010 | fl
    
    
    InternalNLBBypassUrl          : https://srv010.int.doamin.com/ews/exchange.asmx
    Name                          : EWS (Default Web Site)
    InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
    ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
    BasicAuthentication           : False
    DigestAuthentication          : False
    WindowsAuthentication         : True
    MetabasePath                  : IIS://SRV010.int.doamin.com/W3SVC/1/ROOT/EWS
    Path                          : C:\Program Files\Microsoft\Exchange Server\ClientAccess\exchweb\EWS
    Server                        : SRV010
    InternalUrl                   : https://srv010.int.doamin.com/EWS/Exchange.asmx
    ExternalUrl                   :
    AdminDisplayName              :
    ExchangeVersion               : 0.1 (8.0.535.0)
    DistinguishedName             : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,CN=SRV010,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDL
                                    ),CN=Administrative Groups,CN=Remedium,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=int,DC=domain,DC=com
    Identity                      : SRV010\EWS (Default Web Site)
    Guid                          : e8624287-e429-4d5d-97d9-38b7f665272b
    ObjectCategory                : int.doamin.com/Configuration/Schema/ms-Exch-Web-Services-Virtual-Directory
    ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServicesVirtualDirectory}
    WhenChanged                   : 14.09.2009 14:41:44
    WhenCreated                   : 14.09.2009 14:41:38
    OriginatingServer             : SRV014.int.doamin.com
    IsValid                       : True

    Если сообщение было информативным, отметьте его как ответ. И нам приятно и сразу видно ответ на вопрос :-)
    16 сентября 2009 г. 13:15
  • Что показывает setspn -L Имя_сервера_Exchange ?
    18 сентября 2009 г. 9:09

  • PS C:\Users\bakanov> setspn -l srv010
    Registered ServicePrincipalNames for CN=SRV010,OU=Servers,OU=WSUS_computers,DC=int,DC=domain,DC=com:
            TERMSRV/SRV010
            TERMSRV/SRV010.int.domain.com
            IMAP4/SRV010.int.domain.com
            IMAP4/SRV010
            IMAP/SRV010.int.domain.com
            IMAP/SRV010
            DNS/SRV010.int.domain.com
            POP3/SRV010.int.domain.com
            POP3/SRV010
            exchangeRFR/SRV010
            exchangeRFR/SRV010.int.domain.com
            exchangeMDB/SRV010
            exchangeMDB/SRV010.int.domain.com
            SmtpSvc/SRV010.int.domain.com
            SmtpSvc/SRV010
            SMTP/SRV010.int.domain.com
            SMTP/SRV010
            exchangeAB/SRV010.int.domain.com
            exchangeAB/SRV010
            HOST/SRV010.int.domain.com/REMEDIUM
            HOST/SRV010.int.domain.com/int.domain.com
            NtFrs-88f5d2bd-b646-11d2-a6d3-00c04fc9b232/SRV010.int.domain.com
            HOST/SRV010
            HOST/SRV010.int.domain.com

    Если сообщение было информативным, отметьте его как ответ. И нам приятно и сразу видно ответ на вопрос :-)
    18 сентября 2009 г. 9:37
  • http://support.microsoft.com/kb/927612/en-us статья по Exchange 2003, но похоже проблема та же
    • Предложено в качестве ответа Vinokurov Yuriy 21 сентября 2009 г. 8:59
    • Помечено в качестве ответа Bakanov Denis 21 сентября 2009 г. 18:43
    18 сентября 2009 г. 10:35
  • Tnx,  помогло
    Если сообщение было информативным, отметьте его как ответ. И нам приятно и сразу видно ответ на вопрос :-)
    21 сентября 2009 г. 18:43