none
Проблема с установкой RRS feed

  • Вопрос

  • Доброго времени суток!

    Ставлю Exchange первый раз. При установке  получил ошибку:

    "$error.Clear();
              set-ExchangeServerRole -Identity $RoleNetBIOSName -IsProvisionedServer:$true -DomainController $RoleDomainController
            " was run: "Свойство IsProvisionedServer не может быть установлено для этого объекта, поскольку требуется, чтобы версия объекта была не ниже 0.1 (8.0.535.0). Текущая версия объекта: 0.0 (6.5.6500.0)."

    Сервер появился в установленных программах, но не работает. Попытка удалить приводит к той же ошибке. Сервер тестовый, standart 2012, виртуальная машина, он же контроллер тестового домена.  Лог прилагается - exchangesetup.log

    Что за объект и как его обновить до нужной версии? Подскажите пожалуйста.

    29 июня 2015 г. 23:31

Ответы

Все ответы

  • запустите с командной строки (Run as Administrator):

    Setup.exe /PrepareSchema /IAcceptExchangeServerLicenseTerms

    Setup.exe /PrepareAD /OrganizationName:"<organization name>" /IAcceptExchangeServerLicenseTerms

    после чего (если не появится ошибок) запустите штатную установку Exchange.


    Do not multiply entities beyond what is necessary

    30 июня 2015 г. 4:35
  • Пробовал, на первом же этапе получаю:

    Во время установки роли HubTransportRole ранее произошел сбой программы установки. Снова запустите программу установки только для этой роли, либо удалите роль с помощью панели управления.

    По справке пробовал вариант для роли setup /Roles:HT /Mode:Install /IAcceptExchangeServerLicenseTerms, получал:

    Программе установки ранее не удается выполнить действие "Uninstall". Невозможно возобновить установку, выполнив действие "Install".

    Через "изменить" в панели управления тоже получаю ошибку. свежий лог - ссылка

    30 июня 2015 г. 5:37
  • У вас все установки производятся "As Administrator"? Полномочия учетной записи, из под которой производится установка, соответствуют требованиям?

    Do not multiply entities beyond what is necessary

    30 июня 2015 г. 6:23
  • Внимательно проверьте все шаги:

    https://technet.microsoft.com/library/bb125224%28v=exchg.150%29.aspx?f=255&MSPPError=-2147217396

    Так же попробуйте запустить установку через графический установщик (просто в проводнике запустите setup.exe). 

    30 июня 2015 г. 6:28
  • Установка выполняется от Администратора домена, он состоит в группах безопасности "Администраторы схемы" и "Администраторы предприятия".


    C:\Users\Администратор> Setup.exe /PrepareSchema /IAcceptExchangeServerLicenseTerms

    Добро пожаловать в программу автоматической установки Microsoft Exchange Server 2013 Preview

    Performing Microsoft Exchange Server Prerequisite Check

    Анализ необходимых условий                                                                        ОШИБКА
    Во время установки роли HubTransportRole ранее произошел сбой программы установки. Снова запустите программу установки только для этой роли, либо удалите роль с помощью панели управления.


    • Изменено Yan Yunin 30 июня 2015 г. 18:37
    30 июня 2015 г. 18:34
  • А зачем вы устанавливаете превью версию? Скачайте CU9.
    30 июня 2015 г. 18:43
  • Это тестовый сервер с пробными версиями, ставлю то, что мне предложил MS в качестве пробной 180 дневной версии.
    30 июня 2015 г. 18:58
  • Тему можно закрывать, перегуглил всё, ничего не помогает, сервер переставляю с нуля
    • Помечено в качестве ответа Yan Yunin 30 июня 2015 г. 21:33
    30 июня 2015 г. 21:33