none
Виртуальные машины через некоторые время работы становятся не доступны в консоле Hyper-V Manager RRS feed

  • Вопрос

  • Добрый день!

    столкнулся с проблемой.

    Недавно установил новый 2012 Windows Server

    Он призван быть кластером виртуальных машин.

    После установки с неделю боролся с обновлениями

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/98be04e7-2735-4f26-9be8-04198a8d157e/windows-2012-r2-cluster-issues-guest-vms-fail-when-one-specific-node-hosts-csv?forum=winserverClustering#9894f991-d058-4f5b-a02f-a5bda9fe1192

    в итоге победил. Теперь новая беда. Через какое-то продолжительное(несколько дней) время работы виртуальные машины перестают быть доступны в консоли HYper_V при попытке посмотреть свойства.. приконнектится и т.д.(ошибка в скрине)

    При этом, если vmconnect уже был запущен для какой-то из виртуальных машин часть его функций работает, то есть я к примеру не могу посмотреть свойства виртуальной машины, но в "нулевую" консоль подключиться дает. Если попробовать по новой открыть через Hyper_V эту же машину, то ошибка та же...

    пробовал заходить под другой УЗ, запускать с разными правами... не помогает...

    Вылечивается только одним способом - я захожу на виртуальную машину по RDP, перезагружаю ее! и тогда она становится доступной в консоле... такое повторилось уже второй раз...

    В первый раз я грешил на антивирус касперского и по вот этой статье были настроены исключения:

    https://support.microsoft.com/ru-ru/help/3105657/recommended-antivirus-exclusions-for-hyper-v-hosts

    Буду проверять точность настроек...

    проблема в том, что баг проявляется не часто, за пол месяца работы это второй случай, поэтому хочется по максимуму сделать все, что бы этого не повторилось... нормально продиагностировать не получается... В логах не нашел ничего... ни в логах системы, ни приложения, ни в логах самой консоли и все что связанно с HYper-v, я может быть и плохо искал, но все же не нашел...

    Может кто-то что-нибудь посоветовать?

    1 июля 2019 г. 13:22

Ответы

  • Удалите антивирус с узлов Hyper-V вообще.

    Если проблемы уйдут, нужно будет тестировать совместимость и настройки KAV с вашим развёртыванием.
    • Помечено в качестве ответа Sergey2005 12 июля 2019 г. 11:17
    Модератор

Все ответы

  • Здравствуйте Сергей

    Без логов очень трудно обнаружить проблему, имея ввиду, что она возникает редко. Поэтому, как вариант я бы предложил Вам обратиться в службу поддержки, потому что видимо необходимо провести более детальное обследование.

    Техническая поддержка TechNet

    Конечно, я надеюсь, что может быть у кого нибудь из участников была схожая ситуация и он сможет предложить Вам решение.


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.

    Модератор
  • Удалите антивирус с узлов Hyper-V вообще.

    Если проблемы уйдут, нужно будет тестировать совместимость и настройки KAV с вашим развёртыванием.
    • Помечено в качестве ответа Sergey2005 12 июля 2019 г. 11:17
    Модератор
  • Спасибо откликнувшимся!

    Удалю антивирус и понаблюдаю.

     
  • Проблемы ушли, виноват Антивирус, спасибо всем кто отвечал! буду копать
    12 июля 2019 г. 11:18