none
RemoteApp в RDS2016 через интернет

    Вопрос

  • Добрый день!

    Развернул все роли на одном сервере: Gateway, WEB, Licensing, Certificates. Развернул службe сертификации Active Directory. что бы выписать сертификат на RDS. Прописал в Gateway адрес rds.testdomen.ru, сертификат с таким же именем выписал и установил. При попытке подключения из интернета с клиента при попытки открыть какое либо опубликованное приложения, выдает ошибку.  

    Если я на клиенте в файле host пропишу внешний IP сервера, все работает. Как можно исправить ошибку? 

    7 декабря 2017 г. 9:02

Все ответы

  • Добрый день!

    В настройках у вас должен быть прописан внешний FQDN шлюза терминалов с соответствующим именем в сертификате. В случае если выписываете сертификат от локального центра, то корневой должен присутствовать на клиентской машине в Доверенных корневых сертификатах.

    1.На сервере RDS откройте IIS.

    2.Откройте сайт по умолчанию куда установлен RDWEB, перейдите на Pages.

    3.Далее  с правой стороны "Параметры приложения"  и заполните поле DefaultTSGateway.

    4. Перезапустите IIS.

    7 декабря 2017 г. 9:08
  • В настройках у меня прописан внешний адрес 

    В Iis прописал DefaultTSGateway, сертификат выписан так же на rdp.testdomen.ru выдан моим локальным компом, на клиенте установлен в доверенные сертификаты и корневой сертификат центра сертификации и непосредственно для  rdp.testdomen.ru который привязан в iis 

    Ошибка не ушла. 

     
    7 декабря 2017 г. 9:28

  • Если я на клиенте в файле host пропишу внешний IP сервера, все работает. Как можно исправить ошибку? 

    У вас есть A запись на rdp.testdomain.ru ?

    7 декабря 2017 г. 9:46
  • ДА естественно. 
    7 декабря 2017 г. 9:49
  • ДА естественно. 

    То есть невозможно подключиться из локальной сети, в то время как снаружи все работает исправно?

    Я почему спросил - Если клиент находится в одной сети с сервером, и после редактирования файла host rdp.testdomain.com  ВНЕШНИЙ_IP_СЕРВЕРА У вас все работает, то следовательно проблема в DNS - создайте запись на вашем внутреннем DNS сервере rdp.testdomain.com  ВНУТРЕННИЙ_IP_СЕРВЕРА и все должно заработать. 

     
    7 декабря 2017 г. 10:05
  • У меня наоборот, работает внутри сети, а снаружи не робит  
    7 декабря 2017 г. 10:20
  • У меня наоборот, работает внутри сети, а снаружи не робит  

    Вы можете зайти по web на RDS сервер из интернета?

    Если да, то скачайте файл *.rdp и откройте его в блокноте, там есть поле full address: , оно соответствует внешнему адресу вашего сервера?

    7 декабря 2017 г. 14:04
  • на веб могу зайти, адрес там указан локальный компьютера типо rds-01.local.ru, а gatewayhostname:s:rdp.testdomain.ru 
     
    8 декабря 2017 г. 10:44
  • Посмотрите вот это
    8 декабря 2017 г. 11:49
  • full address: теперь такой же как и gatewayhostname:s:rdp.testdomain.ru  ну ошибка осталась. 
    11 декабря 2017 г. 18:52
  • full address: теперь такой же как и gatewayhostname:s:rdp.testdomain.ru  ну ошибка осталась. 

    Добрый День.

    Прошу уточнить:

    Проблемный Сервер смотрит на прямую в интернет или расположен за роутером.

    Если за маршрутизатором, то вы сервер опубликовали на маршрутизаторе порты 3389, 443.

    A запись на внешнем DNS создана на внешний ip сервера либо Маршрутизатора.

    В настройках проблемного сервера и rdp файле не пробовали выставить значение (automatically detect rd gateway server settings) 


    Я не волшебник, я только учусь MCP CCNA. Если Вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Пометить как ответ" или проголосовать "полезное сообщение". Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции работодателя. Вся информация предоставляется как есть без каких-либо гарантий. Блог IT Инженера, Twitter, YouTube, GitHub.

    11 декабря 2017 г. 19:21
    Модератор
  • Порты проброшены, А-запись так же присутствует. automatically detect rd gateway server settings Ставил, проблему не меняет. 
    12 декабря 2017 г. 5:30
  • Проверьте, доступен ли порт из интернета telnet rdp.testdomain.ru  3389
    12 декабря 2017 г. 7:20
  • Доступен
    12 декабря 2017 г. 8:17
  • Были проблемы по 443 порту, исправил, теперь такая ошибка 
    13 декабря 2017 г. 10:07
  • Почитайте вот это обсуждение
    13 декабря 2017 г. 13:08
  • Были проблемы по 443 порту, исправил, теперь такая ошибка 

    Добрый День.

    Уточните ос и программное обеспечение проблемного сервера, так уточните как настраивали проблемный сервер


    Я не волшебник, я только учусь MCP CCNA. Если Вам помог чей-либо ответ, пожалуйста, не забывайте жать на кнопку "Пометить как ответ" или проголосовать "полезное сообщение". Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции работодателя. Вся информация предоставляется как есть без каких-либо гарантий. Блог IT Инженера, Twitter, YouTube, GitHub.

    13 декабря 2017 г. 15:39
    Модератор
  • Настраивал по https://alekssh.com/2014/09/06/rds-gw-ha/

    Windows server 2012r2, Заного все перенастроил, 

    теперь вот это. На удаленном компьютере где запускаю установлен и корневой сертификат и тот что стоит в iis на 443 порт.

    14 декабря 2017 г. 7:55
  • Вопрос с сертификатом решил, проблема была на стороне клиента, обновил win7  все ок стало, на других осях подключается, осталась одна проблема, у меня в rd gateway галочка не стоит" Не использовать сервер шлюза для лок. адресов" Ну в локальной сети он публикации не открывает все ровно Ошибка

    А из интернета все робит Ок. 

    14 декабря 2017 г. 8:09