none
Внимание! Server 2012 R2 Rus + Exchange 2016 CU2!! RRS feed

  • Общие обсуждения

  • Снова поломали эту связку. У меня на тестовой среде служба "Интерфейсный транспорт.." больше не стартует после обновления.
    24 июня 2016 г. 10:00

Все ответы

  • Только CU2 выпустили:)

    scientia potentia est
    My blog

    24 июня 2016 г. 10:02
  • Исправил, конечно ))) просто с CU13 тут как то переплелось ))
    24 июня 2016 г. 10:15
  • .NET Framework 4.6.1 тоже с обновлениями поставился ?

    S.A.

    24 июня 2016 г. 10:20
  • Да. думаете в нем дело?? Попробую грохнуть сейчас.

    Up.. Удалил, все равно служба не стартует.. причем так интересно. Почта в Outlook ходит. Но вот по 25 порту не целяется.. А по 995 работает ))

    24 июня 2016 г. 10:43
  • Но вариант запуска данной службы от доменной учетки помогает решить проблему. Так что вот.. Если кому то очень хочется попробовать новые фичи CU2 то сначала обязательно делаем запуск службы от доменной учетки.
    27 июня 2016 г. 10:11
  • Приветствую.

    Что-то не помогло мне изменение входа на доменную учётную запись, служба так и не стартует. Теперь надо придумать как обратно на CU1 откатиться.

    28 июня 2016 г. 12:19
  • Приветствую.

    Что-то не помогло мне изменение входа на доменную учётную запись, служба так и не стартует. Теперь надо придумать как обратно на CU1 откатиться.

    Обратно никак не откатиться.
    28 июня 2016 г. 12:31
  • Никак. Поднимать другой сервер и\или перевести на ENG версию.
    28 июня 2016 г. 12:36
  • Про то, что откатиться не получится, я уже понял, спасибо :) 

    Можно немного подробнее по поводу перевода на английскую версию? А точнее реализуемо ли это без полной переустановки системы? 

    Хотя в любом случае так как вариантов у меня нет, попробую перевестись и проверить.

    Заранее спасибо за ответы :)



    • Изменено p0larus 28 июня 2016 г. 13:24
    28 июня 2016 г. 13:17
  • Нет, не получится. Получится ли через восстановление сервера, но на английскую версию с тем же именем и прочими настройками вернуть не могу сказать - не пробовал. Но я бы поднял еще один сервер, на него бы перенес все базы и после этого уже удалил бы старый. Кстати, а Вы под какой учеткой службу пытаетесь запустить?? У меня запустилась под пользователем входящим в группу администраторов. НО!! Все равно 25 порт не рабочий полностью. При попытке послать через него вываливается ошибка и пересылка через между серверам в разных организациях тоже не работает.
    28 июня 2016 г. 13:27
  • В общем опять наступили на те же грабли, ясно-понятно.

    Если 25 порт не рабочий полностью, то смысл от такой работы службы frontend transport пропадает. Интересно, обновления вообще тестируются, перед выкатом?

    28 июня 2016 г. 13:42
  • Да, похоже так и есть.. Я уже и NET 4.6 и ставил и удалял.. И чего только не делал..  Пока не обновлял до CU2 рабочию среду, но чую надо ей перевести на ENG версию, им вроде можно.
    28 июня 2016 г. 13:50
  • Коллеги, ну сколько можно одними и теми же граблями в лоб получать? :)

    Давно вроде бы определились, что в промышленной среде  надо отказаться от локализованных версий Windows Server.


    Do not multiply entities beyond what is necessary


    • Изменено Dmitry.I 29 июня 2016 г. 5:52
    29 июня 2016 г. 4:44
  • Дмитрий, с продакшном всё понятно.

    Вы мне вот что лучше скажите, имеет ли смысл вообще мучиться с frontend transport, если все роли стоят на одном сервере? Вчера для тестов пересоздал все коннекторы с hub transport и всё полетело. Понятно, что это уж явно не best practice, но я не нашёл особых противопоказаний.

    И да, после перевода интерфейса в английский, служба frontend transport запустилась от доменной учётки, но нифига не работает как надо :) 

    29 июня 2016 г. 6:05
  • Дмитрий, Все бы хорошо... Но не у всех можно это сделать не нарушая лицензии.. У меня например в одной организации пришлось таки воспользоваться "обходом" ибо ОЕМ только RUS и все. Ключи, имеющийся не подходят для ENG версии.. 

    p0larus, интерфейс на английский переводить нет смысла. Надо ставить ENG дистрибутив, а уже НА НЕГО ставить LP русский если хочется русского интерфейса, правда смысла в последнем я не вижу совсем. А прямо заработало все после полного пересоздания коннекторов?? Ну вот видите, вы нашли еще один более гуманный способ (((
    29 июня 2016 г. 6:12
  • Сергей, я пересоздал коннекторы именно для hub transport, на входящие 25 и 587 порты, так как frontend transport, это же по сути прокся, которая нужна при разнесении ролей по разным серверам. Само собой, в большом продакшне так лучше не делать, но в allinone до выхода чинящего frontend апдейта этот костыль имеет право на жизнь.
    • Изменено p0larus 29 июня 2016 г. 6:58
    29 июня 2016 г. 6:38
  • Я понял что сделали.  Ну я и говорю что такой вариант для починки если вдруг нет возможности переделывать то вполне себе вариант.
    29 июня 2016 г. 7:11
  • Давно вроде бы определились, что в промышленной среде  надо отказаться от локализованных версий Windows Server

    А если у меня работают локализованные (часть), и так не ломаются, мне заранее застрелиться?

    А вот это https://blogs.technet.microsoft.com/exchange/2016/02/10/on-net-framework-4-6-1-and-exchange-compatibility/ секретная информация, и её никто не видел?


    S.A.

    29 июня 2016 г. 8:15
  • NET тут не причем. Мы тут как бы про CU2 и секретная информация ваша уже устарела немного )) https://blogs.technet.microsoft.com/exchange/2016/06/21/released-june-2016-quarterly-exchange-updates/ ибо SUPPORT.. Да и сломалась она у меня когда на сервере не было 4.6, запрет был на его установку в реестре.
    29 июня 2016 г. 8:25
  • Я ставил  CU2 на сервер где уже был установлен  NET 4.6.1

    После установки обновления Интерфейсный транспорт не стартонул.

    Я удалил NET используя (Test-ServiceHealth).ServicesRunning | %{Stop-Service $_ -Force} , перезагрузил сервер, установил повторно NET - странно, но Интерфейс транспорта запустился. Но сервер просил перезагрузку для завершения процесса установки обновлений. Я перезагрузил сервер, все установилось, но после этого Интерфейс транспорта вновь перестал стартовать.

    В виду этого для меня не понятно как МАЙКРОСОФТ вообще выпускают такие сырые обновления.????

    30 июня 2016 г. 11:15
  • И еще в CU2 есть косяк!!! Сегодня и на рабочей системе всплыло.. http://www.expta.com/2016/06/mapi-virtual-directory-bug-in-exchange.html
    1 июля 2016 г. 12:58
  • Возможно у вас старая история с коллизией портов 25 и 2525 на коннекторах фронтенда и бакенда - проверяли?

    Сазонов Илья

    https://isazonov.wordpress.com/

    1 июля 2016 г. 13:35
    Модератор
  • Нет, после установки в рабочую среду перестало подключаться.. Проверил по этой статье - так и есть.. У меня на рабочей системе ENG версия, и там проблем с 25 портом и отказом службы нет. А тут я сразу залез в ECP поставил две галки и все заработало.
    1 июля 2016 г. 13:37
  • всем привет. друзья, появилось решение безболезненной установки CU2 на русскую редакцию? имеем проблему с поиском писем, которую апдейт должен решить, но очень страшно положить действующий сервис.
    2 августа 2016 г. 8:14
  • и не появится скорее всего до выпуска CU3 или еще хуже они о нем не знают.
    2 августа 2016 г. 8:40
  • Есть вопросик немного не в тему.

    Можно ставить CU2 без установленной CU1 ?

    3 августа 2016 г. 9:47
  • Можно. Можно даже сразу ставить CU2 как самостоятельную установку.
    3 августа 2016 г. 9:52
  • Да можно - все CU полновесные установочные пакеты.

    Сазонов Илья

    https://isazonov.wordpress.com/

    3 августа 2016 г. 11:27
    Модератор
  • Да уж.. Длина слишком длинная ))) Совсем перестали проверять что выпускают..

    21 сентября 2016 г. 16:13