none
Exchange 2010 + Outlook 2007 - не стоит соединение. RRS feed

  • Вопрос

  • Имеется следующая конфигурация: Windows Server 2008 R2, на нём TMG 2010, Kaspersky Security for Exchange Servers и Exchange 2010 SP1 (поначалу - без SP1). Рядом - такой же Windows Server 2008 R2, но DC. Клиенты - Windows XP SP3, на них - Outlook 2007.

    Проблема заключается в том, что при попытке соединения с сервером клиенты начинают активно ронять соединение, при этом папки почты - пустые, отправка писем иногда случается, но далеко не сразу, а журнал событий полон сообщениями об ошибках операций EcDoRpcExt и EcDoDisconnect на транспорте ncacn_ip_tcp. Рано или поздно клиент падает. OWA при этом работает корректно.

    Та же ситуация наблюдалась изначально, без SP1. Единственное, что изменилось после его наложения - перестала работать автонастройка и первоначальная загрузка клиента замедлилась примерно в три раза.

    Трафик между локальной сетью и сервером Exchange не ограничен. Раньше клиенты работали с Kerio Mail Server через Outlook Offline Connector, но сейчас от KMS отказались.

    Хотелось бы понять, чем вызвано сие неприятное явление и искоренить его.

    9 марта 2011 г. 6:48

Ответы

  • Ну и крещендо.

    Снёс TMG2010, поставил обратно, руками, а не визардом, открыл порты для локалки и на выход и всё заработало. Видимо, визард майкрософта для публикации Exhcnage через TMG оказался склонен к некромантии.

    • Помечено в качестве ответа Yuriy Lenchenkov 11 марта 2011 г. 11:52
    11 марта 2011 г. 9:06

Все ответы

  • Смотрели - http://support.microsoft.com/kb/325930 ?
    http://alexxhost.ru
    9 марта 2011 г. 7:05
  • Смотрел, вздыхал - там несколько заплесневелая вода, а хочется актуальную для 2011 года инструкцию вида "Проверить то-то, должно быть так-то, если нет, то..."

    Но чеклист пройден - значения реестра имеются, конечные точки зарегистрированы, версии библиотек верны.

    Переустановку TCP/IP на клиентском компьютере пока не пробовал - несколько затруднительно делать это через VNC.

    9 марта 2011 г. 7:38
  • А ExBPA что-нить интересное говорит?


    http://alexxhost.ru
    9 марта 2011 г. 7:42
  • Предлагаю начать с решения проблемы autodiscover

    Оно из IE открывается?

    Посмотрите Ctrl+right click на значке Outlook у часов и выберите Test E-mail Autoconfiguration

    Интересует вкладка Log.

    Где спотыкается и с каким кодом ошибки.


    MCSE:M 2003, MCITP:EA, SA, EMA, EMA:2010
    9 марта 2011 г. 8:01
  • По первой опции ругается на отсутствие записей (А) в роутере этажом выше и на самоподписанный сертификат сервера. Также сообщает, что у меня неверно заданы права на папку OAB. Причём через проводник я вижу именно те права, которых он просит.

    Дальше сейчас попробую посмотреть.

    9 марта 2011 г. 8:28
  • Странно, но сейчас автодисккавер заработал, без перезагрузки сервера и каких-то активных действий. В пять утра не работал.

    Но папки всё ещё не синхронизируются.

    9 марта 2011 г. 8:35
  • Ко всему добавились ошибки RfrGetNewDSA
    9 марта 2011 г. 9:23
  • Переставил на Outlook 2010, ситуация не улучшилась - ровно те же симптомы.
    9 марта 2011 г. 13:50
  • Ну и крещендо.

    Снёс TMG2010, поставил обратно, руками, а не визардом, открыл порты для локалки и на выход и всё заработало. Видимо, визард майкрософта для публикации Exhcnage через TMG оказался склонен к некромантии.

    • Помечено в качестве ответа Yuriy Lenchenkov 11 марта 2011 г. 11:52
    11 марта 2011 г. 9:06