none
Исчез доступ к веб-частям RRS feed

  • Вопрос

  • Доб.. недоброе утро ((( 

    Прихожу я значит с утра. И вижу страшную вещь на всем семействе сайтов. Гневное сообщение "Не удается отобразить веб-часть.... ". В логе сервера 6398 и сообщения о распределенном кеше. Погуглил удалял службу, ставил заново.

    Теперь результат - другое гневное сообщение "Доступ запрещен. У вас нет разрешений на выполнение этого действия или на доступ к этому ресурсу."

    Разрешения везде указаны (т.е. они не удалились никуда), но по факту ничего не отображается. Последние ошибки в логах (раз 6-7 одна и та же):

    Исключение в методе Execute определения задания Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (идентификатор 2afe3164-2d03-46b9-baf2-48741846664d). Дополнительные сведения см. ниже.

    Непредвиденное исключение в методе FeedCacheService.IsRepopulationNeeded: Не удалось создать DataCache. Вероятно, распределенный кэш SPDistributedCache не работает..

    Хелп!!!!!!

    21 ноября 2013 г. 4:54

Ответы

  • К сожалению, вынужден закрыть вопрос. пробный период заканчивается и такие выкрутасы руководство не устроили (
    • Помечено в качестве ответа Sobsoft 23 ноября 2013 г. 14:30
    23 ноября 2013 г. 14:30

Все ответы

  • добрый день

    посмотрите: Distrubited Cache in SharePoint 2013

    21 ноября 2013 г. 5:12
    Модератор
  • Пишет при остановке кластера - отсутствуют узлы в кластере.
    21 ноября 2013 г. 5:21
  • Зашёл в службы в админке шарпойнта. служба "Распределенный кеш" выключена. Пытаюсь включить - пишет "cacheHostInfo is null".

    Решил этим http://asharepointsolutions.blogspot.ru/2013/07/cachehostinfo-is-null.html

    Но доступа все равно нету(

    21 ноября 2013 г. 5:29
  • Продолжают сыпаться ошибки:

    Исключение в методе Execute определения задания Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (идентификатор 2afe3164-2d03-46b9-baf2-48741846664d). Дополнительные сведения см. ниже.
    
    Непредвиденное исключение в методе FeedCacheService.IsRepopulationNeeded: Не удалось создать DataCache. Вероятно, распределенный кэш SPDistributedCache не работает..

    Исключение в методе Execute определения задания Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (идентификатор 2afe3164-2d03-46b9-baf2-48741846664d). Дополнительные сведения см. ниже.
    
    Непредвиденное исключение в методе FeedCacheService.IsRepopulationNeeded: Communications with the cache cluster has experienced a delay past the timeout value,please increase the RequestTimeout of the client..

    Исключение в методе Execute определения задания Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (идентификатор 2afe3164-2d03-46b9-baf2-48741846664d). Дополнительные сведения см. ниже.
    
    Непредвиденное исключение в методе FeedCacheService.IsRepopulationNeeded: Cache cluster is down, restart the cache cluster and Retry.

    Исключение в методе Execute определения задания Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (идентификатор 2afe3164-2d03-46b9-baf2-48741846664d). Дополнительные сведения см. ниже.
    
    Возник конфликт обновлений, действие необходимо повторить. Объект LMTRepopulationJob Name=Приложение-служба профилей пользователей_LMTRepopulationJob был обновлен пользователем домен\service_app в рамках процесса w3wp (3360) на компьютере SHAREPOINT. Дополнительные сведения о конфликте см. в журнале трассировки.

    Я щас застрелюсь, если придется заново сервер поднимать

    21 ноября 2013 г. 6:49
  • во нашел еще одну ссылку SharePoint 2013 so many 6398 errors

    21 ноября 2013 г. 7:06
    Модератор
  • во нашел еще одну ссылку SharePoint 2013 so many 6398 errors

    Не совсем то. Ощущение, что служба AppFabrik повреждена, но переустновка и вообще все манипуляции не прошли.
    21 ноября 2013 г. 7:28
  • Ошибку "доступ запрещен" удалось исправить - на папку с XSL был потерян доступ.

    Но ошибку с "Не удается отобразить веб-часть" так и не исправил... помогите плиз!

    21 ноября 2013 г. 9:40
  • а ошибки в ULS есть?
    21 ноября 2013 г. 10:03
    Модератор
  • а ошибки в ULS есть?
    как посмотреть?
    21 ноября 2013 г. 10:41
  • 21 ноября 2013 г. 10:50
    Модератор
  • Обилие поступающей инфы, которая появилась при подключении данной проги сильно испугала.

    http://yadi.sk/d/A-1uLHMSD5CX2 - подскажите пожалуйста, что там накалякано - щас мозг из ушей выплывет и поплывет домой отдельно(

    21 ноября 2013 г. 11:08
  • Поставил ещё 1 сервер SP 2013 - очень странно, но там началось то же самое

    21 ноября 2013 г. 11:43
  • я предлагаю помотреть программой в режиме реального времени что происходит в момент ображения к странице (веб части)
    21 ноября 2013 г. 12:06
    Модератор
  • я предлагаю помотреть программой в режиме реального времени что происходит в момент ображения к странице (веб части)

    Ок. Открываю главную страницу (там несколько веб-частей - информеров висит), беру идентификатор взяимосвязи, нахожу его через ULS Viewer и получаю:

    UlsRuntimePump could not understand this line: 11/22/2013 09:30:48.95 	w3wp.exe (0x0F38)                       	0x1D9C	SharePoint Foundation         	Logging Correlation Data      	xmnv	Medium  	Name=Request (GET:http://sharepoint/sites/dom/SitePages/Домашняя.aspx)	8f00599c-e6df-90aa-aaaf-ff05e433fbe3. Error was: System.FormatException: Строка не распознана как действительное значение DateTime.
       в System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
       в UlsGump.Column.TimeColumn.ParseTime(StringFacade timeString)
       в UlsGump.UlsEntry.SetEntryFromThread(StringFacade[] threadFacades, StringCacheFile stringCacheFile, Int64 messageLocation)
       в UlsGump.UlsEntry.ReadFromUlsLine(String line)
       в UlsGump.UlsRealtimePump.ReadUls()

    Т.е. получается, что раз и у второго чистого сервера шарпойнта возникла уже через несколько промежутков времени сама по себе такая ошибка, значит где-то в БД рыть нужно?

    22 ноября 2013 г. 3:34
  • лог ошибки представленный Вами описан в ULS Viewer - Home (в комментариях). и не связан в общей темой обсуждения.
    22 ноября 2013 г. 6:18
    Модератор
  • хм.

    ну вообщем я удалил все базы связанные с Sharepoint, поставил новый сервер, новая установка - чистый сервер. Все вроде бы работало. С утра захожу ииии .. опять все тоже самое - на чистой некастомной системе... походу сервер SQL продолжает жувать все мое детище... и походу и его нужно с нуля переставлять - это капрац какой то((

    23 ноября 2013 г. 5:01
  • Это только с одной страничкой такое?
    Что за веб-часть? Кастомная?

    Какая версия sql и sharepoint?
    Какая архитектура? Сколько серверов и что на каждом?

    Попробуйте создать пустую страничку.
    Поместите на нее веб-часть.

    • Предложено в качестве ответа Alexander Ulmaskulov 23 ноября 2013 г. 10:37
    • Отменено предложение в качестве ответа Sobsoft 23 ноября 2013 г. 13:59
    23 ноября 2013 г. 10:37
  • неенен... со страницами все норм. с формами инфопач все норм. все плохо только с веб-частями списков (кроме календаря - ему повезло тоже). а так даже нульцевый настраиваемый список с 1 полем заголовка троит. как форма просмотра, так и представления. ещё BCS формам просмотра тоже повезло, но не представлению опять же. Страницы веб-частей и вики - тоже в порядке (но не веб-части на них естественно).

    Sharepoint 2013 на Win Server 2012, SQL 2012 на Win Server 2012 (оба датацентр версии).

    Ещё есть сервер с Dynamics CRM 2011 на Win Server 2008R2 - но он абсолютно не пострадал.

    При создании пустой страницы та же фигня( 

    23 ноября 2013 г. 10:44
  • Что-то делали? С чего все началось?

    Сколько серверов в ферме?

    Получается только xslt веб-части не работают? 


    23 ноября 2013 г. 11:27
  • Что-то делали? С чего все началось?

    Сколько серверов в ферме?

    Получается только xslt веб-части не работают? 


    Ну товарищ ставил новую версию CRM для пробы. Говорит дополнительный инстанс для MSSQL делал на том же сервере. До 6 вечера рабочего дня все работало исправно. Даже до 9 - в 9 вечера я через Sharepoint Designer допиливал дизайн masterpage. Более ничего сверхьестественного.

    В ферме SP только 1 сервер и 2 узла (внутренний и внешний - у обоих одинаковые проблемы, но это понятно итак - 1 ферма). 

    Насчет XSL получается именно так. Папку эту я проверял - с ней все норм (ну там права, владелец и т.п.).

    23 ноября 2013 г. 11:32
  • Попробуйте временно поставить стандартную мастер-страницу.

    Точнее создайте узел, оставьте стандартную мастер-страницу.

    Маловероятно, но все же.

    В нерабочее время попробуйте восстановить БД из бэкапа. (Текущее состояние сохраните только)

    Может поможет. Но тоже маловероятно. Во всяком случае даст понять, что БД не менялась.

    И не только БД контента, но и БД настроек.

    Может еще какие то изменения были?

    23 ноября 2013 г. 12:14
  • Попробуйте временно поставить стандартную мастер-страницу.

    Точнее создайте узел, оставьте стандартную мастер-страницу.

    Маловероятно, но все же.

    В нерабочее время попробуйте восстановить БД из бэкапа. (Текущее состояние сохраните только)

    Может поможет. Но тоже маловероятно. Во всяком случае даст понять, что БД не менялась.

    И не только БД контента, но и БД настроек.

    Может еще какие то изменения были?

    Стандартная мастер страница стоит на внутреннем узле без изменений.
    На кастомном узле ставил все странницы из идущих в комплекте - та же беда. тем более я ж выше писал я ставил шарпойнт с нуля - абсолютно новый чистый сервер - спустя какое то время произошла та же беда. бд восстанавливал с начала несколько раз - резульатов ноль.
    и если сервер бд переставить заново это не проблема, то если сервер ад чето троит (предполагаю) то тогда трындец - он физический сервер и на нем все виртуалки.
    23 ноября 2013 г. 12:20
  • Вы новую ферму ставили?

    Т.е. новый sql и новый SP?

    Виртуальные машины новые сделали?

    23 ноября 2013 г. 12:47
  • вспомнил, может быть проблема с веб частями  и из-за обновлений Windows

    вот ветка SharePoint 2010 ошибка: "Не удается отобразить эту веб-часть..."

    23 ноября 2013 г. 13:18
    Модератор
  • вспомнил, может быть проблема с веб частями  и из-за обновлений Windows

    вот ветка SharePoint 2010 ошибка: "Не удается отобразить эту веб-часть..."

    Владимир, к сожалению и это я уже успел прочесть. Не то, тем более хочу в очередной раз повторить "ЧИСТЫЙ СЕРВЕР" с шарпойнтом делает все то же самое.

    Если бы ещё обновления SQL ладно, но их не ставилось давно уже (2-3 недели).

    23 ноября 2013 г. 13:59
  • А время везде одинаковое?
    23 ноября 2013 г. 14:28
  • А время везде одинаковое?
    да
    23 ноября 2013 г. 14:29
  • К сожалению, вынужден закрыть вопрос. пробный период заканчивается и такие выкрутасы руководство не устроили (
    • Помечено в качестве ответа Sobsoft 23 ноября 2013 г. 14:30
    23 ноября 2013 г. 14:30
  • К сожалению, вынужден закрыть вопрос. пробный период заканчивается и такие выкрутасы руководство не устроили (

    Жаль что так вышло.

    Ради теста - попробуйте с новым доменом.

    23 ноября 2013 г. 15:56
  • ну как то уж сильно громоздко.
    тем более объяснить компьютерно неграмотному руководству - очень тяжело.
    ну и пользователям в количестве 80 человек сбросить пароли весьма "морально" тягостно - каждый ведь хочет выразить свое мнение. так что если вдруг после установки SP 2010 будет аналогичная проблема, то да - безусловно жахну и АД тоже. Но это в самом крайнейнем случае.
    23 ноября 2013 г. 15:59