none
Отказоустойчивое VPN подключение RRS feed

  • Вопрос

  • Цель организовать отказоустойчивое VPN соединение удаленного сервера WinSvr2012 с существующей инфраструктурой предприятия.

    На стороне предприятия установлена CISCO с сконфигурированным VPN сервером L2TP и IPSEC.

    На удаленном сервере создано L2TP подключение.

    Как организовать автоматическое переподключение к VPN серверу в случае разрыва связи?


    18 октября 2013 г. 13:22

Ответы

  • Использовать не подключение, а создать интерфейс соединения по требованию (Demand-dial) в Routing and Remote Access Server (RRAS). Для этого надо установить роль Remote Access со службой Routing, в мастере начальной конофигурации выбрать VPN Only, а затем настроить RRAS в варианте Secure Connection between two private networks (или Custom, с добавлением Deand-dial connections)

    Слава России!

    18 октября 2013 г. 14:08
  • Windows Server 2012 R2 официально заявлен в публичном доступе, если есть возможность, обновитесь и используйте Auto Triggering, срабатывающее на разрешение имен.

    18 октября 2013 г. 15:03
    Отвечающий
  • Добрый день

    на чей стороне ПО Microsoft или Cisco?

    уточните какая железяка стоит

    как вариант балансировщик поставить,

    либо в зависимости от модели железа и купленой лицензии на

    Cisco написать конфиг 

    ip sla monitor 1
    type echo protocol ipIcmpEcho 78.140.11.1 source-interface FastEthernet0/1
    ip sla monitor schedule 1 life forever start-time now
     
    track 11 rtr 1 reachability
     
    interface FastEthernet0/0
    description L2RTK
    ip address XX.XX.XX.XX 255.255.255.252
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
     
    interface FastEthernet0/1
    description L2Tomica
    ip address YY.YY.YY.YY 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
     
    interface FastEthernet0/0/0
    switchport access vlan 99
     
    ...
    interface Vlan99
    ip address 192.168.99.1 255.255.255.252
    ip nat inside
    ip virtual-reassembly
    ip policy route-map ISP
     
    ...
    ip route 0.0.0.0 0.0.0.0 X1.X1.X1.X1 track 11
    ip route 0.0.0.0 0.0.0.0 Y1.Y1.Y1.Y1 50
     
    ...
    route-map Tomica permit 10
    match interface FastEthernet0/1
    !
    route-map RTK permit 10
    match interface FastEthernet0/0
     
    * где X1, Y1 шлюзы провайдеров
     

    Если на стороне Windows server

    создать VPN подключение (резервный)

    написать скрипт на переключение на резервный порт Cisco при падении

    первичного WAN канала провайдера


    Я не волшебник, я только учусь MCTS Мнения, высказанные здесь, являются отражение моих личных взглядов, а не позиции работодателя. Вся информация предоставляется как есть без каких-либо гарантий Мой Блог http://blogs.officeonline.su/


    18 октября 2013 г. 13:43
    Модератор

Все ответы