locked
The requested OLE DB provider Microsoft.ACE.OLEDB.12.0 is not registered RRS feed

  • السؤال

  • I have a Dataflow that has Exccel Source. When I run, I get this error.

    [Connection manager "Excel Connection Manager"] Error: The requested OLE DB provider Microsoft.ACE.OLEDB.12.0 is not registered. If the 64-bit driver is not installed, run the package in 32-bit mode. Error code: 0x00000000.
    An OLE DB record is available.  Source: "Microsoft OLE DB Service Components"  Hresult: 0x80040154  Description: "Class not registered".

    I've seen this error before on another server and I fixed that by installing a driver from this link.

    http://www.microsoft.com/en-us/download/confirmation.aspx?id=13255

    That same driver for some reason isn't fixing this error on my current machine. As far as I know, the two machines have the same spec. I've also read verious discussions on this and tried all those suggestions, but not able to fix this problem.

    Questions:

    (1) How can I verify that the driver is installed correctly? I have check the installed programs in the Programs and Features window and I do see something called Microsoft Access database engine 2010. Is this the 64 bit driver that the error message is complaining about?

    (2) To further verify, is there a certain file I should look for in C:\Program Files or C:\Program Files (x86)?

    03/رمضان/1434 04:23 م

الإجابات

  • How do you run the package? In BIDS or on the server?

    * if in BIDS: set the Run64BitRuntime property to False in the project properties

    * on the server: install the 64-bit driver or run the package in 32-bit mode by either calling the 32-bit DTEXEC or by checking the 32-bit runtime option in the SQL Server Agent job


    MCSE SQL Server 2012 - Please mark posts as answered where appropriate.

    • تم الاقتراح كإجابة بواسطة Mike Yin 08/رمضان/1434 02:25 ص
    • تم وضع علامة كإجابة بواسطة Mike Yin 10/رمضان/1434 09:51 ص
    04/رمضان/1434 06:44 ص

جميع الردود

  • You simply need to run your package in 32 Bit mode

    Arthur My Blog

    03/رمضان/1434 06:34 م
  • How do you run the package? In BIDS or on the server?

    * if in BIDS: set the Run64BitRuntime property to False in the project properties

    * on the server: install the 64-bit driver or run the package in 32-bit mode by either calling the 32-bit DTEXEC or by checking the 32-bit runtime option in the SQL Server Agent job


    MCSE SQL Server 2012 - Please mark posts as answered where appropriate.

    • تم الاقتراح كإجابة بواسطة Mike Yin 08/رمضان/1434 02:25 ص
    • تم وضع علامة كإجابة بواسطة Mike Yin 10/رمضان/1434 09:51 ص
    04/رمضان/1434 06:44 ص