none
Error [0x80070003] The system cannot find the path specified

    Question

  • We have Windows 2012 Server hosting 2 VMs - Domain Controller & RDS.  We have been doing Windows Server Backup incremental and have an ongoing issue with scheduled backups each night.  The backup shows completed with warnings and generates 2 log files.

    The first log files shows:  

    Backup of volume \\?\Volume{5d46f853-5db2-11e2-93e7-806e6f6e6963}\ succeeded.

    Backup of volume C: succeeded.

    Backup of volume F: succeeded.

    Application backup
    Writer Id: {66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}
       Component: ACBCD71E-A8CA-4672-B951-52C1BE8444BE
       Caption     : Backup Using Child Partition Snapshot\FMLRDS1
       Logical Path: 


    Writer Id: {66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}
       Component: Host Component
       Caption     : Host Component
       Logical Path: 

    The 2nd log file more often than not shows:  

    Backup of volume E: has failed. Backup failed as shadow copy on source volume got deleted. This might caused by high write activity on the volume. Please retry the backup. If the issue persists consider increasing shadow copy storage using 'VSSADMIN Resize ShadowStorage' command.

    Error in backup of E:\ during enumerate: Error [0x80070003] The system cannot find the path specified.
    Application backup
    Writer Id: {66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}
       Component: 2B4A9541-C88B-442E-9A7A-6D8A27342C11
       Caption     : Backup Using Child Partition Snapshot\FMLDC1
       Logical Path: 
       Error           : 8078010D
       Error Message   : Enumeration of the files failed.

       Detailed Error  : 80070003
       Detailed Error Message : (null)

    We had been getting a successful backup once or twice a week which showed completed (with no mentioned of warnings) but now it regularly shows completed with warnings as noted above.  

    We did a manual full backup of the DC to a different external drive a few days ago and that completed without warnings and the backup shows:  E: Completed 63.38 Full - VSS Copy Backup Successful, 8/27/13 3:35 PM - 4:43 PM. Data Transferred 63.38

    On a side note, we can view the logs in the windows/logs/windowsserverbackup directory but when we attempt to view the details of a log file through the Local Backup Console for any log which shows completed with errors, we get a "MMC has detected an error in the snapin and will unload and then it shows Object referenced not set to instance of an object."  The manual backup noted above that was successful is able to be viewed through the Local Backup Console without this error.  

    Any idea as to why this is failing during the scheduled backups?  This hosts a database that we need to have regular successful backups.


    Tuesday, September 03, 2013 4:55 PM

All replies

  • Hi,

    First please follow the steps below to re-register dll files. Detailed information could be found here: http://support.microsoft.com/kb/940032:

    1. Click Start, click Run, type cmd, and then click OK. 
    2. Type the following commands at a command prompt. Press ENTER after you type each command. 
    3. cd /d %windir%\system32 
    4. Net stop vss 
    5. Net stop swprv 
    6. regsvr32 ole32.dll 
    7. regsvr32 oleaut32.dll 
    8. regsvr32 vss_ps.dll 
    9. vssvc /register 
    10. regsvr32 /i swprv.dll 
    11. regsvr32 /i eventcls.dll 
    12. regsvr32 es.dll 
    13. regsvr32 stdprov.dll 
    14. regsvr32 vssui.dll 
    15. regsvr32 msxml.dll 
    16. regsvr32 msxml3.dll 
    17. regsvr32 msxml4.dll 

    Please let us know if any command failed to be performed with an error.

    If issue still exists, have a try with the step it provided "VSSADMIN Resize ShadowStorage" to enlarge the shadow storage.

    Also you could test to delete all old Shadow Copies by acccessing <Drive> Properties --> Shaodow Copies --> Delete Now. This will remove all your backup information so if it is not acceptable, just skip this step.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, September 05, 2013 11:52 AM
    Moderator
  • Thank you for your reply.  

    We attempted to regsvr the files as directed above and received several error messages as noted below:

    10. regsvr32 /i swprv.dll the module was loaded but the call to dllregserver failed with error code 0x80070715

    11. regsvr32 /i eventcls.dll the module was loaded but the call to dllregserver failed with error code 0x80070715

    12. regsvr32 es.dll the module es.dll was loaded by the entrypoint dllregisterserver was not found make sure … is valid…

    14. regsvr32 vssui.dll the module was loaded but the call to dllregserver failed with error code 0x80070715

    15. regsvr32 msxml.dll the module failed to load.  Make sure the binary is stored at the specified path or debug…

    17. regsvr32 msxml4.dll the module failed to load.  Make sure the binary is stored at the specified path or debug…


    Thursday, September 05, 2013 3:21 PM
  • Did you run those commands from an Elevated Command prompt? That may have caused the errors if you didn't.
    Thursday, September 05, 2013 9:05 PM
  • We are logged in remotely as Administrator and are running from Command Prompt as Administrator and still getting those responses.  When we looked at the article you referenced and research those errors on our own, they are referring to Windows 2003 Server.  This is a Windows 2012 server if that makes a difference. 
    Friday, September 06, 2013 12:56 AM
  • Has there been any resolution to this?  My Server 2012 Windows Server Backup is posting the same error though on my C: drive.

    Error in backup of C:\ during enumerate: Error [0x80070003] The system cannot find the path specified.

    I have read that re-registering the VSS DLLs on Server 2012 could have a negative effects.  Any help on this would be greatly appreciated.

    Tuesday, October 01, 2013 3:46 PM
  • Not sure actually.  Very frustrated that Microsoft has given up on responding to this thread.  We did get a successful backup for a couple of days in a row after attempting to reregister but then it started to failed again a couple of days later and we did not get a full successful backup for over a week.  Yesterday we updated chipset and storage drivers on the Lenovo server and last night we got a successful backup.  I guess we are in a wait and see mode.  Not sure what to tell you as there is very little information on this problem and most of the items I have seen including a hotfix refer to Windows 2008 Server.
    Tuesday, October 01, 2013 4:10 PM
  • I have tons of errors from VSS, SPP and MSMQ at every backup. After a weeks runtime the server becomes unresponsive and failes to start backup. Reboot solves issue and vackup runs another 6 nights. Same as in example above, VM in Hyper-V 2012 R2, Windows Server 2012 R2 Standard.

    Starting wbadmin allways takes over a minute (reading from eventlog?)

    Always writes this en backup error log

    Writer Failures
    Writer Id: {7E47B561-971A-46E6-96B9-696EEAA53B2A}
    Instance Id: {9BA9259F-995B-4111-B5AC-832F5AC6F8FB}
    Writer Name: MSMQ Writer (MSMQ)
    Writer State: 8
    Failure Result: 800423F2
    Application Result: 1
    Application Message: (null)
       Component: config
       Logical Path: (null)
       Component Result: 800423F2
       Component Message: (null)
           File Spec: C:\Windows\System32\msmq\config\0*.* Recursive: 0
           File Spec: C:\Windows\System32\msmq\config\msmqreg.bkp Recursive: 0
           File Spec: C:\Windows\System32\msmq\config\msmqwebacl.bkp Recursive: 0
           File Spec: C:\Windows\System32\msmq\mapping\*.xml Recursive: 0
       Component: storage
       Logical Path: (null)
       Component Result: 800423F2
       Component Message: (null)
           File Spec: C:\Windows\System32\msmq\storage\LQS\* Recursive: 0
    *-----------------------------*
    Tuesday, February 18, 2014 9:50 AM
  • We resolved the problem by adding an additional hard drive to the server and set the VSS copies to be stored on that drive.  We have been trouble free since we did that.  Hope this is helpful to you.

    Lauri

    Tuesday, February 18, 2014 3:34 PM
  • Hi Marten,

    I am getting a similar writer failure as you. Did you ever find a solution?

    Server 2012 R2 hosting one VM of Win7 Pro (VM excluded from backup)

    We already have a dedicated ext HDD for VSS backups and another for WSB.

    Here is our log

    Writer Failures
    Writer Id: {66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}
    Instance Id: {72F58AA6-E2AD-4D7F-A916-1ECD1C069655}
    Writer Name: Microsoft Hyper-V VSS Writer
    Writer State: 5
    Failure Result: 80042336
    Application Result: 80004005
    Application Message: (null)
    Writer Id: {7E47B561-971A-46E6-96B9-696EEAA53B2A}
    Instance Id: {5505D5EA-24A2-45A9-B054-EDA3389315F2}
    Writer Name: MSMQ Writer (MSMQ)
    Writer State: 8
    Failure Result: 800423F2
    Application Result: 1
    Application Message: (null)
       Component: config
       Logical Path: (null)
       Component Result: 800423F2
       Component Message: (null)
           File Spec: C:\Windows\System32\msmq\config\0*.* Recursive: 0
           File Spec: C:\Windows\System32\msmq\config\msmqreg.bkp Recursive: 0
           File Spec: C:\Windows\System32\msmq\config\msmqwebacl.bkp Recursive: 0
           File Spec: C:\Windows\System32\msmq\mapping\*.xml Recursive: 0
       Component: storage
       Logical Path: (null)
       Component Result: 800423F2
       Component Message: (null)
           File Spec: C:\Windows\System32\msmq\storage\LQS\* Recursive: 0
    *-----------------------------*

    Thursday, June 11, 2015 10:57 PM
  • Solution to:MSMQ The system cannot find the path specified. 
    I know this is an old thread but we had a customer with the exact same problem and I found a solution to it. 

    backup will fail both with WBackup and Networker, with the error:
    Backup failed during event OnPrepareSnapshot. Error 0x80070003
    And from MSMQ: The system cannot find the path specified. 
    And the MSMQ vss writer is after that in a failed state

    I have tried it all, 
    * Add new disk for VSS Storage
    * Reregistred VSS dll's
    * Sfc /scannow
    * Checkdisk
    * Took recording with procmon on a system that worked with similar configuration and compared it with the system that had problem with no luck.
    * Vacumcleaning the internet on solutions but stil no luck.

    So in my case it was the MQ HTTP Support component that was the problem.
    As I understand it: If you have moved the default website to another location than c:\Inetpub\wwwroot this will 

    happen. For some reason when MQSvc is looking the MSMQ folder under C:\Inetpub\wwwroot Instead of %Yourdrive

    \Yourdefaultwwwroot%\MSMQ
    So in my case the solution was to create a MSMQ folder under C:\Inetpub\wwwroot and the backup began to work 

    again.
    Going through the procmon recording now that I know what caused the problem I see that I have 1 entry from Mqsvc.exe that tries to create a file under c:\inetpub\wwwroot\MSMQ and the result NAME NOT FOUND.
    When going through the procmon file I have over 100 000 NAME NOT FOUND, (but only one pointing wwwroot on c:\)

    So, I hope this will help someone out there struggling with MSMQ Writers that fails

    Best Regards

    Robert 

    Monday, December 07, 2015 11:50 AM
  • Did a simplified version

    PROBLEM:

    Backup don’t work either with Networker or Windows backup.

    Error from MSMQ:  Backup failed during event OnPrepareSnapshot. Error 0x80070003: The system cannot find the path specified.

    And VSS Writers hang in a incomplete state.

    CAUSE:

    If you have MSMQ HTTP Support enabled and if you have moved you Default Website away from C:\Inetpub\wwwroot this will happen.

    SOLUTION:

    Either disable HTTP Support in MSMQ feature or  add a folder named MSMQ under C:\Inetpub\wwwroot

    And the backup is working like a charm.


    • Edited by rodani Wednesday, December 09, 2015 8:11 AM
    • Proposed as answer by rodani Wednesday, December 09, 2015 8:14 AM
    Wednesday, December 09, 2015 7:21 AM
  • Thank you rodani, I just created the empty folder and fixed my problem.

    Xsibackup had problems using vss writer because of MSMQ.

    I lost 2 full days for an empty folder. Thanks Microsoft again for my lost hours.

    Saturday, February 20, 2016 7:55 PM