none
Enable-psremoting fails - Access Denied RRS feed

  • Question

  • I have a windows 2008 R2 server that is in a workgroup and no matter what I attempt to do to configure PowerShell remoting I get access denied error messages

    enable-psremoting yields access denied, try to set any property of WSMan and get access denied or more specifically

    Set-WSManQuickConfig : Access is denied.
    At line:50 char:33
    +             Set-WSManQuickConfig <<<<  -force
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand

    Even in ServerManager the link "Configure Server Manager Remote Management" has the checkbox checked but if I try to uncheck it I also get, yes you guessed it - Access Denied 

    Most posts and articles I have found assume Enable-PSremoting will work and I can't seem to get to first base because of this issue.  I suspect it has something to do with Kerberos but do not seem to have a way to help myself. 

    All commands are being issued by and admin account and PS is always launched with elevated authority.

    Monday, August 30, 2010 6:03 AM

Answers

  • Hi 

    You won't be able to replicate the issue at home, as there are some distinct differances the way that remoting works, on a domain and in a workgroup,

    So lets concentrate on the workgroup computer first,  here is a good write up using it in a workgroup  http://blogs.msdn.com/b/wmi/archive/2009/07/24/powershell-remoting-between-two-workgroup-machines.aspx I've been meaning to configure it at home so will have a shot at it later tonight let you know how I go.

    As for the domain computer, what OS is it ?  and are any GPO applied to it that may be configuring WinRM  ?

    cheers

    shane

     

      


    Shane Hoey scriptingdownunder.com | Scripting Downunder psugbne.org | Powershell Usergroup Brisbane
    Wednesday, September 1, 2010 5:06 AM

All replies

  • You wouldn`t by any chance got the display language set to any other than English?
    I got the same issue on a Windows 7 Enterprise computer once, where another displaylanguage was installed and activated.

    When I changed back to English, the Enable-PSRemoting ran fine. Seemed like a bug.


    Jan Egil Ring

    Blog: http://blog.powershell.no
    Twitter: http://twitter.com/janegilring
    Monday, August 30, 2010 6:51 AM
  • Hi, boycehr

    please try to run the command "whoami /all" to check whether the account you use belongs to the local admin group.

     

    And I think you can also create the other user with local admin privileges, then use the new created local admin to enable the PS-remoteing.

     

    Best Regards,

    Tommy HAO

    Monday, August 30, 2010 7:44 AM
  • did you open the console as elevated?
    Monday, August 30, 2010 10:21 AM
    Moderator
  • @Jan
    No thankfully everything is English.

    @Tommy
    My account is in a domain group which is in the local administrators group on the server.

    Tuesday, August 31, 2010 1:25 AM
  • @Oliver

    Thanks for the reply, yes all attempts to execute both PS and/or WinRM commands were done with elevated privledges.

     

    Tuesday, August 31, 2010 1:28 AM
  • at the start you said the server is in a workgroup,  but then mention your account is in a domain group ?  

    Setting up remoting on a domain joined computer is differant to a workgroup computer,  for example a computer  in a workgroup you need to configure the computer for https trasport and add the remote computers into trusted hosts. You must use -credential parameter on all remote commands. 

    Finally which I doubt this is it, but you need to make sure you've set a password on the account otherwise remote commands will fail.

    cheers

    shane 


    Shane Hoey scriptingdownunder.com | Scripting Downunder psugbne.org | Powershell Usergroup Brisbane
    Tuesday, August 31, 2010 11:26 AM
  • Thanks for the reply Shane...

    You're right - I got my two powershell issues confused and said the domain group when I should have said local admins group. I encounter this issue while I was trying to get some experience in my home lab environment, which does not have a domain to help me solve an issue at work where there is a domain so it was a not quite Fruedian slip.  I never got to replicating my work problem at home because of the problem initializing remoting in the workgroup. 

    Any how I am not sure I understood your suggestion and I think your answer jumped ahead of where I am unless you are telling me that before I run ENABLE-PSREMOTING on the server I have to set up HTTPS first on the workgroup server.  Can you supply a hint as to how to do that?

    Locally on the server I tried > winrm quickconfig -transport:https
    and
    winrm create winrm/config/listener?Transport=HTTPS

    but got - you guessed it "Access Denied" for both

    BTW your were right - there is a password on the admin account I am using and I am logged in locally at the console on the workgroup server where I connot get WinRM to do much of anything for me that does not return an ACCESS DENIED message.

     

    • Proposed as answer by jfaoc Thursday, November 1, 2012 2:02 AM
    Wednesday, September 1, 2010 4:11 AM
  • Hi 

    You won't be able to replicate the issue at home, as there are some distinct differances the way that remoting works, on a domain and in a workgroup,

    So lets concentrate on the workgroup computer first,  here is a good write up using it in a workgroup  http://blogs.msdn.com/b/wmi/archive/2009/07/24/powershell-remoting-between-two-workgroup-machines.aspx I've been meaning to configure it at home so will have a shot at it later tonight let you know how I go.

    As for the domain computer, what OS is it ?  and are any GPO applied to it that may be configuring WinRM  ?

    cheers

    shane

     

      


    Shane Hoey scriptingdownunder.com | Scripting Downunder psugbne.org | Powershell Usergroup Brisbane
    Wednesday, September 1, 2010 5:06 AM
  • also just another thought have you confirmed the WinRM port is open on the firewall ?

     


    Shane Hoey scriptingdownunder.com | Scripting Downunder psugbne.org | Powershell Usergroup Brisbane
    • Proposed as answer by jfaoc Thursday, November 1, 2012 2:01 AM
    • Unproposed as answer by jfaoc Thursday, November 1, 2012 2:02 AM
    • Proposed as answer by jfaoc Thursday, November 1, 2012 2:02 AM
    Wednesday, September 1, 2010 5:07 AM