none
Start-job is giving "The background process reported an error with the following message: ." RRS feed

  • Question

  • Hi team,

    I am using following script block and it is always returning error. Can you check what is wrong in this?

    ===============================================================

    $Job = start-job -ScriptBlock {get-process};

    get-job ($job.Name);;

    $job.ChildJobs[0].JobStateInfo.Reason.Message;

    Error returned is:-

    The background process reported an error with the following message: .

    =============================================================================

    Powershell version is as below:-

    Name                           Value                                                                                 
    ----                           -----                                                                                 
    PSVersion                      5.1.14393.2969                                                                        
    PSEdition                      Desktop                                                                               
    PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}                                                               
    BuildVersion                   10.0.14393.2969                                                                       
    CLRVersion                     4.0.30319.42000                                                                       
    WSManStackVersion              3.0                                                                                   
    PSRemotingProtocolVersion      2.3                                                                                   
    SerializationVersion           1.1.0.1     

    receive-job ($job.name); gives 

    +++++++++++++++++++++++++++++++++++

    [localhost] The background process reported an error with the following message: .
        + CategoryInfo          : OpenError: (localhost:String) [], PSRemotingTransportException
        + FullyQualifiedErrorId : 2100,PSSessionStateBroken

    ++++++++++++++++++++++++++++++++

    Windows OS :- Windows server 2016 in azure VM.

    Please let us know the fix.

    Thank You.

    Regards,

    Subhash


    Regards,
    Subhash Konduru
    ------------------------------------------------------------------------------------
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, August 12, 2019 12:11 PM

All replies