none
SCOM 2012 - Event ID 6024 (Launching Restart Health Service. Health Service exceeded Process\Handle Count or Private Bytes threshhold.) RRS feed

  • Question

  • I am getting event ID 6024 (LaunchRestartHealthService.js : Launching Restart Health Service. Health Service exceeded Process\Handle Count or Private Bytes threshhold.) within an interval ranging from 12-17 minutes.

    I am using SCOM (2012 SP1 and 2012 R2) on Windows Server (2008 R2 / 2012 / 2012 R2).

    This issue is occurring only on agent managed computer (acting as proxy and discover managed objects on other computers setting is enabled) which i am using for monitoring my device. All discovery scripts (powershell) and monitors are targeted on this agent managed computer.

    There are total 80 discoveries and 900 monitors. 55 discoveries and 550 monitors are enabled by default and rest all are disabled.

    I am seeing event id 6024 frequently only on agent managed computer. Can anyone help me to resolve this issue.

    Thanks,

    Mukul

    Monday, July 28, 2014 9:53 AM

Answers

  • To fix issue 6024, you can follow below steps:

    1. Open SCOM console. Go to Monitors -> Agent -> Entity Health -> Performance -> Health Service Performance -> Health Service State.

    2. Double click Health Service Handle Count Threshold monitor and go to Overrides page.

    3. Click Override -> For a specific object of Class: Agent. Select the affected SCOM agent QMXServer.

    4. Check on the parameter Agent Performance Monitor Type - Threshold. Change the default value 2000 to an appropriate value, like 4000. You can check the Health service handle count alert in SCOM console to get the value when the alert is generated. You can also launch the health explorer against QMXServer to check the value when the monitor state is changed from healthy to critical.

    Also you can refer below links

    http://blogs.technet.com/b/omx/archive/2013/10/17/health-service-restarts-on-service-manager-servers-with-scom-agents.aspx


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question, please click "Mark As Answer" Mai Ali | My blog: Technical | Twitter: Mai Ali

    • Marked as answer by Dr. Mukul Jain Thursday, August 14, 2014 10:16 AM
    Wednesday, July 30, 2014 12:02 AM

All replies

  • Hi,

    I would like to suggest you to identify why this agent's health service handle count is exceeding the threshold before you increase the threshold for this particular system. You may download the handles.exe tool from SysInternals to evaluate what is occuring with the HealthService and review the Health Service Handle Count threshold using PerfMon.

    Here is a blog that could be helpful, please go through it:

    The new and improved guide on HealthService Restarts.  Aka – agents bouncing their own HealthService

    http://blogs.technet.com/b/kevinholman/archive/2009/12/21/the-new-and-improved-guide-on-healthservice-restarts-aka-agents-bouncing-their-own-healthservice.aspx


    Regards, Yan Li

    Tuesday, July 29, 2014 6:08 AM
    Moderator
  • To fix issue 6024, you can follow below steps:

    1. Open SCOM console. Go to Monitors -> Agent -> Entity Health -> Performance -> Health Service Performance -> Health Service State.

    2. Double click Health Service Handle Count Threshold monitor and go to Overrides page.

    3. Click Override -> For a specific object of Class: Agent. Select the affected SCOM agent QMXServer.

    4. Check on the parameter Agent Performance Monitor Type - Threshold. Change the default value 2000 to an appropriate value, like 4000. You can check the Health service handle count alert in SCOM console to get the value when the alert is generated. You can also launch the health explorer against QMXServer to check the value when the monitor state is changed from healthy to critical.

    Also you can refer below links

    http://blogs.technet.com/b/omx/archive/2013/10/17/health-service-restarts-on-service-manager-servers-with-scom-agents.aspx


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question, please click "Mark As Answer" Mai Ali | My blog: Technical | Twitter: Mai Ali

    • Marked as answer by Dr. Mukul Jain Thursday, August 14, 2014 10:16 AM
    Wednesday, July 30, 2014 12:02 AM
  • I have tried to override the value from 2000 to 4000 and then 6000 and lately i have done it 10000. but it is not helping.
    Wednesday, July 30, 2014 5:35 AM