locked
The Audience URI could not be validated RRS feed

  • Question

  • I have two load balanced WFEs. My site is using Form Based Authentication (FBA).

    There is also two load balanced Proxy Servers in between. Let's call my site www.example.com.

    So if someone opens my site then it goes like this:

    1. Request first come to load balancer of proxy server
    2. Let's say request goes to proxy1
    3. From there it goes to load balancer of WFE
    4. Let's say request goes to WFE2
    5. And then finally the site opens in browser.

    If I go to www.example.com/login.aspx and enter correct user/password then it works and I am able to login.

    If I go to example.com/login.aspx and enter correct user/password then I get following error:

    The Audience URI could not be validated

    I read that this is due to incorrect/missing entries in Alternate Access Mapping (AAM). Please check attached to see AAM entries.

    This is only happening when I am browsing site like normal user from my PC. If I take Remote Desktop (RDP) of WFE1 or WFE2 and open site from there after making entries in HOSTS file then it works fine.

    How do I solve this issue?

    Friday, December 18, 2015 2:32 PM

Answers

  • Fixed the issue by applying correct AAM settings. Here's how I did it.  

    Deleted "Custom" zone and only kept "Default" and "Internet" zones. In Internet zone I defined www.example.com as public URL. I then added following Internal URLs in "Internet" zone.

    example.local  
    www.example.com  
    example.com
    • Proposed as answer by Victoria Xia Monday, December 21, 2015 9:57 AM
    • Marked as answer by Victoria Xia Friday, January 1, 2016 6:14 AM
    Friday, December 18, 2015 3:38 PM

All replies

  • Fixed the issue by applying correct AAM settings. Here's how I did it.  

    Deleted "Custom" zone and only kept "Default" and "Internet" zones. In Internet zone I defined www.example.com as public URL. I then added following Internal URLs in "Internet" zone.

    example.local  
    www.example.com  
    example.com
    • Proposed as answer by Victoria Xia Monday, December 21, 2015 9:57 AM
    • Marked as answer by Victoria Xia Friday, January 1, 2016 6:14 AM
    Friday, December 18, 2015 3:38 PM
  • Hi Frank,

    I am glad that your issue has been resolved.

    You can mark it as answer and it will help others who meet the same issue.

    Best regards,

    Victoria


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, December 21, 2015 9:57 AM