Got a sick sbs2011 Where to begin fixing things? RRS feed

  • Question

  • I have a neglected sbs2011 (by me), that I am trying to fix. I didn't need the server the last couple of years, it has been running in the background doing a few tasks, and never caused any reason for concern. I just decided to see if I could revive the server's RRAS capability, and it seem there is a LOT wrong with the server now. When I open the server manager, I see many red marks, and I have started to fix them. The first thing I looked at were the certificates. Some of them had expired. The then opened the SBS console to run "fix my network", which is supposed to renew some (?) certificates, but I was told by the server that there was no internet connection (which was strange since was able to open browser windows to a anywhere I wanted). Looking here and in other places, I found that the fix my network wizard doesn't like when the sbs is not the DHCP server (My firewall is the DHCP server), which I think was a good thing, otherwise I would have had all sorts of issues with clients on the network. Interestingly, also the remote desktop application works, but I digress. So I disabled DHCP on the firewall and enabled it on the SBS, but when I boot up a client, they don't get an IP address. Trying to fix that, I ran some other diagnostic that told me that the DNS service failed to start (but when I look in the services, it appears to be running). If I look at clients that were running before I changed the DHCP, they happily continue to access internet resources (I suppose they kept their IP information from before the change). Another interesting point is that the SBS connects to the internet when I restart it (I can browse), but a couple of minutes into the session, it now loses the internet connection (the network icon in the tray sprouts a yellow flag with a "1" in it. This flag goes away and hovering over the icon I am told that I have internet connection, but neither the server or any browser connects. I also cannot ping anything, not even resources on the internal network. And without an internet connection, nothing seems to work anymore.

    I figured that this must be a problem with the network settings of the adapter of the server (as that is fixed and does not come from a DHCP server), but I can't find anything wrong there. In fact, if I do an ipconfig on the server, everything looks normal, just as it does on the clients that do connect to the internet (not sure about the IPv6 settings. I tried to disable IPv6, but that did not help).

    So, what would you recommend to start with to get this sick puppy to a reasonable healthy state?

    I know that I should probably upgrade to a newer version, but there is one or two legacy applications running on the server that would be an absolute pain to move ...

    Tuesday, December 10, 2019 6:10 PM

All replies

  • Hi,

    If possible, please access the hardware provider’s official website, then, manually download and re-install the NIC driver for your SBS. 

    As far as I know, SBS has its built-in wizard to configure the network. If possible, please re-run the wizard again to check the result. 

    Complete the Getting Started Tasks:

    Besides, as it is previous version of system, it is always recommended to patch the system fully with Windows Update/Hotfix.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 11, 2019 8:16 AM
  • Thanks. I will check for an update of the NIC driver, but I doubt that it is the problem. After all, I do get access to the Internet occasionally, and the internal network connection (Remote Desktop) pretty much never fails.

    Yes, there is a "Fix my network" option on the SBS console. I have run that multiple times, but it does not help. I think one reason is that it needs an internet connection, which I typically have for a couple of minutes after I reboot the server, and that is not enough time for the wizard to finish. I also need the internet connection to download any updates. I also checked, and I think the server is up to date, also I am not 100% sure.

    At this moment I started Remote desktop, and was able to log in without problems. However, there is a warning message that "The server name or address could not be resolved" (started the remote desktop with the server name, not the IP, so it would have to be resolved somewhere). Another weird thing is that the warning has just a chinese symbol in the title bar???

    Current situation:

    network icon in tray says: Internet connection

    Remote desktop: works fine, no problems

    web browser: "No internet"

    SBS console: no internet connection

    Running Windows Network Diagnostics: "couldn't identify the problem"

    Ping "General Failure"

    Ping (the PC that I using the remote desktop on): "General failure"

    I found one difference between the desktop and the server I am using. Ipconfig shows the desktop with a node type: Broadcast, the server with "Hybrid". However, switching the server to broadcast does not change anything. After restart:

    tray icon: internet access, browser works, SBS console shows internet connection. ping works

    Start Fix my network. crashes a few minutes later ("stopped responding")

    tray icon: still says "internet access". SBS console says "not connected", no browser , no ping.

    Hitting "Connect to the internet" in SBS colsole: Detecting existing networks: OK, Detecting existing Routers (after a few minutes): asks for router and server IP address. Enter router IP. Server cannot find router (no ping??). Wizard stops working... (Option to check online for a solution. Interesting suggestion for a Wizard that is suppose to try to connect to the Internet...). Problem details:

    Problem signature:
      Problem Event Name: CLR20r3
      Problem Signature 01: CTIW.exe
      Problem Signature 02: 6.1.7900.0
      Problem Signature 03: 4cd854bd
      Problem Signature 04: CTIW
      Problem Signature 05: 6.1.7900.0
      Problem Signature 06: 4cd854bd
      Problem Signature 07: 7e
      Problem Signature 08: 101
      Problem Signature 09: N3CTRYE2KN3C34SGL4ZQYRBFTE4M13NB
      OS Version: 6.1.7601.
      Locale ID: 1033
      Additional Information 1: 4229
      Additional Information 2: 4229adec8750b661e4eff5a8aa0d55e8
      Additional Information 3: 2f6c
      Additional Information 4: 2f6c1f3af968c45714a27905b3094d82

    Checked IPconfig again, and the adapter settings changed (Server now This must have happened during the "Fix my network" or "Connect to the internet wizards". Will they change the IP settings of the adapter? Why? It is not set to DHCP...

    Trying a few more things...

    Thursday, December 12, 2019 7:13 PM
  • Just a quick update:

    got the internet connection back. Turned out to be a setting in the network adapter. The IPv4 and IPv6 settings were set to "IP routing". Not sure where that came from, but disabling that, fixed the connection problem. Now I can tackle the other issues one by one ...

    Friday, December 13, 2019 5:54 AM
  • Hi,

    Thank you for taking the time to update the details and show your solution. If there is any more questions or concerns, please feel free to let us know. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 16, 2019 8:11 AM