none
The permissions granted to user 'NT AUTHORITY\ANONYMOUS LOGON' are insufficient for performing this operation. While deploying SSRS reports to SharePoint 2013. How to resolve the issue? RRS feed

  • Question

  • Hello Everybody,

    I'm facing a permission issue while deploying SSRS 2012 reports to SharePoint 2013. The error is below.

    Error 1 The permissions granted to user 'NT AUTHORITY\ANONYMOUS LOGON' are insufficient for performing this operation. ---> Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user 'NT AUTHORITY\ANONYMOUS LOGON' are insufficient for performing this operation. 0 0

    SSRS configuration with SharePoint is correct and both the services are running in same machine.

    Please help me to resolve this issue.

    Reagrding,
    Thiru


    • Edited by P T Reddy Tuesday, April 29, 2014 12:06 PM
    Tuesday, April 29, 2014 12:05 PM

Answers

  • Hi P T,

    SSRS does not support anonymous access.  You can disable anonymous access or extend the Web Application into another zone that does not have anonymous access enabled?

    clip_image001 clip_image002 clip_image003 clip_image004 clip_image006 clip_image008


    -Ivan

    Tuesday, April 29, 2014 2:28 PM

All replies

  • Hi P T,

    SSRS does not support anonymous access.  You can disable anonymous access or extend the Web Application into another zone that does not have anonymous access enabled?

    clip_image001 clip_image002 clip_image003 clip_image004 clip_image006 clip_image008


    -Ivan

    Tuesday, April 29, 2014 2:28 PM
  • Hello Ivan,

    Thank You for Your reply. Its worked for me.

    Regards,

    Thiru


    Thanks and Regards, Thirupathi Reddy

    Wednesday, April 30, 2014 11:31 AM
  • Where is the anonymous access disable option?

    Edit: I found the option:  Go into IIS Manager, navigate through Sites > (SharePoint site with SSRS in Integrated Mode) > Authentication > Anonymous Authentication = Disable


    Friday, December 19, 2014 5:34 PM
  • Hans558,

    Thanks for the solution, it worked for me.

    Wednesday, February 18, 2015 1:34 PM
  • Thanks Hans558
    Thursday, January 7, 2016 6:18 PM
  • Hello Ivan,

    I also faced this strange issue and spent a lot of time investigating it, until I found your response.

    Definitely when I disabled the anonymous access from SharePoint Central Admin (Authentication Providers) it starts working.

    So my question to you is: why SQL server report builder is trying to save the report with anonymous account in case I'm logged in to the client machine with admin account and I'm using the SQL server builder report with the same account, I can open the SharePoint report library with this account (I have full control to this site)?

    Thank you for your prompt reply.


    Sunday, August 21, 2016 7:24 PM
  • I have this problem too.But another site that has anonymous access can open report from site .can you help me?
    • Edited by MahlaT Sunday, September 11, 2016 9:38 AM
    Sunday, September 11, 2016 9:35 AM