none
NPS 2016 non autentifica macchine win7 RRS feed

  • Domanda

  • Buongiorno, dalla scorsa settimana ho un problema alquanto strano. Tutte le macchine windows7 non vengono più autenticate dal mio server radius. Premesso che il sistema sta funzionando da almeno un paio di anni senza problemi e  che sul server non è stato modificato nulla. L'ultimo aggiornamento risale a quasi un mese fa. Il certificato è valido e scade tra un anno circa, le macchine win10 che utilizzano la stessa policy non hanno nessun problema di collegamento. L'unica cosa strana che noto guardando i log di NPS è che le macchine win7 si presentano come account name con questa stringa host/nomemacchina.dominio e il log termina con un Reason code 48  "The connection request did not match any configured network policy", mentre le macchine win10 si presentano come account name con questa stringa  dominio\nome utente e il log termina con   "Accounting information was written to the local
    log file."

    Ringrazio anticipatamente chiunque possa darmi un aiuto per risolvere il problema

    Luca

    martedì 7 luglio 2020 13:16

Tutte le risposte

  • Ciao,

    trovato una situazione simile con una risoluzione:

    I had to go into NPS:

    Policies > Network Policies > Double Click policy name > Constraints tab > Auth Methods > Select EAP/PEAP and click Edit > I changed the "Certificate Issues to" dropdown and tried different ones. I am now using the cert with CA-1 on the end because the server itself is a root CA. All seems to be working now, even on Windows 7.

    Sorry this isn't the most informative, but I thought I would put my solution just in case anyone else has similar issues with similar knowledge with RADIUS as me.

    Articolo originale

    Saluti, Nikola

    giovedì 9 luglio 2020 08:28
    Moderatore
  • Ciao Nikola, ti ringrazio per l'aiuto ma purtroppo non funziona. Io se scrollo la tendina del certificato mi fa sceglier solo tra il nome del serverNPS e il nome del serverNPS.dominio. In entrambe i casi non funziona
    giovedì 9 luglio 2020 13:17
  • hai detto che non hai toccato nulla e che tutto funziona allo stesso modo da un paio di anni, corretto ?

    l'unica differenza è che i client win7 non si autenticano più tramite radius, giusto ?

    quali criteri sono impostati su radius per permettere l'accesso dei clients ?

    usi i certificati digitali ?

    sembrerebbe un problema di crittografia...


    Edoardo Benussi
    e[dot]benussi[at]outlook[dot]it


    lunedì 13 luglio 2020 08:39
    Moderatore
  • Ciao Edoardo, scusa per la risposta in ritardo, ma tra il periodo di ferie e quello anomalo per varie emergenze post covid non sono più riuscito a seguire il problema. I criteri impostati sul radius sono i seguenti:

    - Condizioni = windows group (domain users)

                          NAS PORT TIPE  Wireless- IEEE 802.11 Or Wireless -Other

    - Authentication Methods=  secured password (EAP-MSCHAP v2)

                                            Protected  EAP (PEAP)

    IL certificato che uso è quello creato da una mia CA Interna su windows server 2008 R2. Il certificato è stato rinnovato automaticamente il giorno 26-06-2020 e scade il 26-06-2021

    L'unica cosa che ho notato tra i due radius che ho implementato nelle due sedi è quella che in una il radius risiede su un server 2008 R2 ( come la CA) e non ho nessun problema, mentre l'altro risiede su un server 2016 ed è quello che mi crea problemi. Ma il problema è nato solo ultimamente, mentre il server 2016 è installato da parecchio tempo con a bordo il Radius. Ora che ti scrivo mi sono accorto anche di un'altra cosa che combinazione ha la data dell'inizio dei miei problemi. Il certificato associato è stato rinnovato proprio nei giorni dove è cominciato il problema.

    Grazie in anticipo

    Luca

      

    venerdì 7 agosto 2020 07:29
  • A me sembra per deduzione che il problema è incentrato sulla distribuzione del nuovo certificato
    venerdì 7 agosto 2020 09:44
  • quando hai rinnovato il certificato, quali operazioni hai fatto sui radius server ?

    i radius server contattano regolarmente la CA interna ?


    Edoardo Benussi
    e[dot]benussi[at]outlook[dot]it

    venerdì 7 agosto 2020 17:59
    Moderatore