none
Configuring TS WEB ACCESS to prompt for Computer login credentials when using TS GATEWAY RRS feed

  • Question

  • I've configured a TS Gateway Farm with TS WEB ACCESS.  The way it works now, when you start the Remote Desktop Process it uses the same credentials for the TS Gateway as it does for the "connect to" computer  login.  If you configure the remote application to use TS Gateway you get the option to use the same credentials for the computer login as you do for the TS gateway.  I know that the Desktops.aspx makes a call to MsRdpClient.MsRdpClientShell.RdpFileContents, which variable can I change so that you will be asked for your login on the "Connect to" computer?
    Wednesday, January 21, 2009 7:18 PM

Answers

  • In case you want to know the actual RDP property through which you can configure to use different credentials for TS Gateway and the TS server, then here it is: promptcredentialonce:i:0.

    The property value 0 means prompt for credentials twice, once for TS Gateway and second time for TS.
    The property value 1 means use same credentials for both TS Gateway and TS.

    Hope it helps!!

    Thanks
    Vikash
    Friday, September 4, 2009 3:59 AM
    Moderator

All replies

  • Is your goal to disable sharing credentials between Gateway and TS server (so that user gets asked for credentials twice - once at Gateway and once again at TS)?  If so, you can do that in Remote Desktop client -> options -> advanced -> gateway settings (at the bottom) -> Logon options at the bottom you can uncheck the "share credentials" box.

    Thursday, September 3, 2009 7:08 PM
    Moderator
  • In case you want to know the actual RDP property through which you can configure to use different credentials for TS Gateway and the TS server, then here it is: promptcredentialonce:i:0.

    The property value 0 means prompt for credentials twice, once for TS Gateway and second time for TS.
    The property value 1 means use same credentials for both TS Gateway and TS.

    Hope it helps!!

    Thanks
    Vikash
    Friday, September 4, 2009 3:59 AM
    Moderator