none
'Unknown Error' when activating Office SharePoint Server Publishing Infrastructure

    Question

  • For quite some time I'm trying to activate the 'Office SharePoint Server Publishing Infrastructure' in my

    site collection pool. I can activate all site collection features except this one. It produces an 'Unknown error'.

    Some articles on the net suggest to temporarily change the home directy of the application into the one used by the central administration tool, but that does also not help. In fact, in these articles the error is 'Access denied', but i get a different one: Unknown error.

     

    So I deleted the application pool, and created a new one, but still no luck.

    Then I uninstalled the complete Sharepoint server, deleted all directories left on the server, deleted all databases that were used by sharepoint from my sql 2005 server and reinstalled sharepoint 2007. I created a new application pool, followed very precisely all steps of the suggested administrator tasks, but still the same:

     

    Unknown Error

    Troubleshoot issues with Windows SharePoint Services.

     

    Did I forget some prerequisite tasks, or how can I troubleshoot this problem?

     

    Any help would be appreciated!

    Saturday, June 16, 2007 8:57 AM

All replies

  • I am not sure if this is at all helpful, but have you checked the event log in administrative options on the server.  Most of the time it describes exactly what that unknown error really is.
    Monday, June 18, 2007 3:05 PM
  • Reading the log surely is a good idea!

    Shame on me...

     

    Reading the log I discovered that:

     

    - Sharepoint removed the local hosts file. Because it does not have rights in the etc folder sharepoint  could not write its own one.  I placed a standard hosts file and set permissions on it, and now sharepoint has written its own versions there.

     

    - Not being able to enable the Publishing infrastructure has to do with credential problems with the database.

      Looking on the database server I can see wich users tries to do a proc_putObject (Login failed for user 'testdomain\svc_sharepoint'. [CLIENT: 172.18.0.15]). (database 'SharePoint_Config', schema 'dbo)

     

      Now I'm a bit puzzeled how to solve this. Should the account which is running the application pool always have write access on the configuration database?

     

     

     

    Tuesday, June 19, 2007 9:25 AM
  • I did a little research and the administrative account needs the ability to create databases, which means your admin account needs write access to the SQL Server.
    Thursday, June 21, 2007 9:11 PM
  • Nothing on event viewer.

    Only happens if site collection is created with another language pack other than English. If I create a site collection using English this error does not occur.

    Tuesday, October 2, 2007 11:27 AM
  • If you give that sproc "proc_putObject" explicit execute permissions on the configuration database. That error should go away.
    Thursday, October 9, 2008 9:15 PM
  • Hi Kopke,

    This error may ocurr because you are using an incorrect URL to access SharePoint.

    For example: if you create a Web Application using URL http://server01, and you create a DNS Alias to this name (ej: alias01), when you use the alias in the URL you have the "unknown error" to activate this feature (and you have more errors, for example when searching in this Site Collection). However, when using the same URL used to create Web Application (server01 in this example), you can Search and you can activate features without errors.

    Sorry my english...

    Regards,

    GuilleSQL
    http://www.guillesql.es

    This posting is provided AS IS with no warranties, and confers no rights
    Friday, March 6, 2009 3:42 PM