none
how to configure sharepoint to send email to external users RRS feed

  • Question

  • we have a sharepoint farm and an exchange server. Sharepoint is configured to use the exchange server as the outgoing email server.

    all internal users are AD users and have exchange mailboxes.

    all internal users are able to receive email alerts. 

    All external users were created as a local user and group on the sharepoint server.

    no external users are able to receive email alerts.

    I have tried entering email addresses in the 'Alert me' dialog box, but receive this error: No exact match was found. Click the item(s) that did not reslove for more options

    I have tried entering the local user account and get this error:

    The following user do not have e-mail addresses specified:

    - MYSHAREPOINTSERVERNAME\localusername

    Alerts have been created successfully but these users will not receive notification until valid e-mail or mobile addresses have been provided

    What should I do to be able to have external users receive email alerts?

    The AD adminstrator does not want external users as part of AD. The Exchange administrator does not want external users to have a mailbox.


    davidh
    Tuesday, December 13, 2011 7:02 PM

All replies

  • You would need to update each of the profiles from within SharePoint to include the email address.  You can do that form within the user profile service application.  Once profiles have been updated there, remember to leave time for the sync job to run and update the profiles in your sites.
    Wednesday, December 14, 2011 1:19 AM
  • Thanks Jason, I think you are on to something here.

    I have a synchronization connection to AD and I can view the user profiles that are coming from AD. But I cannot view the local user profiles that were created at the SP server itself (MYSHAREPOINTSERVERNAME\localusername).

    Maybe I can create a synchronization connection to the SP server to suck the local user profiles into sharepoint but I don't know how to do that?

    When creating a new synchronization connection, I am given the following choices for connection type:

    • Active Directory
    • Active Directory Logon Data
    • Active Directory Resource
    • Business Data Connectivity
    • IBM Tivoli Directory Server (ITDS)
    • Novel eDirectory
    • Sun Java System Directory Server


    Can you help me figure out how to do this?

    Thanks again for your help!

     


    davidh
    Wednesday, December 14, 2011 11:26 AM
  •  

    -> The reason why you can't see their profiles in UPS is because in UPS(User Profile Service) the entries are automatically made only when the specific user navigates to profile page.

    -> I don't think you can have a sync connection created for the accounts from local machine. (all the types you have specified are from other directory sources). You have to move the users to AD or create a custom code which creates profiles for those users in sharepoint (which is not a suggested approach)


    Satheesh
    http://spsatheesh.wordpress.com
    Wednesday, December 14, 2011 12:52 PM
  • The local users are only added after their first log in.  Logging in with a local account will add a skeleton profile to the site collection's user information list. 

    The next incremental sync of the user profile service will detect the user from the site collection and sync with it.  After that, it will be available in your user profile service for editing. 

    Once it's edited, there will need to be another sync to populate the changes back to the site collection.  The sync back to site collection is a different timer job.  It's called User Profile to SharePoint Full Syncronization and is configured to run hourly OOTB.

    Alternatively, you can have the user edit their own profile.  The only catch is that the Work Email property isn't available for user edit out of the box so you'd have to change that.  This is also done in the User Profile Service app.

    Wednesday, December 14, 2011 1:09 PM
  • The next incremental sync of the user profile service will detect the user from the site collection and sync with it.  After that, it will be available in your user profile service for editing. 

    Interesting Point... checking this... :)


    Satheesh
    http://spsatheesh.wordpress.com
    Wednesday, December 14, 2011 3:38 PM
  • that seems to be working to add the user email address.. This is what I had to do:

    From Central Administration->Manage Service Applications->User Profile Service Application->Manage User Profiles

    I was still unable to use 'find' to return any of the external users, however, I was able to use New Profile to modify the profile. I entered the username in the 'Account Name' box and clicked 'Check Names' it correctly resolved the username (MYSHAREPOINTSERVERNAME\localusername), I could then add data to the work email field.

    After doing that and after waiting for the synchronization to occur the user was able to logon and use Alert Me to set an alert. The user can also edit his 'My Settings' by clicking on his name in the upper right corner. In his profile settings he can also click 'My Alerts' and see that his alerts are indeed there, he can view the properties of the alert and the properties correctly show his external email address.

    However, unfortunately, the external user is still not receiving Alerts. sigh.

    I feel like I am so close to resolving this but still not there. Any and all help is very much greatly appreciated.


    davidh
    Wednesday, December 14, 2011 7:50 PM
  • It sounds like SharePoint is working fine now.  I wonder if you're having trouble relaying the email through exchange.
    • Marked as answer by Seven M Wednesday, December 21, 2011 6:44 AM
    • Unmarked as answer by DAH69 Wednesday, December 21, 2011 4:59 PM
    Thursday, December 15, 2011 12:05 AM
  • @Jason, Users in User Information List are not getting added to UP after a Full Sync (I believe it is still oneway between UP -> User information List). If the same user tries to browse 'My Profile' then a entry goes into the UPS immediately.



    Satheesh
    http://spsatheesh.wordpress.com
    Thursday, December 15, 2011 8:49 AM
  • good question.

    I am not well versed in Exchamge so just to make sure I understand what needs to take place so I can speak intellegently with our Exchange admin...

    We obviously do not want to open the Exchange box to relay from all sources becuase of potential SPAM threat, but as I understand it our Exchange SMTP server needs to be able to relay SMTP packets from our Sharepoint server only to the external user's mail server. yes, no, maybe?

    Is there anything else I need to ask our Exchange admin to look at?   


    davidh
    Thursday, December 15, 2011 10:55 AM
  • I'm also not very well versed in Exchange but my question to the exchange guys is usually as simple as: "Does this server have access to relay mail, if not, can you allow it?"
    Thursday, December 15, 2011 1:26 PM
  • Sadly, it is still not working. I know sombody marked this as answered but it is not. The Exchange admin tells me that he has opened up the Exchange box to accept relay from the Sharepoint box but external users are still not receiving alerts. If anybody has any other suggestions I would certainly appreciate the help.

    Thanks,


    davidh
    Wednesday, December 21, 2011 4:59 PM
  • Hi, I had the same issue on an SBS box which is a lot more awkward as normally you wouldn't have sharepoint and exchange on the same box. I'm posting here although this is very old just in case some other poor fool spends an entire day messing around like I did. These instructions are explicitly for a SBS 2011 standard installation but should work with other scenarios (obvioulsy replace any connector names with your own)

    Open as administrator exchange management shell and run:
     
    Get-ReceiveConnector "Windows SBS Fax Sharepoint Receive SERVER" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"

    This will allow relay to external recipients from sharepoint (The default server address in sharepoint foundation on an SBS box outgoing email server resolves through a local DNS entry to 127.0.0.1 - The SBS Fax Sharepoint Receive connector only runs on 127.0.0.1 - kinda makes sense)

    Running:

    Get-ReceiveConnector “Windows SBS Internet Receive SERVER” | Remove-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “ms-Exch-SMTP-Accept-Any-Recipient”

    will stop open relays from the internet. I found that when checking for open relays that the SBS Internet Receive connector will accept any recipient. Of course this can be restricted by IP on your connector, but I'd rather not have it look like an open relay and get every man and his dog having a go at it.

    Hope this helps somebody


    Friday, September 21, 2012 6:23 PM