none
Maximum Upload Size - Setting not taking affect

    Question

  • I have set the "Maximum Upload Size" to 100 from the default 50 in the "Web Applicaiton General Settings" screen but I am still not able to upload any file bigger than 50MB?

    If I use the "Open with Windows Explorer" the file uploads and when done shows a size of "0". When using the upload option I get this error "The form submission cannot be processed because it exceeded the maximum length allowed by the Web administrator. Please resubmit the form with less data."

    WSS 3.0

     

    Stunpals - Disclaimer: This posting is provided "AS IS" with no warranties.
    • Edited by Stunpals Thursday, February 11, 2010 5:20 PM added SP Version
    • Moved by Mike Walsh FIN Thursday, February 11, 2010 5:37 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, February 11, 2010 5:19 PM

Answers

All replies

  • Did you also increase the IIS connection timeout setting?
    Thursday, February 11, 2010 5:41 PM
  • You may have to edit the web.config. It seems like changing the value in CA doesn't always take.

    Look for:
    <httpRuntime maxRequestLength="51200" />

    The 51200 is 50MB. Change the value to up the size.

    (Might want to try this in a test environment first ;))

    Thursday, February 11, 2010 5:51 PM
  • DOCMAN - I adjust this on the SharePoint - 80 site, I am assuming this is the right one.

    scogordo - I read this on another site but I am not sure where to find this file, I did a search and there are several on the server. Is this the correct path? "C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\LAYOUTS\"


    When I look in this file there are 3 entries for "httpRuntime maxRequestLength="

          <httpRuntime maxRequestLength="2097151" />
        </system.web>
      </location>
      <location path="ctdmsettings.aspx">
        <system.web>
          <httpRuntime maxRequestLength="2097151" />
        </system.web>
      </location>
      <location path="ChangeContentTypeOptionalSettings.aspx">
        <system.web>
          <httpRuntime maxRequestLength="2097151" executionTimeout="999999" />
        </system.web>

    Stunpals - Disclaimer: This posting is provided "AS IS" with no warranties.
    Thursday, February 11, 2010 6:22 PM
  • Hi Stunpals,

     

    The path is correct. You need to find the node:

    <Location path =”upload.aspx”> and change the executionTimeout parameter there. Please follow the article below:

    SharePoint File Upload Size Limit

    http://www.getsharepoint.com/blogs/bw/Lists/Posts/Post.aspx?ID=16

     

    Hope this helps.

     

    Lu Zou

    • Marked as answer by Stunpals Wednesday, February 17, 2010 3:56 PM
    Monday, February 15, 2010 5:46 AM