locked
Folder permission in sharepoint foundation 2010 RRS feed

  • Question

  • I am running sharepoint foundation 2010, I have a new document library, and would like to add folders to this library.  I would like to set permissions on each folder within the library but cant seem to do it. 

     

    Is it possible to add permissions on folder within a doc library?  if so how?

    • Moved by Mike Walsh FIN Monday, January 24, 2011 5:25 PM SP 2010 questions go only to SP 2010 forums (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    Monday, January 24, 2011 4:25 PM

Answers

  • Yes, you can do permission operations for Folder. That was callled a Item - Level Permissions.

    There are two ways to open the manage permissions Page for the Folder.

    1. The Manage Permissions option from the context menu of the folder.

    2.After selecting the document, there was a Document Permission utton under Manage Group in Ribbon.

    After Selecting the Manage Permissions / Document Permissions, the page will redirect to Permissions Page.

    There you have to stop the inherting permissions and add / replace the permissions as per your wish.


    Regards,
    Shantha Kumar .T | MCPD - SharePoint Developer 2010 | MCITP - SharePoint Administrator 2010 |
    (B) Shantha Kumar's Blog | (T)Follow me | (C) IOTAP
    Monday, January 24, 2011 6:30 PM

All replies

  • Hi,

    It is called item level permission and you can configure this permission by following steps on

    http://www.sharepointusecases.com/index.php/2010/03/configure-item-level-permissions-for-document-libraries-part-2/

    Hope this helps


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Monday, January 24, 2011 4:42 PM
  • Yes, you can do permission operations for Folder. That was callled a Item - Level Permissions.

    There are two ways to open the manage permissions Page for the Folder.

    1. The Manage Permissions option from the context menu of the folder.

    2.After selecting the document, there was a Document Permission utton under Manage Group in Ribbon.

    After Selecting the Manage Permissions / Document Permissions, the page will redirect to Permissions Page.

    There you have to stop the inherting permissions and add / replace the permissions as per your wish.


    Regards,
    Shantha Kumar .T | MCPD - SharePoint Developer 2010 | MCITP - SharePoint Administrator 2010 |
    (B) Shantha Kumar's Blog | (T)Follow me | (C) IOTAP
    Monday, January 24, 2011 6:30 PM
  • Thanks for the quick responses.  I had it fixed for a while, but it seems to have come back.  Originally I deleted the doc library then recreated it, I then could highlight a folder and get a menu to set permissions.  It seems that option has gone away, and Im not sure why.  When I hover the mouse over the folder the row does not highlight.  if I click the folder it opens it, not allowing me to set permissions.

     

    Thanks for the help.

    Tuesday, January 25, 2011 6:39 PM
  • The second option: when you select a particular folder, there will be option "Document Permission"on the Ribbon bar. Click on that and then stop inheriting the permission. Now you can define your specific permission for that folder. Hope it makes you more clear.
    Thursday, May 31, 2012 6:48 AM