none
content database is in single user mode

    Question

  • Hi all

    When I create a new application using the sharepoint central administration v3.0 this end with an unspecified error.
    When i use sql server 2005 manager studio i can see the databasename is created but the content database is in single user mode.

    I can create new web sites using the STSadm tool without any problem.
    so what can be wrong ????

    please help
    thx
    Koen
    Saturday, October 18, 2008 6:15 PM

Answers

  • Hi Koen,

    i have seen cases where the Content Database stays in a Single-User mode after a backup and it could been something wrong with the permissions as Gary pointed out.

    I could also be a Maintainance Plan that leeves the DB in single-user mode:

    FIX: Database Remains in Single User Mode with the Database Maintenance Plan Option "Repair Any Minor Problems":
    http://support.microsoft.com/kb/259551

    I would change the setting manually in SQL Studio Manager.

    Hope this helps!

    Cheers,


    Daniel Bugday™ Web: © SharePoint Forum Blog: Daniel Bugday's Blog
    Sunday, October 19, 2008 10:05 AM

All replies

  • Just a stab here but you might want to check the permissions of the app pool account that central admin and your timer service is running as - make sure it has db_creator and security_admin roles on the sql server.
    Sunday, October 19, 2008 12:15 AM
  • Hi Koen,

    i have seen cases where the Content Database stays in a Single-User mode after a backup and it could been something wrong with the permissions as Gary pointed out.

    I could also be a Maintainance Plan that leeves the DB in single-user mode:

    FIX: Database Remains in Single User Mode with the Database Maintenance Plan Option "Repair Any Minor Problems":
    http://support.microsoft.com/kb/259551

    I would change the setting manually in SQL Studio Manager.

    Hope this helps!

    Cheers,


    Daniel Bugday™ Web: © SharePoint Forum Blog: Daniel Bugday's Blog
    Sunday, October 19, 2008 10:05 AM