none
Event ID 3759 error when adding new server to SPS 2010 server farm

    Question

  • Hi,

    I am creating SPS 2010 server farm. I installed SPS 2010 on WFE server. The installation went through successfully.  Both portal site and central admin site show up correctly. Without changing anything I try to install the SPS 2010 on APP server.

    The installation on APP server went through without error. After trying to join the existing SPS 2010 server farm, I got the following error message in ULS,

    Database 'SP_ConfigDB' on SQL Server instance 'SPS2010' is not empty and does not match current database schema.

     Also the same error showed on event log as Event ID: 3759

    I am using farm service account to deploy SPS 2010 on APP server, and the account has the following permission,

    1.       In local administrator group

    2.       Sysadmin and dbcreator permission of SQL server

     

    I can't find a solution, any ideas?

    Thanks in advance.

     

    Thursday, June 30, 2011 7:35 PM

Answers

  • Can you check if your SQL server has both TCP and Named pipes enabled?

    Database server-->SQL Server Configuration Manager-->SQL Server Network Configuration - Protocols for YourNamedInstance-->Double click on Named Pipes and enable them


    Regards

    Henrik A. Halmstrand http://www.sharepointrevealed.com
    • Marked as answer by Seven M Friday, July 8, 2011 1:55 AM
    Friday, July 1, 2011 7:51 AM

All replies

  • Hi,

    Strange one, have you installed any patch, hotfix or language pack? Which account did you use to install the binaries? Can you application server connect successfully to SQL? Who is the DB owner of your Config_DB? 


    Regards

    Henrik A. Halmstrand http://www.sharepointrevealed.com
    Thursday, June 30, 2011 8:40 PM
  • Hi Henrik,

    I am using SharePoint Farm account to install SPS 2010 on APP server. The account has local admin rights and sysadmin & dbcreator sql permission. It find ConfigDB but for some reason could not connect to ConfigDB. It is db owner of ConfigDB. The error message is

    Database 'SP_ConfigDB' on SQL Server instance 'SPS2010' is not empty and does not match current database schema.

    The binaries installed successfully, but the APP server failed to connect to SPS 2010 server farm.   

    OK, I have new update now, I created a database alias, since SharePoint uses named SQL instance. I opened SQL Management Studio, I can connect database engine through named instance (sqlservername\instancename) successfully, but I could not open database engine through database alias. The error message says,

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections.

    Any idea?

    Thanks in advance,  

     


    Friday, July 1, 2011 2:17 AM
  • Can you check if your SQL server has both TCP and Named pipes enabled?

    Database server-->SQL Server Configuration Manager-->SQL Server Network Configuration - Protocols for YourNamedInstance-->Double click on Named Pipes and enable them


    Regards

    Henrik A. Halmstrand http://www.sharepointrevealed.com
    • Marked as answer by Seven M Friday, July 8, 2011 1:55 AM
    Friday, July 1, 2011 7:51 AM
  • Hi Peter

    Make sure that the Farm  account is added to the Security  Admin role in SQL.

    Regards

    Friday, October 30, 2015 12:44 PM