none
Issues with Time Services in Server 2008 RRS feed

  • Question

  • I am having a hard time getting my PDC to sync with an external time source.  It will only refrence it's internal CMOS clock.  I have verified that I port 123 is opne.  I have run "w32tm /stripchart /computer:nist1-lnk.binary.net /samples:5 /dataonly" to verify connectivity.  I have run the w32tm command "w32tm /config /manualpeerlist:nist1-lnk.binary.net /syncfromflags:manual /reliable:yes /update"  The command executes.  However, when I run "w32tm /resync" I am told that, "no time data is available".  Then when I run "w32tm /query /status" I see that the CMOS clock is the source.  To do a little more testing I ran w32tm /query /peers /verbose and got the following output:

    Peer:
    State: Pending
    Time Remaining: 770.3625852s
    Mode: 0 (reserved)
    Stratum: 0 (unspecified)
    PeerPoll Interval: 0 (unspecified)
    HostPoll Interval: 0 (unspecified)
    Last Successful Sync Time: (null)
    LastSyncError: 0x800706E1 (The entry is not found. )
    LastSyncErrorMsgId: 0x0000005C (The peer is unreachable. )
    AuthTypeMsgId: 0x0000005A (NoAuth )
    Resolve Attempts: 1
    ValidDataCounter: 0
    Reachability: 0

    I have also rebooted and stopped and started w32time muliple times.  Any Help would be greatly appreciated.

    Wednesday, February 15, 2012 4:52 PM

Answers

  • Please, run "w32tm /resync /rediscover" command and post all info from "w32tm /query" commands

    • Marked as answer by Dan Patterson Wednesday, February 15, 2012 6:53 PM
    Wednesday, February 15, 2012 5:14 PM
  • After Running this command I realized that a GPO was conflicting with my server settings.  I made sure that GPO wasn't applied to my DC.  Problem Solved!

    Dan Patterson

    Wednesday, February 15, 2012 6:53 PM

All replies

  • read this article

    http://support.microsoft.com/kb/816042/en

    registry parameter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\AnnounceFlags must be "5".
    Wednesday, February 15, 2012 4:55 PM
  • I did as suggested and after doing w32tm /resync and w32tm /query /status I got the same results.

    Dan Patterson

    Wednesday, February 15, 2012 5:04 PM
  • Please, run "w32tm /resync /rediscover" command and post all info from "w32tm /query" commands

    • Marked as answer by Dan Patterson Wednesday, February 15, 2012 6:53 PM
    Wednesday, February 15, 2012 5:14 PM
  • C:\Users\administrator.OHB>w32tm /resync /rediscover
    Sending resync command to local computer
    The computer did not resync because no time data was available.

    C:\Users\administrator.OHB>w32tm /query /status
    Leap Indicator: 0(no warning)
    Stratum: 1 (primary reference - syncd by radio clock)
    Precision: -6 (15.625ms per tick)
    Root Delay: 0.0000000s
    Root Dispersion: 10.0000000s
    ReferenceId: 0x4C4F434C (source name:  "LOCL")
    Last Successful Sync Time: 2/15/2012 11:19:35 AM
    Source: Local CMOS Clock
    Poll Interval: 6 (64s)


    Dan Patterson

    Wednesday, February 15, 2012 5:21 PM
  • What about "w32tm /query /configuration"?
    Wednesday, February 15, 2012 5:25 PM
  • Hello,

    you may reset the time service to default and start fresh. All required commands are in http://msmvps.com/blogs/mweber/archive/2010/06/27/time-configuration-in-a-windows-domain.aspx


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Wednesday, February 15, 2012 5:25 PM
  • I did as suggested and the resetup according to this article http://support.microsoft.com/kb/816042/en.  The behavior hasn't changed.

    Dan Patterson

    Wednesday, February 15, 2012 5:34 PM
  • Here is the /query /configuration as requested.

    C:\Users\administrator.OHB>w32tm /query /configuration
    [Configuration]

    EventLogFlags: 2 (Policy)
    AnnounceFlags: 10 (Policy)
    TimeJumpAuditOffset: 28800 (Local)
    MinPollInterval: 6 (Policy)
    MaxPollInterval: 10 (Policy)
    MaxNegPhaseCorrection: 172800 (Policy)
    MaxPosPhaseCorrection: 172800 (Policy)
    MaxAllowedPhaseOffset: 300 (Policy)

    FrequencyCorrectRate: 4 (Policy)
    PollAdjustFactor: 5 (Policy)
    LargePhaseOffset: 50000000 (Policy)
    SpikeWatchPeriod: 900 (Policy)
    LocalClockDispersion: 10 (Policy)
    HoldPeriod: 5 (Policy)
    PhaseCorrectRate: 1 (Policy)
    UpdateInterval: 100 (Policy)


    [TimeProviders]

    NtpClient (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)
    CrossSiteSyncFlags: 2 (Policy)
    AllowNonstandardModeCombinations: 1 (Local)
    ResolvePeerBackoffMinutes: 15 (Policy)
    ResolvePeerBackoffMaxTimes: 7 (Policy)
    CompatibilityFlags: 2147483648 (Local)
    EventLogFlags: 0 (Policy)
    LargeSampleSkew: 3 (Local)
    SpecialPollInterval: 3600 (Policy)
    Type: NT5DS (Policy)

    NtpServer (Local)
    DllName: C:\Windows\system32\w32time.DLL (Local)
    Enabled: 1 (Local)
    InputProvider: 0 (Local)
    AllowNonstandardModeCombinations: 1 (Local)

    VMICTimeProvider (Local)
    DllName: C:\Windows\System32\vmictimeprovider.dll (Local)
    Enabled: 1 (Local)
    InputProvider: 1 (Local)


    C:\Users\administrator.OHB>


    Dan Patterson

    Wednesday, February 15, 2012 5:57 PM
  • After Running this command I realized that a GPO was conflicting with my server settings.  I made sure that GPO wasn't applied to my DC.  Problem Solved!

    Dan Patterson

    Wednesday, February 15, 2012 6:53 PM
  • In Windows 2008 server it was showing

    Next synchrinization:1/4/2012 at 9:17 AM

    The Clock was successfully synchronized with time-b.nist.gov on 12/14/2012 at 9:17 AM.

    The server was having a 10 Minutes differance with the local time at this time and even after
    it was sync again on 1/4/2013 the time was having the same differance.So manully changed the
    time and corrected.
    so what will be the reason for this ? can any one help me?

    Monday, January 7, 2013 4:04 PM
  • If the time difference is great (not sure what the max. difference is but it is adjustable), it will not update the time.  Thus, when you updated manually, it worked from that point on because the difference was smaller than the max. difference).

    Wednesday, February 27, 2013 9:52 PM