none
SP2 Install 100% complete, then fails with ERROR_ALREADY_EXISTS RRS feed

  • Question

  • Removed the beta (successfully) using control panel app, and then tried to install the RC of SP2.

    Vista Ultimate x64 completes the install of SP2, then after reboot and Stage 3 shows 100% complete, it says "Install of SP2 failed; ERROR_ALREADY_EXISTS" and reverts the install.

    I have tried all forms of uninstall given on MSDN/Technet, and then the restore point (which, helpfully, said "Cannot restore from this restore point.").

    OS Name Microsoft® Windows Vista™ Ultimate
    Version 6.0.6001 Service Pack 1 Build 6001
    Other OS Description  Not Available
    OS Manufacturer Microsoft Corporation
    System Name HMFA-DEV2
    System Manufacturer INTEL_
    System Model DX58SO__
    System Type x64-based PC
    Processor Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz, 2661 Mhz, 4 Core(s), 8 Logical Processor(s)
    BIOS Version/Date Intel Corp. SOX5810J.86A.3504.2009.0218.0058, 2/18/2009
    SMBIOS Version 2.5
    Windows Directory C:\Windows
    System Directory C:\Windows\system32
    Boot Device \Device\HarddiskVolume1
    Locale United States
    Hardware Abstraction Layer Version = "6.0.6001.18000"
    Time Zone Pacific Daylight Time
    Installed Physical Memory (RAM) 6.00 GB
    Total Physical Memory 1.99 GB
    Available Physical Memory 3.67 GB
    Total Virtual Memory 12.1 GB
    Available Virtual Memory 9.61 GB
    Page File Space 6.28 GB
    Page File C:\pagefile.sys


    =================================
    Checking System Update Readiness.
    Version 6.0.6001.22275
    2009-03-19 15:13

    Checking Deployment Packages

    Checking Package Manifests and catalogs.

    Checking package watchlist.

    Checking component watchlist.

    Checking packages.

    Checking component store

    Checking SMI Store
    Summary:
    Milliseconds: 1079895
     No errors detected




     

    Thursday, March 19, 2009 9:33 PM

Answers

  • This problem is unusual, but not unheard-of: There is a driver (somewhere; unfortunately, we don't know which one) that renames TMM to TMM_DUP in %windir%\System32\Tasks\Microsoft\Windows\MobilePC. Renaming it back to TMM solves this problem. See FEEDBACK ID 426141.
    • Marked as answer by theBeez Friday, March 27, 2009 6:19 PM
    Friday, March 27, 2009 6:19 PM

All replies