none
email not working : The following users do not have e-mail addresses specified

    Question

  • Hi,

    I have configure email settings in sharepoint 2010. i have not done configuration for profile import from AD. i have added the AD users in sharepoint.

    But when i try to configure alerts, i get the follwoing error:

    "The following users do not have e-mail addresses specified:
        -<name>
    Alerts have been created successfully but these users will not receive notifications until valid e-mail or mobile addresses have been provided. "

    Please help.

    Thursday, August 02, 2012 7:16 AM

Answers

  • first, make sure that Email address is set for user in AD;

    then, run this command: Get-SPUser –Web http://yoursite | Set-SPUser –SyncFromAD

    Note that AD user property is synchronized to SharePoint site collection user information list only the first time user is added. You have to synchronize manually later.

    Friday, August 03, 2012 3:07 AM
    Moderator

All replies

  • You will need to configure User Profile Sync from AD or use Central Admin to populate the user's email addresses.

    teh*remo

    Thursday, August 02, 2012 7:57 PM
  • first, make sure that Email address is set for user in AD;

    then, run this command: Get-SPUser –Web http://yoursite | Set-SPUser –SyncFromAD

    Note that AD user property is synchronized to SharePoint site collection user information list only the first time user is added. You have to synchronize manually later.

    Friday, August 03, 2012 3:07 AM
    Moderator
  • GuYuming's answer : Get-SPUser –Web http://yoursite | Set-SPUser –SyncFromAD

    Solved my SharePoint 2013 "The following users do not have e-mail addresses specified" issue too when trying to send/set alert from the Site. Thanks! 



    Thank you. Regards, Kâpeng

    Wednesday, June 05, 2013 1:14 PM