none
Install SQL Server 2012 SP1 on a Windows Server 2012 R2 Failover Cluster - hangs at "Running discovery on remote machine" on VMWare VSphere 5.5 Update 1 RRS feed

  • Question

  • <p>Hi,</p><p>I'm trying to install SQL Server 2012 SP1 on the first node of a Windows Server 2012 R2 failover cluster.</p><p>The install hangs whilst displaying the "Please wait while Microsoft SQL Server 2012 Servce Pack 1 Setup processes the current operation." message.</p><p>The detail.txt log file shows as follows:</p><p>(01) 2014-07-17 15:36:35 Slp: -- PidInfoProvider : Use cached PID<br />(01) 2014-07-17 15:36:35 Slp: -- PidInfoProvider : NormalizePid is normalizing input pid<br />(01) 2014-07-17 15:36:35 Slp: -- PidInfoProvider : NormalizePid found a pid containing dashes, assuming pid is normalized, output pid<br />(01) 2014-07-17 15:36:35 Slp: -- PidInfoProvider : Use cached PID<br />(01) 2014-07-17 15:36:35 Slp: Completed Action: FinalCalculateSettings, returned True<br />(01) 2014-07-17 15:36:35 Slp: Completed Action: ExecuteBootstrapAfterExtensionsLoaded, returned True<br />(01) 2014-07-17 15:36:35 Slp: ----------------------------------------------------------------------<br />(01) 2014-07-17 15:36:35 Slp: Running Action: RunRemoteDiscoveryAction<br />(01) 2014-07-17 15:36:36 Slp: Running discovery on local machine<br />(01) 2014-07-17 15:36:36 Slp: Discovery on local machine is complete<br />(01) 2014-07-17 15:36:36 Slp: Running discovery on remote machine: XXX-XXX-01</p><p>After about 4 hours and 10 minutes, the step seems to time out and move on, however it doesn't seem to have discovered what it needs to and the setup subsuently fails</p><p></p>
    Thursday, July 17, 2014 3:03 PM

Answers

  • Hi,

    Sorry Information you provided did not helped can you post content of both summary file and details,txt file on shared location for analysis.

    Can you download Service pack again and try once more


    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it.

    My TechNet Wiki Articles

    • Proposed as answer by Jin Chen Monday, July 21, 2014 7:30 AM
    • Unproposed as answer by Jin Chen Monday, July 21, 2014 7:31 AM
    • Proposed as answer by Sofiya LiModerator Monday, July 21, 2014 7:33 AM
    • Marked as answer by Steven Hodson Tuesday, March 24, 2015 10:04 PM
    Thursday, July 17, 2014 5:46 PM
    Moderator

All replies

  • Hi,

    Sorry Information you provided did not helped can you post content of both summary file and details,txt file on shared location for analysis.

    Can you download Service pack again and try once more


    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it.

    My TechNet Wiki Articles

    • Proposed as answer by Jin Chen Monday, July 21, 2014 7:30 AM
    • Unproposed as answer by Jin Chen Monday, July 21, 2014 7:31 AM
    • Proposed as answer by Sofiya LiModerator Monday, July 21, 2014 7:33 AM
    • Marked as answer by Steven Hodson Tuesday, March 24, 2015 10:04 PM
    Thursday, July 17, 2014 5:46 PM
    Moderator
  • As per the setup logs, the installation is trying to run the discovery report from the remote machine and its waiting. 

    To fix this, Enable Admin Shares (i.e. \\NODE1\C$ should be accessible from NODE2) and vice versa and retry the setup. 


    Regards, Don Rohan [MSFT]

    Friday, January 12, 2018 7:28 AM
  • Do we not have a way to SKIP ACTION ?

    I was able to skip the rule 

    Setup /SkipRules=Cluster_IsOnlineIfClustered /action="patch"

    but setup still hangs on  "RunRemoteDiscoveryAction"

    Its not safe to enable ADMIN SHAREs on remote Data center hosting Disaster Recovery NODE for AG

    atlest by skipping the discovery process will save the install time.

    Wednesday, November 13, 2019 7:01 PM