locked
Internet connection sharing / Routing and remote access (ICS/RRAS) RRS feed

  • Question

  • Hello,

    I am using W2008R2 connected to internet. My internal network is connected by cable to the second network adapter.
    I was using ICS (internet connection sharing) to connect my internal network to the internet and everything worked well. But I read in some forums that ICS is bad and it is better to use RRAS. So I setted up RRAS, configured NAT to connect my internal network to the internet (it is working). 

    BUT,  i found several problems:

    1) When I want to connect from outside to my W2008 it is not working when RRAS enabled.
    2) Also when I want to receive multicast (watching TV) on W2008, it is not working when RRAS enabled.

    So I decided return back to ICS, but i've got following error

    3) ICS cannot be enabled because routing and remote access has been enabled on this computer. to enable ics, first disable routing and remote access. - even if RRAS service is completely disabled

    So my questions are:
    Q1) Can you help me to make ICS working OR
    Q2) Can you help me configure RRAS to avoid problems described in 1) and 2) ?

    I am not network specialist and I am unable to configure RRAS on my own.

    Thank you very much for an answers

    Thursday, August 11, 2011 4:35 PM

Answers

  • Hi Jullo,

     

    Thanks for update.

     

    Not sure how did you completely disabled the RRAS, but we should remove “Network Policy and Access Service” role with following the proper way first and re enable ICS on that host:

     

    Removing Server Roles and Features

    http://technet.microsoft.com/en-us/library/cc732257.aspx

     

    Meanwhile, you can also try to delete NAT protocol form RRAS if you still install it by right click “NAT” and delete under “IPv4” in RRAS console and see if will get any luck.

     

    Thanks.


    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 16, 2011 7:21 AM
  • Hello,

    by complete disabling I meant - disabling RRAS service and removing role.

    Anyway I'm gonna pray to you, because I haven't assumed, that removing items in RRAS console (before removing role) can help. And, viola, it works.

    Under NAT I deleted all interfaces configuration and after that step, I removed RRAS role. This helped. I thank you a lot. I owe you beer in Prague;)

    Julo 

    Tuesday, August 16, 2011 5:09 PM

All replies

  •   I agree that I would never use ICS on a server. But if you are watching TV on it you are not really using it as a server!

      RRAS is a bit more complex than ICS. http://technet.microsoft.com/en-us/library/dd469854(WS.10).aspx

       You cannot run them both at the same time because they do basically the same thing and share some components.

     


    Bill
    Thursday, August 11, 2011 11:19 PM
  • Ok, so do you know how to get ICS working?
    Friday, August 12, 2011 8:12 PM
  • Hi,

     

    Thanks for posting here.

     

    Try verifying and stopping “Routing and Remote Access” service form service MMC snap in and re enable ICS to see how is going.

     

    Thanks.


    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 15, 2011 8:07 AM
  • Hi,

    Even if I stop RRAS and disable RRAS service, after attempt to start ICS I get error

    "Internet Connection Sharing (ICS) cannot be enabled because Routing and Remote Access has been enabled on this computer. To enable ICS, first disable Routing and Remote Access."

     J.

    Monday, August 15, 2011 3:09 PM
  • Hi Jullo,

     

    Thanks for update.

     

    Not sure how did you completely disabled the RRAS, but we should remove “Network Policy and Access Service” role with following the proper way first and re enable ICS on that host:

     

    Removing Server Roles and Features

    http://technet.microsoft.com/en-us/library/cc732257.aspx

     

    Meanwhile, you can also try to delete NAT protocol form RRAS if you still install it by right click “NAT” and delete under “IPv4” in RRAS console and see if will get any luck.

     

    Thanks.


    Tiger Li


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 16, 2011 7:21 AM
  • Hello,

    by complete disabling I meant - disabling RRAS service and removing role.

    Anyway I'm gonna pray to you, because I haven't assumed, that removing items in RRAS console (before removing role) can help. And, viola, it works.

    Under NAT I deleted all interfaces configuration and after that step, I removed RRAS role. This helped. I thank you a lot. I owe you beer in Prague;)

    Julo 

    Tuesday, August 16, 2011 5:09 PM