none
Hyper-V error: Assign a virtual desktop to a user RRS feed

  • Question

  • Hi,

    We have a Windows Server 2016 Hyper-V Virtual Desktop environment since two years and now also a new Windows Server 2019 Hyper-V Virtual Desktop environment. The 2016 servers are not clustered, but the new 2019 collection is a three node cluster. Both VDI environments are separate.

    They have a lot of Windows 10 Virtual machines running on it. The collections are personal unmanaged collections.

    When I try to assign a user to a desktop collection on the 2019 servers it gives the error: The specified user account does not have the appropriate permissions to user this collection.

    But the user is a member of the correct group. Even if we change the group name to "domain users" it doesn't work.

    What could be the issue?

    Thanks,

    Tuesday, October 8, 2019 7:29 AM

All replies

  • HI
    1“Both VDI environments are separate.”
    Are w2016 RDVH and w2019 RDVH in the same AD domain and the user account in the same DC server?
     "The specified user account does not have the appropriate permissions to user this collection."
    2 if you create a new AD domain account(testa) and try to assign this new user a desktop collection on the 2019 servers ,will the problem persist ?
    3 what's VDI license do you use on both your w2016 vdi environment and w2019 vdi environment ?
       do you use windows 10 SA or VDA license per user/per device as VDI license ?
      

    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, October 9, 2019 7:00 AM
    Moderator
  • HI
    Is there any progress on your question?

    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, October 13, 2019 7:43 AM
    Moderator
  • Hi,

    1. The servers and user accounts are in the same domain.

    2. I created a new user TestA and had the same issue.

    3. The licensing mode is per user. The license server is a 2019 server and has user licenses for 2016 and 2019 on it.

    Thanks,

    Monday, October 14, 2019 6:51 AM
  • HI 
    4 what's your setting like picture on RDCB server ?


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 15, 2019 2:20 PM
    Moderator
  • Hi,

    This is not configured on both environments, because these are personal unmanaged computers.

    There are installed with PXE boot and SCCM.

    Thanks


    Friday, October 18, 2019 6:26 AM
  • HI
    5 did you mean there is no RDCB in your environment ?
    6 do you mean you use SCCM to deploy vm client to RD virtulization host ?
    7 did you assign domain user to w2016 vdi environment ?


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, October 22, 2019 3:26 PM
    Moderator