none
Can't Copy and Paste into a sharepoint 2010 Site RRS feed

  • Question

  • I have several users who can not copy and paste into a SharePoint 2010 site.  Yet they can copy and paste into other web sites without a problem. The site is added to the trusted site zone.

    This seems to affect only users who have a XP SP3 system, Office 2007, IE7.

    Any help would be very appreciated.

    Chilly


    pfcjt@hotmail.com

    • Changed type Chilly Moon Monday, September 17, 2012 2:36 PM Correct Anser needs to be selected
    Wednesday, August 22, 2012 1:58 PM

Answers

  • Ok.  I figured out the problem.  Seems to only affect those users who are on XP SP3 operating sytsem with IE7.

    There is not any Java preventing copy and paste, as this works with those users who have windows 7, IE8.

    Ok to Fix copy and paste I had to make sure the following settings were completed.

    IE 7 Settings to correct "Can't Copy and Paste in SharePoint" follow these steps:

      • Select the Tools | Internet Option… menu item
      • Click the Security Tab.  Select Trusted Sites Check
      • Click the Sites Button
      • Make sure your site is in the Trusted Zone.  If not add it. If so move on to next step

    Once out of the Sites area you are now back in the Security tab.

    1. Click the Custom Level button at the bottom.
    2. Scroll to Settings list and Mark the following settings:

    Downloads:

    • Enable the “File Download” radio button

    Miscellaneous:

    • Enable the “Don’t Prompt for Client Certificate Selection when no Certificates or only one certificate exists” radio button.
    • Enable the “Drag and drop or copy and paste files” radio button
    • Enable the “Launching Programs and Files in an IFRAME” radio button

    Scripting:

    • Enable the “Allow Programmatic Clipboard Access”
      1. Click the OK button to accept the changes in the Security Settings dialog window.
      2. Click Yes to accept the security settings.


    pfcjt@hotmail.com

    • Marked as answer by Chilly Moon Monday, September 17, 2012 2:37 PM
    Monday, September 17, 2012 2:34 PM

All replies

  • Are the sites that work without a problem also in the Trusted Sites zone?

    Jason Warren
    Infrastructure Specialist

    Wednesday, August 22, 2012 3:16 PM
  • For the sites that cut and paste work on machines that are XP SP3 with office 2007 and IE7, they are not sharepoint  2010 sites, they are google, wikis and various other websites in our intranet .  Our network in an intratnet all sites on the network is by group policy added to the intranet.  For these sites that are not sharepoint 2010 sites, they are not not added to the trusted sites zone. 

    Removing a sharepoint 2010 from the trusted sites zone does not enable the cut and paste.  Putting the  sharepoint 2010 sites in the trusted sites zone still does not enable cut and paste. 

    Cut and paste seemed to have stopped working about a month ago.

    Do you think and update could affect copy and paste on sharepoint 2010 sites alone only on machines with  XP SP3 with office 2007 and IE7? 


    pfcjt@hotmail.com

    Thursday, August 23, 2012 1:33 AM
  • Sorry, what are you trying to copy and paste?

    Jason Warren
    Infrastructure Architect

    Thursday, August 23, 2012 2:38 AM
  • Anything text related in our Sharepoint site. 

    pfcjt@hotmail.com

    Thursday, August 23, 2012 10:38 AM
  • Hi Chilly Moon,

    To open the document library in the explorer view the service called webclient must be running on the client machine.

    http://support.microsoft.com/kb/841215

    Could you try it as following:

    In task manager, go to view-> select colums, select PID.

    At the command prompt type tasklist /svc /fi "imagename eq svchost.exe" and press the enter key.

    this will show svchost , service running against it and the PID. Check the PID for the SVCHOST running against webclinet

    in the task manager find the SVChost for the PID and kill it.

    More information, please check the below link:

    http://www.bleepingcomputer.com/tutorials/list-services-running-under-svchostexe-process/

    Friday, September 7, 2012 9:22 AM
  • Ehtan_Chan 

    I am a bit confused,

      Is open in explorer view directly related to Copy and Paste on SharePoint sites? 

    also if webdav is suppose to run, why are we killing its related svchost?

    Thanks,

    Chilly


    pfcjt@hotmail.com

    Friday, September 7, 2012 3:14 PM
  • Hi Chilly,

    For security purposes, Windows Vista and Windows XP SP2 disable Basic authentication in the Web Distributed Authoring and Versioning (WebDAV) Redirector. Both Explorer View in Windows SharePoint Services and the Windows shell commands that are associated with Windows SharePoint Services use WebDAV redirector technology.

    WebDAV is an extension of the HTTP protocol. WebDAV includes Basic Authentication. 

    The DAV redirector in Windows XP Service Pack 1 and earlier versions of Windows does not support encrypted HTTP protocols if the server is configured to use Basic Authentication. To help keep computers and networks secure, Windows Vista and Windows XP SP2 include functionality that lets you control the use of Basic Authentication by the DAV redirector.

    In Windows Vista and later versions of Windows, the DAV redirector supports encrypted HTTP protocols. This includes the SSL protocol. By default, Basic Authentication is disabled unless SSL is enabled. 

    Otherwise, you can fix it as followings:

    To enable Basic authentication on the client computer, follow these steps:(Windows XP)
    1. Click Start, and then click Run.
    2. In the Open box, type regedit, and then click OK.
    3. Locate and then click the following registry subkey:
      <samp>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters</samp>
    4. On the Edit menu, point to New, and then click DWORD Value.
    5. Type UseBasicAuth, and then press Enter.
    6. On the Edit menu, click Modify.
    7. In the Value data box, type 1, and then click OK.
    8. Exit Registry Editor, and then restart the computer.
    To enable Basic authentication on the client computer, follow these steps:(Windows Vista)
    1. Click Start 
       Start button
      , type regedit in the Start Search box, and then click regedit.exe in the Programs list.
    2. Locate and then click the following registry subkey:
      <samp>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters</samp>
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type BasicAuthLevel, and then press Enter.
    5. On the Edit menu, click Modify.
    6. In the Value data box, type 2, and then click OK.

    http://support.microsoft.com/kb/841215/en-us

    Monday, September 10, 2012 3:49 AM
  • Ehtan_Chan 

    I am a bit confused,

      Is open in explorer view directly related to Copy and Paste on SharePoint sites? 

    also if webdav is suppose to run, why are we killing its related svchost?

    Thanks,

    Chilly


    pfcjt@hotmail.com

    Hi Chilly Moon,

    For the first question,

    I always copy and paste in explorer. 

    For the second question,

    I don't sure that. Svchost maybe take a long time to run but nothing happens. Is the workaround effect?

    Thanks for your assistance.

    Wednesday, September 12, 2012 5:11 AM
  • i guess there might be some javascript on your SharePoint 2010 site prevent you from copy and paste;

    some relevant reference:

    http://www.ehow.com/how_6751328_control-copy-paste.html

    http://msdn.microsoft.com/en-us/library/bb250473(v=VS.85).aspx

    Saturday, September 15, 2012 1:19 AM
  • Ok.  I figured out the problem.  Seems to only affect those users who are on XP SP3 operating sytsem with IE7.

    There is not any Java preventing copy and paste, as this works with those users who have windows 7, IE8.

    Ok to Fix copy and paste I had to make sure the following settings were completed.

    IE 7 Settings to correct "Can't Copy and Paste in SharePoint" follow these steps:

      • Select the Tools | Internet Option… menu item
      • Click the Security Tab.  Select Trusted Sites Check
      • Click the Sites Button
      • Make sure your site is in the Trusted Zone.  If not add it. If so move on to next step

    Once out of the Sites area you are now back in the Security tab.

    1. Click the Custom Level button at the bottom.
    2. Scroll to Settings list and Mark the following settings:

    Downloads:

    • Enable the “File Download” radio button

    Miscellaneous:

    • Enable the “Don’t Prompt for Client Certificate Selection when no Certificates or only one certificate exists” radio button.
    • Enable the “Drag and drop or copy and paste files” radio button
    • Enable the “Launching Programs and Files in an IFRAME” radio button

    Scripting:

    • Enable the “Allow Programmatic Clipboard Access”
      1. Click the OK button to accept the changes in the Security Settings dialog window.
      2. Click Yes to accept the security settings.


    pfcjt@hotmail.com

    • Marked as answer by Chilly Moon Monday, September 17, 2012 2:37 PM
    Monday, September 17, 2012 2:34 PM