How to Delete Site collection using STSADM RRS feed

  • Question


    Hi All


    One of our site collections got corrupted, i would like to delete it, i tried using Central Administration but couldn’t.


    Can any body tell me how to do it using command prompt.





    Thursday, April 3, 2008 12:33 PM


All replies

  • Thursday, April 3, 2008 1:04 PM
  • Hi John

    I tried this but it says:
    The system cannot find the path specified. (Exception from HRESULT: 0x80070003) 

    The "Central Administration --> List Sitecollection" lists the URL, I have used, as an existing sitecollection.

    Is there an other way?

    Kind Regards
    Robert Gromek
    Thursday, March 5, 2009 2:58 PM
  • Hi John

    This was a temporary Sitecollection which I use to migrate (using import and export option of stsadm tool) a 6GB subsite tree to an other MOSS farm.
    After finishing the migration, I tried to delete the sitecollection using the Central Administration.
    Deleting finished afer a very long time but the sitecollection is still listed as existing sitecollecction.
    Now I can't browse it and there are no details (e.g. owner, sitecollection admin...) shown in the sitecollection list.

    So, I think, the deleting process itself has corrupted the sitecollection.

    Just deleting the content database is no option because this web contain another sitecollection which is still in use.

    Kind Regards
    Robert Gromek
    Friday, March 6, 2009 10:05 AM
  • Robert-

    I ran into this before...
    First of all, try running stsadm -o databaserepair -url http://theurl/that/you/are/trying/to/delete -databasename YourContentDBName

    If it returns <OrphanedObjects Count="0" />, then the site collection is gone from the content DB, but still referenced in the configuration database.  Remove the content DB in Central administration and then add it right back in, and the problem should go away.

    Worked for me!

    • Proposed as answer by Robert Gromek Tuesday, March 17, 2009 11:11 AM
    • Marked as answer by Mike Walsh FIN Wednesday, September 7, 2011 12:59 PM
    Monday, March 16, 2009 3:20 PM
  • It solves the problem

    Thank you

    Kind Regards
    Robert Gromek
    Tuesday, March 17, 2009 11:11 AM
  • Hello,

    I have got the same problem.

    I run the stsadm -o deletesite -url https://SERVERNAME/SITES/SITENAME and the result was

    The system cannot find the path specified. (Exception from HRESULT: 0x80070003)


    When I run stsadm -o databaserepair -url https://SERVERNAME/SITES/SITENAME -databasename CONTENTDBNAME it returns

    <OrphanedObjects Count="0" />


    What happens when i remove the content DB and add it Back?

    In the warning of removing Content Database there is "Caution: When you remove the content database, any sites listed in that content database are removed from the server farm, but the site data remains in the database" shown.

    What is with with the sites? Are they really removed from the server farm?





    Tuesday, May 18, 2010 10:30 AM