none
Infopath 2010 Web forms on Sharepoint 2010 keep timing out

    Question

  • I have changed the session state and data connection time outs to 48 hours.  My infopath web forms keep timing out if someone waits too long.  I have a lengthy Performance Evaluation form in Infopath and users pause to answer the phone or get distracted with other things and when they go back to the form it times out and they have to start over.  This is very bad since a performance review can contain lots of text that they have to reenter every time.

    Is there someplace else other than central administrator, infopath form services to change these values?  Does it require a reboot of the server to take effect?

    Please help...

    Friday, March 04, 2011 9:55 PM

Answers

  • Those settings you mentioned are not related to the SharePoint security timeout.  What you're experiencing is the BROWSER timeout for SharePoint, which of course affects browser forms, but it's not related to InfoPath.  It's a farm setting for all of SharePoint, and it's related to the browser security, not InfoPath forms.  Your users aren't hitting an InfoPath timeout; they are hitting a browser timeout.  The default is 30 minutes, and that's to protect your system from security breaches.  If you want to change it for people to fill out InfoPath forms, then you're going to have to change it for the entire farm, and it will affect all browser sessions unrelated to InfoPath.

    My recommendation is to provide a custom Save button that allows the user to Save progress along the way.

    I also definitely do not recommend manually editing web.config files.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force

    Sunday, March 06, 2011 7:32 AM

All replies

  • You should check about Timer job and Run now it.

     

    Sunday, March 06, 2011 3:20 AM
  • Try SharePoint Timeouts.. In the SharePoint Root directory, there is a web.config settings for the httpRuntime - executionTimeout, which is set to 6 minutes by default.. If your form times out after 6 minutes, this is the place to check.

    Although this link for MOSS 2007, its still valid for SharePoint 2010...

    http://www.sharepointassist.com/2009/08/24/changing-sharepoint-timeouts-execution-timeout/

    Also, check IIS and ASP.NET timeout settings.

    Nik

    • Proposed as answer by AprilLorDrake Tuesday, October 23, 2012 2:16 PM
    Sunday, March 06, 2011 5:34 AM
  • Those settings you mentioned are not related to the SharePoint security timeout.  What you're experiencing is the BROWSER timeout for SharePoint, which of course affects browser forms, but it's not related to InfoPath.  It's a farm setting for all of SharePoint, and it's related to the browser security, not InfoPath forms.  Your users aren't hitting an InfoPath timeout; they are hitting a browser timeout.  The default is 30 minutes, and that's to protect your system from security breaches.  If you want to change it for people to fill out InfoPath forms, then you're going to have to change it for the entire farm, and it will affect all browser sessions unrelated to InfoPath.

    My recommendation is to provide a custom Save button that allows the user to Save progress along the way.

    I also definitely do not recommend manually editing web.config files.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force

    Sunday, March 06, 2011 7:32 AM
  • I agree with Clayton here.

    Even though I have provided the option, better solution would be to create the form submission process like turbo-tax. While moving through the form views, you can save the information to the underlying database or sharepoint list or any other data source..

    Nik

    Monday, March 07, 2011 2:17 AM
  • Those settings you mentioned are not related to the SharePoint security timeout.  What you're experiencing is the BROWSER timeout for SharePoint, which of course affects browser forms, but it's not related to InfoPath.  It's a farm setting for all of SharePoint, and it's related to the browser security, not InfoPath forms.  Your users aren't hitting an InfoPath timeout; they are hitting a browser timeout.  The default is 30 minutes, and that's to protect your system from security breaches.  If you want to change it for people to fill out InfoPath forms, then you're going to have to change it for the entire farm, and it will affect all browser sessions unrelated to InfoPath.

    My recommendation is to provide a custom Save button that allows the user to Save progress along the way.

    I also definitely do not recommend manually editing web.config files.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force

    the Save solution doesn't work for me. i have the list trigger a Workflow on new item so if they Saved before completing the form the Workflow would bust. 6 minutes is far too short. people DO get distracted. my form isn't long enough to have it make sense to divide it up. i suppose i'll have to use the workaround to increase the timeout.
    Tuesday, October 23, 2012 2:08 PM
  • In the Clayton's solution, You will have to use a temporary list to save data until final save/submit button is hit. Remember to clean up temp data after final save.
    Friday, December 21, 2012 3:24 PM
  • So where do you configure this "BROWSER timeout for SharePoint" thing?
    Thursday, May 16, 2013 3:05 PM
  • So where do you configure this "BROWSER timeout for SharePoint" thing?

    There are so many smart people on this site, but nobody can give the correct answer.  That means people who replied to this posting are arzzes and should be removed from ever posting Replies again.  We don't need responses like this at all. EVER! It wastes all are time looking for a result/solution.


    Chris

    Thursday, July 18, 2013 1:39 PM
    • Proposed as answer by Levente Rög Monday, August 05, 2013 4:24 PM
    Monday, August 05, 2013 4:24 PM