none
Anonymous users haven't access to list/lib views and all content page - SharePoint 2010 RRS feed

Answers

  • The symptoms you are describing are definately the result of the site collection feature "Limited-access User permission lockdown mode" being activated.  Check the Site Collection Features list again.  Its on that list.  You'll need to not only deactivate that feature you'll also need to remove and reset anonymous access permission settings.  Applying anonymous access works differently if the lockdown feature is active.  So deactivating the feature is not enough to give anonymous users access to _layout pages again. You need to reset the permission settings too.


    Paul Stork SharePoint Server MVP
    Owner/Principal Architect: Don't Pa..Panic Consulting
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as 'answered' if this solves your problem.


    Friday, November 16, 2018 1:55 PM
  • Hi Morgan,

    In SharePoint 2010, the "ViewFormPagesLockdown" feature is hidden, we need to use PowerShell to disable it.

    If the feature is disable, you need to check the master page of the site collection and make sure it is checked in and approved, as the below:

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, November 19, 2018 8:26 AM
    Moderator

All replies

  • The symptoms you are describing are definately the result of the site collection feature "Limited-access User permission lockdown mode" being activated.  Check the Site Collection Features list again.  Its on that list.  You'll need to not only deactivate that feature you'll also need to remove and reset anonymous access permission settings.  Applying anonymous access works differently if the lockdown feature is active.  So deactivating the feature is not enough to give anonymous users access to _layout pages again. You need to reset the permission settings too.


    Paul Stork SharePoint Server MVP
    Owner/Principal Architect: Don't Pa..Panic Consulting
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as 'answered' if this solves your problem.


    Friday, November 16, 2018 1:55 PM
  • Hi Morgan,

    In SharePoint 2010, the "ViewFormPagesLockdown" feature is hidden, we need to use PowerShell to disable it.

    If the feature is disable, you need to check the master page of the site collection and make sure it is checked in and approved, as the below:

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, November 19, 2018 8:26 AM
    Moderator
  • Indeed, I need to remove the anonymous access (change to "nothing") and re-give access (change to "Entire web site), then it's works! Saved me lot of time. Thanks a lot!
    Monday, November 19, 2018 11:45 AM