Volume Shadow Copy Service error RRS feed

  • Question

  • Event 12292 -

    Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {463948d2-035d-4d1d-9bfc-473fece07dab} [0x80070005, Access is denied.

    Event 13 -

    Volume Shadow Copy Service information: The COM Server with CLSID {463948d2-035d-4d1d-9bfc-473fece07dab} and name HWPRV cannot be started. [0x80070005, Access is denied.

    Event 12289 -

    Volume Shadow Copy Service error: Unexpected error DeviceIoControl(\\?\Volume{869ecff5-0cc6-11e2-93f1-00155d03f90d} - 0000000000000064,0x0053c008,000000E100014880,0,000000E100015890,4096,[0]).  hr = 0x80070057, The parameter is incorrect.

    I'm receiving these errors on both virtual and physical installs of Windows Server Standard 2012.  The VSS seems to work on the local drive, but fails for iSCSI connected drives.  Any thoughts?

    Wednesday, October 3, 2012 9:25 PM


All replies

  • Hi,

    Sometimes the event 12292 could be caused by third party VSS provider. So please first run:

    vssadmin list writers

    Check if there is any third party VSS provider listed. If so, you could test to backup and delete it from HKLM\System\CurrentControlSet\Services\Vss\Providers to see if it will get to work on iSCSI drives.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Tuesday, October 9, 2012 8:15 AM
  • Please try the following fix for configuring the credentials:


    Microsoft Partner

    • Proposed as answer by rEMOTE_eVENT Wednesday, October 10, 2012 10:53 AM
    • Marked as answer by dbiz Friday, October 12, 2012 5:48 PM
    Tuesday, October 9, 2012 9:32 PM
  • Thanks r_EMOTE_eVENT,

    This helped me track dow the issue.

    • Edited by dbiz Friday, October 12, 2012 5:49 PM problem solved
    Friday, October 12, 2012 3:52 PM
  • Thanks a lot ... you made my day!

    A question I'd ask Microsoft as this is very troublesome - why is there no hint or info on the MS download pages or in the installation program?

    In fact you install an update like dozens of others - but afterwards, the complete VSS system is hosed until you configure the creds (in case you knew) or uninstall the hotfix. It renders your backup software unusable (Symantec Backup Exec for example, except you are able to dedicatedly choose a VSS provider) and breaks other VSS-based stuff like NetApp SnapVaults.

    I also see problems in server farms deploying the update - especially the "set the credentials" part. And updating the credentials when regular password changes occur.

    Nevertheless you spared me a lot of grief in a storage project, thanks again :-)

    Thursday, October 25, 2012 7:00 PM
  • I received a similar error. I was receiving this error on a SBS 2011 server . . .

    Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class CLSID { 423bbc78-9b20-4bbe-a967-b63ec43bc7f3} [0x80040154, Class not registered].

    Operation: Creating instance of hardware provider, Obtain a callable interface for this provider, List interface for all providers supporting this context, Get Show Copy Properties . . .

     This one was tough to troubleshoot but here is what fixed it for me. I hope this helps. 

    Step One: Start a backup. Go into  Event Viewer and see if there are any VSS error logs. In my situation there were hundreds of them. This is what my VSS error log said.

    Step Two: Open a CMD prompt as an administrator. Run this command:  vssadmin list writers . Check your results. If all of your VSS writers say Stable – No error, then your VSS writers are fine. If your VSS writers are failing or corrupting you may need to reboot the server. In my case, the VSS writers were fine.

    Type this command: vssadmin list providers . This will show the VSS writers capable of taking a system snapshot when backing up your sbs 2011. Take note of how many VSS providers you have.  Next type: diskshadow  . Once that comes up type:  list providers .  You will now see the hardware ID for each VSS writer that you have. 

    Step Three: Take note of what your VSS error said in your event log. For mine I noticed that a VSS writer with the ID of { 423bbc78-9b20-4bbe-a967-b63ec43bc7f3} was giving me lots of errors. I matched up the ID number of the event log to the ID number of command prompt output. I noticed that the VSS Lifeline HW Provider was the writer that was giving me all my grief.

    Step Four: Since I didn’t need that VSS writer, I decided to remove that writer. Here is how to remove your troublesome VSS writer.  Please be advised that you do this at your own risk! Incorrect use of the Windows Registry could cause your operating system to crash. Be sure to back up your Registry before deleting these keys.

    • Open the Registry Editor (Start -> Run -> enter “regedit”, hit enter)
    • Navigate to the this registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Providers
    • Delete the registry tree with the GUID referenced in the event log and CMD prompt that was giving you issues.

    Go back to command prompt and type in diskshadow and then list providers. The VSS writer that was faulty should now be gone. 

    Type exit in command prompt to close diskshadow.

    • {optional but recommended} Reboot the server.

    Step Five: I tried starting a backup with Acronis and  it worked!! After a couple successful backups with Acronis I decided to try Windows Server Backup.  I started a backup and to my amazement the backup went through successfully! I have run numerous backups since and they have gone through without a hitch! 

    Source: http://techspeeder.com/2014/09/23/volume-shadow-copy-service-error-creating-the-shadow-copy-provider-com-class-with-clsid/

    Tuesday, September 23, 2014 10:41 PM